File:  [cvs.NetBSD.org] / pkgsrc / net / owncloudclient / Makefile
Revision 1.51: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:29 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.51 2025/01/23 23:27:29 riastradh Exp $

DISTNAME=	ownCloud-2.7.6.3261
PKGNAME=	${DISTNAME:S/ownCloud/owncloudclient/1}
PKGREVISION=	16
CATEGORIES=	net
MASTER_SITES=	https://download.owncloud.com/desktop/ownCloud/stable/${PKGVERSION_NOREV}/source/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://owncloud.com/
COMMENT=	Synchronization program for ownCloud
LICENSE=	gnu-gpl-v2

BROKEN=		"Needs to be updated, for qt5 compatibility"

USE_CMAKE=	yes
USE_LANGUAGES=	c c++

CMAKE_CONFIGURE_ARGS+=	-DSYSCONF_INSTALL_DIR=${PKG_SYSCONFDIR}
CMAKE_CONFIGURE_ARGS+=	-DBUILD_SHELL_INTEGRATION=OFF
CMAKE_CONFIGURE_ARGS+=	-DBUILD_TESTING=OFF

EGDIR=		${PREFIX}/share/examples/owncloudclient
CONF_FILES=	${EGDIR}/sync-exclude.lst \
		${PKG_SYSCONFDIR}/ownCloud/sync-exclude.lst

OWN_DIRS+=	${PKG_SYSCONFDIR}/ownCloud

.include "../../mk/bsd.prefs.mk"
BUILDLINK_API_DEPENDS.sqlite3+=	sqlite3>=3.9.0
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/extra-cmake-modules/buildlink3.mk"
.if ${OPSYS} != "Linux"
.  include "../../devel/libinotify/buildlink3.mk"
.endif
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../security/qt5-qtkeychain/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>