[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / openvpn

Annotation of pkgsrc/net/openvpn/Makefile, Revision 1.78

1.78    ! adam        1: # $NetBSD: Makefile,v 1.77 2020/05/22 10:56:30 adam Exp $
1.1       wulf        2:
1.49      manu        3: DISTNAME=      ${OPENVPN_DISTNAME}
1.8       jlam        4: CATEGORIES=    net
1.49      manu        5: MASTER_SITES=  ${OPENVPN_MASTER_SITES}
1.53      adam        6: EXTRACT_SUFX=  .tar.xz
1.1       wulf        7:
1.15      jlam        8: MAINTAINER=    pkgsrc-users@NetBSD.org
1.74      rillig      9: HOMEPAGE=      https://openvpn.net/
1.8       jlam       10: COMMENT=       Easy-to-use SSL VPN daemon
1.29      wiz        11: LICENSE=       gnu-gpl-v2
1.1       wulf       12:
1.49      manu       13: PKG_DESTDIR_SUPPORT=   user-destdir
                     14:
1.41      adam       15: USE_LIBTOOL=           yes
1.62      adam       16: USE_TOOLS+=            grep:run pkg-config
1.8       jlam       17: GNU_CONFIGURE=         yes
1.41      adam       18: CONFIGURE_ARGS+=       --disable-debug
                     19: CONFIGURE_ARGS+=       --disable-dependency-tracking
                     20: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
                     21:
1.8       jlam       22: TEST_TARGET=           check
                     23:
                     24: PKG_SYSCONFSUBDIR=     openvpn
                     25: EGDIR=                 ${PREFIX}/share/examples/${PKGBASE}
                     26: RCD_SCRIPTS=           openvpn
                     27:
1.41      adam       28: INSTALLATION_DIRS+=    ${EGDIR}/config
                     29: INSTALLATION_DIRS+=    ${EGDIR}/keys
                     30: INSTALLATION_DIRS+=    ${EGDIR}/scripts
1.1       wulf       31:
1.62      adam       32: SMF_METHODS=   openvpn
1.54      wiedi      33:
1.43      cheusov    34: .include "../../mk/bsd.prefs.mk"
                     35:
                     36: PKG_GROUPS=            ${OPENVPN_GROUP}
                     37: PKG_USERS=             ${OPENVPN_USER}:${OPENVPN_GROUP}
1.70      rillig     38: PKG_GECOS.${OPENVPN_USER}= OpenVPN\ server\ user
1.43      cheusov    39:
1.51      adam       40: MESSAGE_SUBST+=        OPENVPN_PLUGINSDIR=${PREFIX}/${OPENVPN_PLUGINSDIR}
1.49      manu       41:
                     42: post-install:
1.71      adam       43:        ${RUN} cd ${WRKSRC}/sample/sample-config-files; for file in *; do \
1.49      manu       44:                ${INSTALL_DATA} $$file ${DESTDIR}${EGDIR}/config;          \
1.8       jlam       45:        done
1.71      adam       46:        ${RUN} cd ${WRKSRC}/sample/sample-scripts; for file in *; do       \
1.49      manu       47:                ${INSTALL_DATA} $$file ${DESTDIR}${EGDIR}/scripts;         \
1.8       jlam       48:        done
1.71      adam       49:        ${RUN} cd ${WRKSRC}/sample/sample-keys; for file in *; do          \
1.49      manu       50:                ${INSTALL_DATA} $$file ${DESTDIR}${EGDIR}/keys;            \
1.8       jlam       51:        done
                     52:
1.30      spz        53: .include "options.mk"
1.49      manu       54: .include "../../net/openvpn/Makefile.common"
1.41      adam       55:
                     56: # OpenVPN 2.x has a shared module "plugin" architecture that allows
                     57: # inserting callbacks into the server for various tasks.
                     58: DL_AUTO_VARS=          yes
                     59: .include "../../mk/dlopen.buildlink3.mk"
                     60:
                     61: .if ${OPSYS} == "SunOS"
                     62: .include "../../net/solaris-tap/buildlink3.mk"
                     63: .endif
1.62      adam       64: .include "../../archivers/lz4/buildlink3.mk"
1.41      adam       65: .include "../../archivers/lzo/buildlink3.mk"
                     66: .include "../../security/openssl/buildlink3.mk"
                     67: .include "../../mk/pthread.buildlink3.mk"
1.1       wulf       68: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>