File:  [cvs.NetBSD.org] / pkgsrc / net / openh323 / Makefile
Revision 1.37: download - view: text, annotated - select for diffs
Sat Mar 4 21:30:22 2006 UTC (18 years, 9 months ago) by jlam
Branches: MAIN
CVS tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1, HEAD
Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.37 2006/03/04 21:30:22 jlam Exp $

DISTNAME=	openh323-v1_15_2-src
PKGNAME=	openh323-1.15.2
PKGREVISION=	1
CATEGORIES=	net
MASTER_SITES=	http://www.voxgratia.org/releases/
EXTRACT_SUFX=	-tar.gz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.openh323.org/
COMMENT=	Open H.323 library

WRKSRC=			${WRKDIR}/openh323
USE_TOOLS+=		gmake tar
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	PWLIBDIR=${PREFIX:Q}

BUILD_TARGET=		opt apps
MAKE_ENV+=		PWLIBDIR=${PREFIX}/share/pwlib OPENH323DIR=${WRKSRC:Q}
MAKE_ENV+=		SYSLIBDIR=${PREFIX}/lib

post-extract:
	cd ${WRKDIR}; ${TAR} -xf ${DISTNAME:S/$/-tar/}

post-patch:
	cd ${WRKSRC}/include; ${LN} -s . openh323

# override the openh323 install - it uses cp -d, and isn't libtool-aware
do-install:
	cd ${WRKSRC}/src; ${MAKE_ENV} ${GMAKE} install
	${INSTALL_DATA_DIR} ${PREFIX}/include/openh323
	cd ${WRKSRC}/include;				\
		for f in \*.h ; \
			do ${INSTALL_DATA} $$f ${PREFIX}/include/openh323; done
	cd ${WRKSRC}; ${INSTALL_DATA} version.h ${PREFIX}/include/openh323
	cd ${WRKSRC}/samples/simple; ${MAKE_ENV} ${GMAKE} install
	${INSTALL_DATA_DIR} ${PREFIX}/share/openh323
	cd ${WRKSRC}; ${INSTALL_DATA} openh323u.mak ${PREFIX}/share/openh323
	cd ${WRKSRC}/plugins; ${GMAKE} install

.include "../../devel/pwlib/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>