[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / nsd

File: [cvs.NetBSD.org] / pkgsrc / net / nsd / Makefile (download)

Revision 1.21, Tue Mar 16 00:03:15 2004 UTC (20 years ago) by itojun
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.20: +2 -3 lines

upgrade to 2.0.1.

NSD 2.0.1 release notes:

BUG FIXES:
	 - Queries for QTYPE DS (DNSSEC) were not handled correctly in
	   certain cases.
	 - Partial support for unknown RRs.  Known RR types with
	   unknown RR data format is not yet supported.
	 - Bug #75: Fixed bad error message when nsdc update is run for
	   the first time.
	 - Bug #78: Multiple zones, each with include directives, are
	   now compiled correctly.

# $NetBSD: Makefile,v 1.21 2004/03/16 00:03:15 itojun Exp $

DISTNAME=	nsd-2.0.1
CATEGORIES=	net
MASTER_SITES=	http://www.nlnetlabs.nl/downloads/nsd/

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://www.nlnetlabs.nl/nsd/index.html
COMMENT=	Authoritative-only DNS server

BUILD_DEFS+=	USE_INET6

.include "../../mk/bsd.prefs.mk"

GNU_CONFIGURE=	yes
USE_BUILDLINK2=	yes

CONFIGURE_ARGS=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=--enable-bind8-stats
CONFIGURE_ARGS+=--with-libwrap=${BUILDLINK_PREFIX.tcp_wrappers}
.if !defined(USE_INET6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
.if ${OPSYS} == "NetBSD"
CONFIGURE_ARGS+=--with-pidfile=/var/run/nsd.pid
CONFIGURE_ARGS+=--with-user=named
CONFIGURE_ARGS+=--with-namedxfer=/usr/libexec/named-xfer
.endif

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/nsd
	${INSTALL_DATA_DIR} ${PREFIX}/share/nsd/contrib
.for FILE in README RELNOTES DIFFERENCES LICENSE NSD-DATABASE TODO
	${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/share/nsd
.endfor
.for FILE in README build-nsdzones.pl build-nsdzones.pl.README example-plugin.c
	${INSTALL_DATA} ${WRKSRC}/contrib/${FILE} ${PREFIX}/share/nsd/contrib
.endfor

.include "../../security/tcp_wrappers/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"