[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / nmap

Annotation of pkgsrc/net/nmap/Makefile, Revision 1.62

1.62    ! adrianp     1: # $NetBSD: Makefile,v 1.61 2008/06/20 01:09:31 joerg Exp $
1.41      salo        2: #
1.1       hubertf     3:
1.62    ! adrianp     4: DISTNAME=      nmap-4.76
1.8       wiz         5: CATEGORIES=    net security
1.59      adrianp     6: MASTER_SITES=  http://download.insecure.org/nmap/dist/
1.20      salo        7: EXTRACT_SUFX=  .tar.bz2
1.3       hubertf     8:
1.59      adrianp     9: MAINTAINER=    adrianp@NetBSD.org
1.56      wiz        10: HOMEPAGE=      http://insecure.org/nmap/
1.14      wiz        11: COMMENT=       Network/port scanner with OS detection
1.1       hubertf    12:
1.32      jmmv       13: PKG_INSTALLATION_TYPES=        overwrite pkgviews
1.61      joerg      14: PKG_DESTDIR_SUPPORT=   user-destdir
1.32      jmmv       15:
1.57      salo       16: BUILDLINK_API_DEPENDS.libpcap= libpcap>=0.9.4
                     17: BUILDLINK_API_DEPENDS.libpcre= libpcre>=6.7
                     18:
1.52      salo       19: GNU_CONFIGURE=         yes
1.40      adam       20: USE_LANGUAGES=         c c++
1.45      salo       21: USE_LIBTOOL=           yes
1.52      salo       22: USE_TOOLS+=            gmake
1.60      adrianp    23: PLIST_SRC=             ${WRKDIR}/.PLIST_SRC
                     24:
                     25: .include "options.mk"
1.45      salo       26:
1.19      salo       27: CONFIGURE_ARGS+=       --with-libpcap=${BUILDLINK_PREFIX.libpcap}
1.53      rillig     28: CONFIGURE_ARGS+=       --with-libpcre=${BUILDLINK_PREFIX.pcre}
1.28      salo       29: CONFIGURE_ARGS+=       --with-openssl=${BUILDLINK_PREFIX.openssl}
1.7       agc        30:
                     31: .include "../../mk/bsd.prefs.mk"
                     32:
1.15      abs        33: .if ${OPSYS} == "SunOS" || ${OPSYS} == "Linux"
1.7       agc        34: MAKE_ENV+=     CPPFLAGS=""
                     35: .endif
1.1       hubertf    36:
1.47      rillig     37: # The SunPro C++ compiler does not understand __FUNCTION__, as well as
                     38: # __func__. So __FILE__ is the nearest replacement.
                     39: .include "../../mk/compiler.mk"
                     40: .if !empty(PKGSRC_COMPILER:Msunpro)
                     41: CFLAGS.SunOS+= -D__FUNCTION__=__FILE__
                     42: .endif
                     43:
1.54      rillig     44: .if empty(PKGSRC_COMPILER:Mgcc)
                     45: # The Makefile uses a hard-coded option -MM to get the dependencies, which
                     46: # is only understood by the GNU compiler. For a normal build the dependen-
                     47: # cies are not needed anyway, only when patching files and fixing bugs.
                     48: pre-build:
1.57      salo       49:        ${ECHO} "# ignored" > ${WRKSRC}/makefile.dep
1.54      rillig     50: .endif
                     51:
1.60      adrianp    52: post-build:
                     53:        ${CP} ${PKGDIR}/PLIST ${WRKDIR}/.PLIST_SRC
                     54:
1.32      jmmv       55: .include "../../devel/pcre/buildlink3.mk"
                     56: .include "../../net/libpcap/buildlink3.mk"
                     57: .include "../../security/openssl/buildlink3.mk"
1.28      salo       58:
1.1       hubertf    59: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>