File:  [cvs.NetBSD.org] / pkgsrc / net / nextcloud-client / Makefile
Revision 1.18: download - view: text, annotated - select for diffs
Thu Jan 23 23:27:29 2025 UTC (8 weeks ago) by riastradh
Branches: MAIN
CVS tags: HEAD
devel/extra-cmake-modules: Use buildlink3.mk, not TOOL_DEPENDS.

This one is borderline: should it be BUILD_DEPENDS or TOOL_DEPENDS?
It doesn't appear to vary depending on the build environment, so it
doesn't meaningfully describe the cross-builder vs the target system.
It is used only at build-time, but it doesn't have any native
executables -- they're just source code cmake scripts.

For now, it is convenient to use a buildlink3.mk file because this
enables us to explicitly expose only files under share/ECM/ -- and
not other random files installed in the prefix -- via buildlink3 to
keep dependent package builds clean.  Eventually we should have the
same mechanism for TOOL_DEPENDS but that day has not yet come.

This change creates a new use of BUILDLINK_DEPMETHOD build for
extra-cmake-modules, which is a priori risky.  Fortunately,
extra-cmake-modules has no libraries, so this is unlikely to cause
trouble.

# $NetBSD: Makefile,v 1.18 2025/01/23 23:27:29 riastradh Exp $
#

DISTNAME=	nextcloud-client-3.13.2
PKGREVISION=	3
CATEGORIES=	net
MASTER_SITES=	${MASTER_SITE_GITHUB:=nextcloud/}
GITHUB_PROJECT=	desktop
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://nextcloud.com/clients
COMMENT=	Nextcloud Desktop Client
LICENSE=	gnu-gpl-v2

USE_LANGUAGES=	c c++
USE_TOOLS+=	cmake pkg-config

USE_CXX_FEATURES+=	c++17 filesystem

PKG_SYSCONFSUBDIR=	Nextcloud

EGDIR=		${PREFIX}/share/examples/Nextcloud
CONF_FILES=	${EGDIR}/sync-exclude.lst ${PKG_SYSCONFDIR}/sync-exclude.lst

CMAKE_CONFIGURE_ARGS+=	-DSYSCONF_EGDIR:PATH=${EGDIR}
CMAKE_CONFIGURE_ARGS+=	-DSYSCONF_INSTALL_DIR:PATH=${PKG_SYSCONFDIR}

CMAKE_CONFIGURE_ARGS+=	-DBUILD_TESTING:BOOL=OFF

# used as tool during configure
CMAKE_CONFIGURE_ARGS+=	-DSVG_CONVERTER:FILEPATH=${BUILDLINK_DIR}/bin/rsvg-convert

# cmake finds these even when we have not depended on them
CMAKE_CONFIGURE_ARGS+=	-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
CMAKE_CONFIGURE_ARGS+=	-DCMAKE_DISABLE_FIND_PACKAGE_PdfLatex:BOOL=TRUE
CMAKE_CONFIGURE_ARGS+=	-DCMAKE_DISABLE_FIND_PACKAGE_Sphinx:BOOL=TRUE

# ignore warns about xdr functions in a library
LDFLAGS+=	-Wl,--no-fatal-warnings

AUTO_MKDIRS=	yes

.include "../../archivers/karchive/buildlink3.mk"
.include "../../databases/shared-mime-info/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../devel/cmake/build.mk"
.include "../../devel/extra-cmake-modules/buildlink3.mk"
.include "../../devel/kio/buildlink3.mk"
.include "../../devel/libinotify/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/librsvg/tool.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../security/qt5-qtkeychain/buildlink3.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../x11/qt5-qtdeclarative/buildlink3.mk"
.include "../../x11/qt5-qtlocation/buildlink3.mk"
.include "../../x11/qt5-qtquickcontrols2/buildlink3.mk"
.include "../../x11/qt5-qtsvg/buildlink3.mk"
.include "../../x11/qt5-qtwebchannel/buildlink3.mk"
.include "../../x11/qt5-qtwebengine/buildlink3.mk"
.include "../../x11/qt5-qtwebsockets/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>