[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / ncftp3

File: [cvs.NetBSD.org] / pkgsrc / net / ncftp3 / Makefile (download)

Revision 1.5, Tue Apr 24 20:39:37 2001 UTC (23 years ago) by zuntum
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH001
Changes since 1.4: +3 -3 lines

Update ncftp3 to version 3.0.3:

Sorry for dirty-looking list of changes but fmt didn't help much and I don't want to spend whole day
reworking it..

o Preference options can now be "file" completed on the command line with the set/show/prefs commands.
o NcFTP directory changes are now always one subdirectory at a time, for better portability on remote servers with non-UNIX filesystems.
o NcFTP tries to maintain the current directory itself, like /bin/ksh and Bash do, which means that symlinks remain part of the current working directory when possible. For example, on ftp.freesoftware.com if your current directory is /pub and you "cd linux", NcFTP will use /pub/linux as the current directory, even though the canonical directory on the server is /.0/linux. This is also useful for things like Linux's Kernel.org mirrors, so if you bgget a kernel.tar.gz file the "virtual" current directory is used rather than a specific-machine's layout.
o Mac OS X support added. No Mac or Aqua specific features yet.
o NcFTP now has an option to automatically use ASCII mode for transfers if the file's extension corresponds to a textual data file type.
o Using homegrown gl_getpass in place of getpass() and getpassphrase for all platforms, not just Windows..
o Incorporating a few getline suggestions from Ken Cox.
o Configuration tweaks for Cygwin port.
o Removed some arbitrary buffer size limits.
o Lint fixes.
o Curses configuration fixes for HP-UX.
o Shell utilities now have a "-bb" flag which is just like "-b" only the job is submitted only (and no ncftpbatch is spawned).
o More problems fixed with interaction with Windows FTP servers.
o Better compatibility with non-standard extensions to the FTP which allow for TCP Large Windows (specifically, SITE BUFSIZE).
o Win32 port had a bug which leaked file handles.
o Miscellaneous Win32 port fixes.
o Changed default anonymous password to NcFTP@, since no one really cares any more about using a real e-mail address.
o Bug fixed where some types of servers' features might not be queried.
o Fixed some inconsistencies with the -a and -A flags among NcFTP and the shell utilities. "-a" is now ASCII mode across the board, and "-A" is the flag to use for append mode (which not many people use anyway).
o Bug fixed where the flag for delete after upload (-DD) was being ignored.
o You can now do "set yes-i-know-about-NcFTPd yes" from a NcFTP prompt to get it to quit plugging NcFTPd every 7th time you run the program.
o Like the system-wide /etc/ncftp.firewall and /etc/ncftp.firewall.fixed files for global preferences, there is now the equivalent for regular preference files (/etc/ncftp.prefs_v3 and /etc/ncftp.prefs_v3.fixed).
o The ncftpbatch spool files now support some additional options for sending additional FTP commands. The options are called "pre-command", "post-command", and "per-file-command". This is useful if you need to send some odd SITE command before transfer, for example.
o Similarly, ncftpget and ncftpput have new -W/-X/-Y switches so you can send pre/each/post commands. (i.e. "-W SITE MY_WEIRD_IBM_MAINFRAME_OPTION").
o Bug fixed where NcFTP was not taking advantage of re-using a currently open host when exiting and launching ncftpbatch. If you bgget a file from within NcFTP, then exit while the host is still connected, ncftpbatch is supposed to inherit that existing context without having to reopen the host.
o When using a URL with ncftpget, you can do "-a" to have it use ASCII. Prior versions forced to you use the little-known URL syntax to specify ASCII mode (btw, example of that is "ftp://ftp.foo.com/pub/README.TXT;a")
o Bug fixed where our handling of the TCP_NODELAY option was not getting enabled.
o A few tweaks for C++ compatibility.

# $NetBSD: Makefile,v 1.5 2001/04/24 20:39:37 zuntum Exp $

DISTNAME=	ncftp-3.0.3-src
PKGNAME=	ncftp3-3.0.3
CATEGORIES=	net
MASTER_SITES=	ftp://ftp.ncftp.com/ncftp/

MAINTAINER=	zuntum@netbsd.org
HOMEPAGE=	http://www.ncftp.com/
COMMENT=	FTP replacement with advanced user interface

DEPENDS+=	ncurses>=5.1:../../devel/ncurses

WRKSRC=		${WRKDIR}/${DISTNAME:S/-src//}
GNU_CONFIGURE=	yes

post-patch:
	@${MV} ${WRKSRC}/ncftp/pref.h ${WRKSRC}/ncftp/pref.h.in
	@${SED} -e "s:/etc/ncftp.firewall:${PREFIX}/etc/ncftp.firewall:" \
		< ${WRKSRC}/ncftp/pref.h.in > ${WRKSRC}/ncftp/pref.h

.include "../../mk/bsd.pkg.mk"