[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / nagios-plugins

File: [cvs.NetBSD.org] / pkgsrc / net / nagios-plugins / Makefile (download)

Revision 1.35, Wed Feb 12 23:18:23 2014 UTC (10 years, 2 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.34: +2 -2 lines

Recursive PKGREVISION bump for OpenSSL API version bump.

# $NetBSD: Makefile,v 1.35 2014/02/12 23:18:23 tron Exp $
#

PKGREVISION=	8
CATEGORIES=	net sysutils

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://sourceforge.net/projects/nagiosplug/
COMMENT=	Nagios plugins
LICENSE=	gnu-gpl-v2

PKG_DESTDIR_SUPPORT=	destdir

.include "../../net/nagios-plugins/Makefile.common"

.include "../../mk/bsd.prefs.mk"

USE_TOOLS+=	perl:run

PKG_GROUPS+=	${NAGIOS_GROUP}
BUILD_DEFS+=	${NAGIOS_GROUP}

CONFIGURE_ARGS+= --without-pgsql --without-mysql \
		--without-smbclient-command --without-snmpget-command \
		--without-snmpgetnext-command --without-fping-command

SPECIAL_PERMS+=	${PREFIX}/libexec/nagios/check_icmp ${SETUID_ROOT_PERMS}
SPECIAL_PERMS+=	${PREFIX}/libexec/nagios/check_dhcp ${SETUID_ROOT_PERMS}

PLIST_VARS+=	linux sunos NetBSD
.if ${OPSYS} == "Linux"
PLIST.linux=	yes
.elif ${OPSYS} == "SunOS"
PLIST.sunos=	yes
.elif ${OPSYS} == "NetBSD"
PLIST.NetBSD=	yes
.endif

.if ${OPSYS} == "NetBSD"
CONFIGURE_ARGS+=	--with-df-command="/bin/df -Pklt nokernfs,procfs,fdesc"
SPECIAL_PERMS+=	${PREFIX}/libexec/nagios/check_ide_smart \
		${REAL_ROOT_USER} ${NAGIOS_GROUP} 4551
.endif

# required to enable large file support on Solaris
.if ${OPSYS} == "SunOS"
CPPFLAGS_LFS!=		getconf LFS_CFLAGS
MAKE_ENV+=		CPPFLAGS_LFS=${CPPFLAGS_LFS:Q}
.endif
LIBS.SunOS+=	-lm

#DEPENDS+=	nagios-base-*:../../net/nagios-base

.if !exists(/usr/bin/ssh)
DEPENDS+=	{ssh{,6}-[0-9]*,openssh-[0-9]*}:../../security/openssh
.endif

.if (!exists(/usr/bin/dig) && !exists(/usr/sbin/dig)) || \
    (!exists(/usr/bin/nslookup) && !exists(/usr/sbin/nslookup))
DEPENDS+=	bind-[0-9]*:../../net/bind96
.endif

.include "../../security/openssl/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"