[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / mikutter

Annotation of pkgsrc/net/mikutter/Makefile, Revision 1.45

1.45    ! obache      1: # $NetBSD: Makefile,v 1.44 2012/04/21 09:52:19 obache Exp $
1.1       obache      2: #
                      3:
1.45    ! obache      4: DISTNAME=      mikutter.0.1.0.772
1.1       obache      5: PKGNAME=       ${RUBY_PKGPREFIX}-${DISTNAME:S/./-/}
                      6: CATEGORIES=    net
                      7: MASTER_SITES=  http://mikutter.hachune.net/bin/
                      8:
                      9: MAINTAINER=    obache@NetBSD.org
                     10: HOMEPAGE=      http://mikutter.hachune.net/
1.21      obache     11: COMMENT=       Simply, powerfully, and moefully twitter client
1.1       obache     12: LICENSE=       gnu-gpl-v3
                     13:
                     14: PKG_DESTDIR_SUPPORT=   user-destdir
                     15:
1.39      obache     16: RUBY_VERSION_SUPPORTED=        192 193
1.38      obache     17:
1.1       obache     18: .include "../../lang/ruby/rubyversion.mk"
                     19:
                     20: DEPENDS+=      xdg-utils-[0-9]*:../../misc/xdg-utils
1.7       obache     21: DEPENDS+=      ${RUBY_PKGPREFIX}-hmac>=0.4.0:../../security/ruby-hmac
1.27      obache     22: DEPENDS+=      ${RUBY_PKGPREFIX}-gnome2-gtk>=1.0.0:../../x11/ruby-gnome2-gtk
1.45    ! obache     23: DEPENDS+=      ${RUBY_PKGPREFIX}-oauth>=0.4.6:../../security/ruby-oauth
1.7       obache     24: # need included escape.rb
                     25: #DEPENDS+=     ${RUBY_PKGPREFIX}-escape-[0-9]*:../../textproc/ruby-escape
1.1       obache     26: DEPENDS+=      ${RUBY_PKGPREFIX}-memoize>=1.3.1:../../devel/ruby-memoize
1.9       obache     27: DEPENDS+=      ${RUBY_PKGPREFIX}-bsearch>=1.5:../../devel/ruby-bsearch
1.1       obache     28: DEPENDS+=      ${RUBY_PKGPREFIX}-httpclient-[0-9]*:../../www/ruby-httpclient
1.27      obache     29: DEPENDS+=      ${RUBY_PKGPREFIX}-addressable>=2.2.6nb1:../../net/ruby-addressable
1.37      obache     30: # notify-send
1.1       obache     31: DEPENDS+=      libnotify-[0-9]*:../../sysutils/libnotify
                     32:
1.29      taca       33: RUBY_JSON_REQD=        1.5.1
1.1       obache     34: WRKSRC=                ${WRKDIR}/mikutter
                     35: USE_LANGUAGES= # none
                     36: USE_TOOLS+=    pax
                     37:
                     38: REPLACE_RUBY=  mikutter.rb
                     39: REPLACE_RUBY_DIRS=     core
                     40: .include "../../lang/ruby/replace.mk"
                     41:
                     42: INSTALLATION_DIRS+=    bin share/doc/mikutter share/applications share/mikutter
                     43:
                     44: do-build:
1.10      obache     45:        cd ${WRKSRC}/core/lib && \
1.45    ! obache     46:                ${RM} -rf json* hmac*.rb memoize.rb oauth* ruby-bsearch-* addressable && \
1.1       obache     47:        ${SED} -e 's,@PREFIX@,${PREFIX},g' < ${FILESDIR}/desktop.in > ${WRKDIR}/desktop
                     48:        ${SED} -e 's,@PREFIX@,${PREFIX},g' < ${FILESDIR}/mikutter.sh.in > ${WRKDIR}/mikutter.sh
                     49:
                     50: do-install:
                     51:        ${INSTALL_SCRIPT} ${WRKSRC}/mikutter.rb ${DESTDIR}${PREFIX}/share/mikutter
1.9       obache     52:        cd ${WRKSRC} && pax -rwpp -s '/.*\.orig//' core plugin ${DESTDIR}${PREFIX}/share/mikutter
1.1       obache     53:        ${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/mikutter
                     54:        ${INSTALL_SCRIPT} ${WRKDIR}/mikutter.sh ${DESTDIR}${PREFIX}/bin/mikutter
                     55:        ${INSTALL_DATA} ${WRKDIR}/desktop ${DESTDIR}${PREFIX}/share/applications/mikutter.desktop
                     56:
1.29      taca       57: .include "../../lang/ruby/json.mk"
1.1       obache     58: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     59: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>