[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / libtorrent

Annotation of pkgsrc/net/libtorrent/Makefile, Revision 1.43

1.43    ! tron        1: # $NetBSD: Makefile,v 1.42 2011/11/07 13:10:31 hans Exp $
1.1       adam        2:
1.39      tron        3: DISTNAME=      libtorrent-0.12.9
1.1       adam        4: CATEGORIES=    net
1.20      tron        5: MASTER_SITES=  ${HOMEPAGE:=downloads/}
1.1       adam        6:
1.28      tron        7: OWNER=         tron@NetBSD.org
1.1       adam        8: HOMEPAGE=      http://libtorrent.rakshasa.no/
                      9: COMMENT=       BitTorrent library written in C++ for *nix
1.30      tron       10: LICENSE=       gnu-gpl-v2
                     11:
1.17      joerg      12: PKG_DESTDIR_SUPPORT=   user-destdir
                     13:
1.13      rillig     14: USE_LANGUAGES=         c c++
1.1       adam       15: USE_LIBTOOL=           yes
1.4       minskim    16: USE_TOOLS+=            gmake pkg-config
1.1       adam       17: GNU_CONFIGURE=         yes
1.3       adam       18: CONFIGURE_ARGS+=       --disable-debug
1.1       adam       19:
1.32      tron       20: .include "../../mk/bsd.prefs.mk"
1.42      hans       21: .if ${MACHINE_ARCH} == "alpha" || \
                     22:     ${MACHINE_ARCH} == "i386" || \
1.43    ! tron       23:     ${MACHINE_ARCH} == "powerpc" || \
1.42      hans       24:     ${MACHINE_ARCH} == "x86_64"
1.43    ! tron       25: GCC_REQD+=             4.1.3
1.42      hans       26: .else
                     27: GCC_REQD+=             4.2.1
                     28: .endif
1.32      tron       29:
1.38      jakllsch   30: # configure check is fooled by trap & emulate of unaligned access on alpha
                     31: .if (${MACHINE_ARCH} == "alpha")
                     32: CONFIGURE_ARGS+= --enable-aligned
                     33: .endif
                     34:
1.34      tron       35: .if !empty(OPSYS:M*BSD) || ${OPSYS} == "DragonFly" || ${OPSYS} == "Darwin"
1.32      tron       36: CONFIGURE_ARGS+=       --with-kqueue
                     37: .endif
                     38:
1.8       tron       39: .include "../../mk/compiler.mk"
                     40:
                     41: # See http://libtorrent.rakshasa.no/ticket/96
                     42: .if !empty(CC_VERSION:Mgcc-4.*)
                     43: CXXFLAGS+=     -fpermissive -fno-strength-reduce -fno-thread-jumps \
                     44:                -fno-inline -fforce-addr
                     45: .endif
                     46:
1.20      tron       47: .include "../../security/openssl/buildlink3.mk"
                     48: .if !exists(${BUILDLINK_PREFIX.openssl}/lib/pkgconfig/openssl.pc)
                     49: OPENSSL_CFLAGS=        -I${BUILDLINK_PREFIX.openssl}/include
                     50: OPENSSL_LIBS=  -L${BUILDLINK_PREFIX.openssl}/lib \
                     51:                -W,-lR${BUILDLINK_PREFIX.openssl}/lib
                     52:
                     53: CONFIGURE_ENV+=        OPENSSL_CFLAGS=${OPENSSL_CFLAGS:Q}
                     54: CONFIGURE_ENV+=        OPENSSL_LIBS=${OPENSSL_LIBS:Q}
                     55: .endif
                     56:
1.23      wiz        57: .include "../../devel/libsigc++/buildlink3.mk"
1.1       adam       58: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>