[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / kftpgrabber

File: [cvs.NetBSD.org] / pkgsrc / net / kftpgrabber / Attic / Makefile (download)

Revision 1.12, Thu Dec 7 10:03:46 2006 UTC (17 years, 3 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.11: +6 -14 lines

Update kftpgrabber to 0.8.0 beta2.  Fixes build on NetBSD-current

0.8.0-beta2
 CHG: Rewritten support for custom commands
 CHG: Left sidebar is now hidden by default
 ADD: Individual file mark/compare in the listviews
 ADD: Simple directory compare option
 ADD: Reimplemented support for SSCN
 ADD: A button to clear the list of recent sites
 FIX: Handle server replies containing NULLs
 FIX: Implemented a proper remove files dialog
 FIX: Queue and listview speed optimisations
 FIX: Some crash fixes
 FIX: Fixed sorting by timestamp

0.8.0-beta1
 CHG: Rewritten the browser view to support folders with a lot of files
 ADD: Added "move to top/move to bottom" options to the queue
 ADD: An option to toggle the use of primary connection for file transfers
 ADD: A shortcut to open the current local folder in Konqueror
 FIX: Fixed a SFTP related crash when aborting
 FIX: Properly filter selections when using the as-you-type filter

0.8.0-alpha2
 CHG: Rewritten the filtering API to support complex filters
 ADD: A configuration setting to automaticly retry failed transfers
 ADD: An option to ignore external IP for LAN connections
 FIX: Fixed some multiline parsing problems
 FIX: Fixed some SSL upload related problems
 FIX: Disable REST on servers that don't support it

0.8.0-alpha1
 CHG: Rewritten the low-level engine
 CHG: Some visual changes in the list view
 ADD: Keep alive support
 ADD: A nice as-you-type filter
 ADD: Keyboard shortcuts for common file operations
 ADD: A list of recent quick connect sites
 ADD: "Skip all", "Overwrite all", "Resume all" options in the file
      exists dialog
 ADD: Support for EPRT (required for IPv6 operation)
 ADD: Support for machine readable directory listings (MLSD)
 FIX: Many different fixes

0.7.0-beta1
 ADD: Speed limiting support
 ADD: Handling of failed transfers
 ADD: "On file exists" action matrix for FXP transfers
 CHG: Removed KMDI in favor of nice tab widget style from amaroK team
 CHG: Configuration is now KConfigXT based
 ADD: Ability to export directory listings into text files
 ADD: Fast directory listings via control channel on servers that support
      STAT
 ADD: Extrapolate transfer speed for FXP transfers
 ADD: Integrated SFV checksum verifier
 ADD: Global encoding option and ability to change remote encoding on fly
 ADD: Priority list (merged priority and skip list)
 ADD: Show current session status
 ADD: Sites as top-level queue items
 ADD: Ability to view/edit remote files
 FIX: Many SFTP related fixes
 ADD: Support for pubkey authentication (on SFTP connections)

# $NetBSD: Makefile,v 1.12 2006/12/07 10:03:46 markd Exp $

DISTNAME=	kftpgrabber-0.8.0-beta2
PKGNAME=	kftpgrabber-0.8.0b2
CATEGORIES=	net kde
MASTER_SITES=	http://www.kftp.org/uploads/files/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	markd@NetBSD.org
HOMEPAGE=       http://www.kftp.org/
COMMENT=	Graphical FTP client for KDE

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake msgfmt perl
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

.include "../../meta-pkgs/kde3/kde3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../x11/kdebase3/buildlink3.mk"
.include "../../x11/kdelibs3/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"