[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / kdenetwork3

File: [cvs.NetBSD.org] / pkgsrc / net / kdenetwork3 / Attic / Makefile (download)

Revision 1.16, Thu May 22 02:53:23 2003 UTC (20 years, 11 months ago) by markd
Branch: MAIN
Changes since 1.15: +2 -3 lines

Update KDE to 3.1.2.

Changes:
kdenetwork:
* KMail: Don't select multiple folders during keyboard navigation
* KMail: Never display vCards inline
* KMail: Make new mail notification work for people who run KMail without KDE
* KMail: Improved URL highlighting
* KMail: Properly determine SSL/TLS state for non-transport sending (bug 49902)
* KMail: Draw a frame around text attachments which are displayed inline
* KMail: Fix bug 55377 (Hiding attachments causes HTML messages to be renderend
  as HTML code)
* KMail: Fix bug 56049 (wrong encoding of command line arguments)
* KMail: Fix bug 53665 (Error when reply to a HTML message)
* KMail: Use the correct charset for replies to PGP/MIME encrypted messages
* KMail: Fix the bug which broke the signature of all PGP/MIME signed messages with
  attachments
* KMail: Fix bug 56393 (kmail crashes when I try change the name of an imap account)
* KMail: Fix bug 56570 (kmail doesn't show non-mime Japanese message)
* KMail: Fix bug 56592 (Displaying folded Content-Description in MIME tree viewer
  is broken)
* KMail: Disable external editor when no external editor is specified
* KMail: Fix bug 53889 (IMAP: Kmail crashes after authorization-dialog)
* KMail: Fix bug 56930 (BCC, No EMail-List expansion)
* KMail: Fix bug 42646 (multipart/digest forwarding is broken - uses empty boundary)
* KMail: Always make sure that the text body of the message ends with a linefeed.
  This fixes interoperatibility problems with other OpenPGP compliant mail clients.
* KMail: Prevent the user from trying to move local folders to IMAP servers as the
  user might lose the folders if he tries it.
* KMail: Fix bug 57660 ('send again' does not copy the BCC address)
* KMail: Fix bug 56321 (More whitespace in read/unread mails column)
* KMail: Tell gpg explicitely not to use gpg-agent if it's apparently not available.
  Prevents weird "Wrong passphrase" error message.
* KMail: Fix bug 57016 (pgp signature is wrong displayed)
* KMail: Fix bug 57809 (kmail segfaults when checking for new mail if fcntl locking
  is used)
* Desktop Sharing server (krfb): Compile fixes for systems without IPv6
* Desktop Sharing client (krdc): fix: client crashed sometimes while connecting on
  XFree 4.3
* Desktop Sharing client (krdc): fix: resize the right screen resolution in
  multi-screen setups

# $NetBSD: Makefile,v 1.16 2003/05/22 02:53:23 markd Exp $

DISTNAME=	kdenetwork-3.1.2
CATEGORIES=	net
COMMENT=	Network modules for the KDE integrated X11 desktop

.include "../../x11/kde3/Makefile.kde3"

USE_BUILDLINK2=		yes
PTHREAD_OPTS+=		require

FOO_MAIN_FILES= \
	ksirc/ksirc_main.cpp \
	kxmlrpc/kxmlrpcd_main.cpp

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "SunOS"
CONFIGURE_ENV+=		ac_cv_sys_file_offset_bits=no
.endif

.include "../../x11/kde3/Makefile.foo_main"

.include "../../converters/uulib/buildlink2.mk"
.include "../../databases/gdbm/buildlink2.mk"
.include "../../x11/kde3/buildlink2.mk"
.include "../../x11/kdebase3/buildlink2.mk"
.include "../../mk/pthread.buildlink2.mk"

.include "../../mk/bsd.pkg.mk"