[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / jftpgw

File: [cvs.NetBSD.org] / pkgsrc / net / jftpgw / Makefile (download)

Revision 1.9, Sat Mar 4 21:30:19 2006 UTC (18 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.8: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.9 2006/03/04 21:30:19 jlam Exp $

DISTNAME=	    jftpgw-0.13.4
PKGREVISION=	    1
CATEGORIES=	    net
MASTER_SITES=	    http://www.mcknight.de/jftpgw/

MAINTAINER=	    pkgsrc-users@NetBSD.org
HOMEPAGE=	    http://www.mcknight.de/jftpgw/
COMMENT=	    FTP gateway/proxy

GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--with-logpath=${VARBASE}/log
CONFIGURE_ARGS+=	--enable-crypt
CONFIGURE_ARGS+=	--enable-sftp

RCD_SCRIPTS=		jftpgw
EGDIR=			${PREFIX}/share/examples/jftpgw
CONF_FILES=		${EGDIR}/jftpgw.conf ${PKG_SYSCONFDIR}/jftpgw.conf

SUBST_CLASSES+=		log
SUBST_STAGE.log=	post-patch
SUBST_FILES.log=	active.c bindport.c cache.c cmds.c config.c \
			ftpread.c fw_auth_cmds.c jftpgw.c log.c log.h \
			login.c openport.c passive.c states.c std_cmds.c \
			util.c
SUBST_SED.log=		-e "s,\([[:space:]]\)\(log(\),\1x\2,"

SUBST_CLASSES+=		config
SUBST_STAGE.config=	post-build
SUBST_FILES.config=	jftpgw.conf.sample
SUBST_SED.config=	-e "s/nobody/root/"

.include "../../mk/bsd.pkg.mk"