[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / irrtoolset5

File: [cvs.NetBSD.org] / pkgsrc / net / irrtoolset5 / Makefile (download)

Revision 1.11, Thu Oct 17 14:05:49 2019 UTC (4 years, 6 months ago) by he
Branch: MAIN
Changes since 1.10: +11 -10 lines

Update irrtoolset5 to version 5.1.2.

Pkgsrc changes:
 * Project moved to github, follow suit.
 * Use the pre-configure target to run the required autotools
 * Remove ancient GCC_REQD+=3.0
 * Add use of more autotools
 * Fix up PLIST with share/doc/irrtoolset/ files.

Upstream changes:

New Features
 * initial support for IOS XR in rtconfig
 * IOS support for peer templates (-cisco_peer_templates)
 * support of community.delete on Cisco IOS
 * implement importPeerGroup for JUNOS

Bug Fixes
 * better asn32 support on JUNOS
 * fix JUNOS output so it can be deployed using "load replace" (-junos_replace)
 * several toolchain bugfixes (bison 2.x, gcc)
 * workaround for compiler optimisation bug in gcc6
 * permit community values starting with 0:
 * updates for autotools

Other Notes
 * Solaris no longer formally supported
 * delete bugs/, contrib/ and tests/ directories
 * added Travis CI support

We'd like to thank ISC for their continued support and the small
but important army of contributors who made this release possible.

# $NetBSD: Makefile,v 1.11 2019/10/17 14:05:49 he Exp $

VERSION=		5.1.2
DISTNAME=		irrtoolset-${VERSION}
CATEGORIES=		net
MASTER_SITES=		${MASTER_SITE_GITHUB:=irrtoolset/}

OWNER=			spz@NetBSD.org
HOMEPAGE=		https://github.com/irrtoolset/irrtoolset/
COMMENT=		The Internet Routing Registry Toolset - client to IRRd
GITHUB_TAG=		release-${VERSION}
LICENSE=		gnu-gpl-v2 AND mit AND modified-bsd

CONFLICTS=		IRRToolSet-4.*

.include "../../mk/bsd.prefs.mk"

INSTALLATION_DIRS=	${PKGBINDIR} ${PKGMANDIR}/man1

MAKE_JOBS_SAFE=		NO

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_LANGUAGES=		c c++
USE_TOOLS+=		aclocal automake autoconf bison flex

CONFIG_GUESS_OVERRIDE=	config.guess
CONFIG_SUB_OVERRIDE=	config.sub

pre-configure:
	cd ${WRKSRC} && aclocal
	cd ${WRKSRC} && autoreconf --install
	cd ${WRKSRC} && automake --add-missing
	cd ${WRKSRC} && autoconf -v -i -f

.include "../../mk/readline.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"