File:  [cvs.NetBSD.org] / pkgsrc / net / glib-networking / Makefile
Revision 1.16: download - view: text, annotated - select for diffs
Tue Oct 23 17:18:23 2012 UTC (12 years, 1 month ago) by asau
Branches: MAIN
CVS tags: HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.16 2012/10/23 17:18:23 asau Exp $
#

DISTNAME=	glib-networking-2.34.0
CATEGORIES=	net
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/glib-networking/2.34/}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.gnome.org/
COMMENT=	Network-related giomodules for glib
LICENSE=	gnu-gpl-v2

GNU_CONFIGURE=	yes
CONFIGURE_ARGS+= --with-ca-certificates=/etc/ssl/certs/ca-certificates.crt
USE_LIBTOOL=	yes
USE_TOOLS+=	intltool pkg-config gmake gettext

# gcc>=4.2 specific -Werror=XXX flags will be added unconditionally.
.include "../../mk/compiler.mk"
.if !empty(CC_VERSION:Mgcc-4.[01].*) || !empty(CC_VERSION:Mgcc-[1-3].*)
CONFIGURE_ARGS+= 	--disable-more-warnings
.endif

BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/glib2/modules.mk"
BUILDLINK_API_DEPENDS.libproxy+= libproxy>=0.3.1
.include "../../www/libproxy/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
# XXX libcgrypt is not necessary if gnutls was built against nettle,
# but the assumption is hardwired at multiple places
.include "../../security/libgcrypt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>