[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / freeradius-python

File: [cvs.NetBSD.org] / pkgsrc / net / freeradius-python / PLIST (download)

Revision 1.2, Thu Jul 4 07:44:53 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.1: +2 -2 lines

freeradius: updated to 3.0.19

3.0.19:
FEATURE IMPROVEMENTS
Update dictionary.cisco.
Update sqlippool to allow for stored procedures with PostgreSQL. This increases performance substantially Patch from Nathan Ward.
Re-added "show client config" command to radmin.
Cleaned up mods-available/sql example so that it is easier to understand.
Added pfSense dictionary.
Update dictionary.h3c
Update elasticsearch/logstash config for v6.7.0.
EAP-PWD security fixes from Mathy Vanhoef. See http://freeradius.org/security/.

BUG FIXES
Update dynamic_client module and server core so that the functionality works. This has been broken since at least v2.
Fix crash in sqlippool due to escaping changes Patch from Nathan Ward.
Fix systemd notify, watchdog and unit files
Fix erroneous length check in EAP-FAST.
Update documentation to remove old "ignore_null" configuration.
Fix default POD port. Should be 3799.
Correctly encode vendor-specific "encrypted" attributes


3.0.18:
FEATURE IMPROVEMENTS
cleanup_delay can now be 30 seconds. This helps with proxies that have packet loss.
Do-Not-Respond policies can now be set in the "post-auth" section.
Encode / Decode ADSL Forum DHCP options.
Fix module ordering issues. e.g. when "sqlippool" needs "sql". See the "instantiate" section of radiusd.conf.
Add Big Switch dictionary.
Add sql_session_start policy (raddb/policy.d/accounting) This minimizes race conditions when using Simultaneous-Use Patch from Philippe Wooding.
For rlm_perl, all variables are now tainted by default. See raddb/mods-available/perl, and the "perl_flags" configuration item. This change should only affect people who are using variables in insecure ways.
Allow "sqlcounter" module to be listed in "post-auth".
Add support for IPv6 attributes in SQL.
The server is better at handling fail-over for outbound RadSec and TCP connections.
The server is now more aggressive about retrying failed outbound RadSec and TCP connections.
Add TLS-Session-Version and TLS-Session-Cipher-Suite to the "session_state" list.
Add expansion for Radsec connections. "%{listen:TLS-...}" for TLS-Client-Cert-* and TLS-Cert-* attributes.
Add notes on running "ldapsearch" using the parameters from the LDAP module.
"ipaddr" attributes can now be cast to "integer" type attributes in an "update" section.
Move main thread queue to using atomic queues. This should help with contention in high load scenarios.
Add "recv_buff" setting to listeners. For more details, see sites-available/default.
The sqlippool module can now use attributes other than "Pool-Name" to assign IP pools. The "Pool-Name" attribute is still the default.
The "unpack" expansion can now unpack substrings. See mods-available/unpack for documentation and examples.
The preprocess module now does "ciscvo_vsa_hack" for Eltex-AVPair. Vendors SHOULD NOT USE THAT KIND OF ATTRIBUTE.
Allow for <instance>-LDAP-UserDN. See mods-available/ldap for more information.
Add sanitizing of control list for moonshot.
Update rlm_sql_mysql to be compatible with MySQL 8 Fixes https://bugs.launchpad.net/bugs/1795310.
Allow logging of only Access-Accept or Access-Reject messages See radiusd.conf, "auth_accept" and "auth_reject".
Removed Connect-Rate comparison. It was unused and broken.
Add dictionary.infinera.
RPMs can now change raddb location with rpmbuild parameter --define '_sysconfdir /etc'.
OpenDirectory module now points to Apple documentation for help with build and configuration.
Use OpenSSL HMAC functions instead of local ones.
Some SQL modules can now use "auto_escape" to escape unsafe strings See mods-config/sql/main/mysql/queries.conf.
Add wispr2date conversion in mods-available/date.
Implement dictionary-based handling in rlm_python.
Add support for SKIP LOCKED in sqlippool. This can improve performance by an order of magnitude or more. See raddb/mods-config/sql/ippool/*/queries.conf
Updated Debian packages to allow for libssl1.1
Allow PSK and certificates at the same time Except for TLS 1.3 which does not support that.
Update Debian packages for newer releases
Update docker scripts.
Add crypt xlat.
MySQL connections can now skip verifying the server certificate.
Add better mechanism to detect MariaDB (Old MySQL).
Add RFC 7532 "bang path" support for realms
Update dictionary.ukerna documentation.
Add support for systemd service and watchdogs
Check for openss/rand.h, and allow building without OpenSSL engine.
The default PosgtreSQL queries now use "ON CONFLICT" to better deal with issues. This requires PostgreSQL 9.5 or later. Please use a recent version of PostgreSQL, or edit the default queries to remove "ON CONFLICT".

BUG FIXES
The session-state list is no longer cleaned in the inner-tunnel. This lets the outer Access-Reject section access session-state.
Fix typo in lock initialization for TLS sockets Found by Sergio NNX.
Add check for crash when home server down
Add username key for postauth table.
Better libpcap checks, when the header files or libraries are missing.
Allow building with old versions of OpenSSL
Allow non-FreeRADIUS State attributes to be used with the "session-state" list. i.e. State length != 16.
Be more aggressive about cleaning up zombie children when running in debug mode.
Use LTDL_DEEPBIND, which fixes issues with Oracle libraries exporting LDAP API functions.
unlock files when asked to unlock them.
return error instead of asserting in map code.
Don't write 0 bytes to SSL.
Remove "expiry_time IS NULL" from allocate_update query.
Various dictionary cleanups and consistency checks
rlm_python has stronger thread locking to prevent reported issues. Performance may be affected.
Don't allow Message-Authenticator to overflow past the end of a large packet.
Fix crash in sqlippool when SQL server goes away
Typos in man pages. Patch from Nikolai Kondrashov
Check for correct OpenSSL version in vulnerability list. Patch from Christian Hesse.
Fix crash with CoA packets/
Fix crash in rlm_exec with CoA.
Print errors while parsing the log config, and don't quit when deprecated log settings are found.
Fix DHCP encoder xlat so that it can be used with a list of attributes. It previously only encoded the first member of the list, and now encodes all members.
The "expr" module now skips more whitespace.
Remove internal FreeRADIUS-Response-Delay attributes from attr_filter Access-Reject.
Don't send junk to redis when maximum args reached.
Small updates to IPv6 for accounting schema
Fix OpenDirectory integration in rlm_mschap.
Fix slow memory leak with dynamic clients.
Don't artificially truncate debug output for long strings.
Fix memory leak in EAP-PWD.
Fix crash in "hints" file with Fall-Through = yes.
Fix crash / timer issues with many CoA packets.
Fix attr_filter so that it does not treat vendor attributes of number 26 as Vendor-Specific.
Fix reconnect correctly in rlm_sql_mysql.
Fix rlm_cache to properly use Cache-TTL < 0
Fix rare occurance of bad xlat expansion.
Check for rare race condition when a proxy reply arrives too late.

@comment $NetBSD: PLIST,v 1.2 2019/07/04 07:44:53 adam Exp $
lib/rlm_python.${SOEXT}