[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / erlang-xmpp

File: [cvs.NetBSD.org] / pkgsrc / net / erlang-xmpp / Makefile (download)

Revision 1.16, Sat Jan 16 12:42:47 2021 UTC (3 years, 3 months ago) by triaxx
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.15: +8 -11 lines

erlang-xmpp: Update to 1.5.1

upstream changes:
-----------------
Version 1.5.1
  * Fix issues with scram *-PLUS

Version 1.5.0
  * Updating p1_utils to version 1.0.21.
  * Updating stringprep to version 1.0.24.
  * Updating fast_tls to version 1.1.10.
  * Updating fast_xml to version 1.1.45.
  * Add support for scram-sha-256/512-{plus}

Version 1.4.10
  * Updating ezlib to version 1.0.9.
  * Updating fast_tls to version 1.1.9.
  * Updating fast_xml to version 1.1.44.
  * Updating stringprep to version 1.0.23.
  * Add support for MAM Flipped Pages
  * Exclude old OTP releases from Travis
  * Support building specs with rebar3

Version 1.4.9
  * Updating p1_utils to version 1.0.20.
  * Updating fast_xml to version 1.1.43.
  * Updating fast_tls to version 1.1.8.
  * Updating stringprep to version 1.0.22.

Version 1.4.8
  * Fixes to compile with Erlang/OTP 23.0
  * updating ezlib to version 1.0.8.
  * updating fast_tls to version 1.1.7.
  * updating fast_xml to version 1.1.42.
  * updating stringprep to version 1.0.21.
  * Replace bad-protocol sasl errors with not-authorized
  * Add Travis setup, and set Erlang/OTP 19.0 as lowest supported version

Version 1.4.7
  * Updating fast_tls to version 1.1.6.
  * Updating p1_utils to version 1.0.19.
  * Updating fast_xml to version 1.1.41.
  * Updating stringprep to version 1.0.20.
  * Fix compatibility issues with Erlang 23

Version 1.4.6
  * Updating fast_tls to version 1.1.5.
  * Updating fast_xml to version 1.1.40.
  * Recognize elements from XEP-0215 (External Service Discovery)
  * Limit usage of synchronously terminating session, as is can cause problems with handling of queued messages

Version 1.4.5
  * Updating ezlib to version 1.0.7.
  * Updating fast_tls to version 1.1.4.
  * Updating fast_xml to version 1.1.39.
  * Updating p1_utils to version 1.0.18.
  * Updating stringprep to version 1.0.19.
  * Update copyright year

Version 1.4.4
  * Fix handling of infinity values in couple places
  * Declare namespace for "urn:xmpp:carbons:rules:0"

Version 1.4.3
  * Updating fast_tls to version 1.1.3.
  * Updating stringprep to version 1.0.18.
  * Updating fast_xml to version 1.1.38.
  * Updating p1_utils to version 1.0.17.

Version 1.4.2
  * Fix incorrect return type

Version 1.4.1
  * Add support for jid-prep
  * Improve handling of IDNA

Version 1.4.0
  * Updating fast_tls to version 1.1.2.
  * Updating fast_xml to version 1.1.37.
  * Updating stringprep to version 1.0.17.
  * Updating p1_utils to version 1.0.16.
  * Update type specs
  * Improve xdata compiler
  * Add support for CAPTCHA data forms (XEP-0158)
  * Accept certificates without XmppAddr fields
  * Improve xmpp_socket:get_peer_certificate/2
  * Update pubsub#metadata form

Version 1.3.4
  * Updating ezlib to version 1.0.6.
  * Updating fast_tls to version 1.1.1.
  * Updating fast_xml to version 1.1.36.
  * Updating p1_utils to version 1.0.15.
  * Updating stringprep to version 1.0.16.

Version 1.3.3
  * Allow muc_subscriber element to have jid or nick attribute
  * Add support for XEP-0417
  * Add get_subtags/2 and try_subtags/2

Version 1.3.2
  * Release from correct branch

Version 1.3.1
  * Updating ezlib to version 1.0.5.
  * Updating fast_tls to version 1.1.0.
  * Updating fast_xml to version 1.1.35.
  * Updating p1_utils to version 1.0.14.
  * Updating stringprep to version 1.0.15.
  * Add contribution guide
  * Encode by attribute in stanza_error

Version 1.3.0
  * Introduce 'ignore_unknown' xdata codec option
  * Add support for decoding language tags generated by Cisco Jabber
  * Add support for latest MIX version and MIX-PAM (XEP-0405)

Version 1.2.8
  * Improve building with rebar3 and hex packaging

Version 1.2.7
  * Add code required for proxy protocol support

Version 1.2.6
  * Updating fast_tls to version 1.0.26.
  * Add support for XEP-0048 and XEP-0411
  * Add logging of data transmited over xml sockets
  * Add functions for processing white space pings
  * Validate xml:lang values
  * Fix encoding of timestamp with negative TZ offsets

Version 1.2.5
  * Update packaging for hex

Version 1.2.4
  * Updating fast_xml to version 1.1.34.
  * Updating stringprep to version 1.0.14.
  * Updating p1_utils to version 1.0.13.
  * Updating fast_tls to version 1.0.25.

Version 1.2.3
  * Updating fast_tls to version f36ea5b74526c2c1c9c38f8d473168d95804f59d.
  * Updating fast_xml to version 1.1.33.
  * Updating p1_utils to version 1.0.13.
  * Updating stringprep to version 1.0.13.
  * Added handling for xeps: 319, 047, 261, 260, 234, 300, 166
  * Refactor of xmpp_socket

# $NetBSD: Makefile,v 1.16 2021/01/16 12:42:47 triaxx Exp $

DISTNAME=	xmpp-1.5.1
CATEGORIES=	net
MASTER_SITES=	${MASTER_SITE_GITHUB:=processone/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/processone/xmpp/
COMMENT=	XMPP parsing and serialization library on top of Fast XML
LICENSE=	apache-2.0

DEPENDS+=	erlang-p1_utils>=1.0.21:../../misc/erlang-p1_utils
DEPENDS+=	erlang-fast_xml>=1.1.45:../../textproc/erlang-fast_xml
DEPENDS+=	erlang-fast_tls>=1.1.10:../../security/erlang-fast_tls
DEPENDS+=	erlang-ezlib>=1.0.9:../../devel/erlang-ezlib
DEPENDS+=	erlang-idna>=6.0.0:../../net/erlang-idna
DEPENDS+=	erlang-stringprep>=1.0.24:../../textproc/erlang-stringprep

GITHUB_PROJECT=	xmpp

BUILD_TARGET=	src

# Leave a non-versioned symlink in place for net/erlang-esip to find
post-install:
	${LN} -sf ${DISTNAME} ${DESTDIR}${PREFIX}/lib/erlang/lib/xmpp

.include "../../lang/erlang/module.mk"
.include "../../mk/bsd.pkg.mk"