File:  [cvs.NetBSD.org] / pkgsrc / net / dtcpclient / Makefile
Revision 1.25: download - view: text, annotated - select for diffs
Thu Jan 19 18:52:19 2017 UTC (8 years, 2 months ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, HEAD
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

# $NetBSD: Makefile,v 1.25 2017/01/19 18:52:19 agc Exp $
#

DISTNAME=	dtcpclient-20090812
PKGREVISION=	2
CATEGORIES=	net
MASTER_SITES=	http://www.imasy.or.jp/~ume/ipv6/
MASTER_SITES+=	http://home.jp.FreeBSD.org/~ume/ipv6/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.imasy.or.jp/~ume/dtcp/
COMMENT=	Dynamic Tunnel Configuration Protocol client
LICENSE=	2-clause-bsd

USE_BSD_MAKEFILE=	yes

RCD_SCRIPTS=	dtcpclient

SUBST_CLASSES+=		paths
SUBST_MESSAGE.paths=	Fixing hardcoded paths.
SUBST_STAGE.paths=	post-configure
SUBST_FILES.paths=	dtcpclient.8 dtcpclient.script dtcpclient.c
SUBST_SED.paths=	-e 's|/usr/local/etc/dtcpclient.script|${PREFIX}/sbin/dtcpclient-script|'
SUBST_SED.paths+=	-e 's|/usr/local/etc|${PKG_SYSCONFDIR}|g'
SUBST_SED.paths+=	-e 's|/usr/local|${PREFIX}|g'
SUBST_SED.paths+=	-e 's|/var|${VARBASE}|g'

MAKE_ENV+=	VARBASE=${VARBASE}

BUILD_DEFS+=	VARBASE

INSTALLATION_DIRS=	${PKGMANDIR}/cat8 ${PKGMANDIR}/man8 sbin

.include "../../mk/bsd.prefs.mk"

# Keep this in sync with patch-aa, as that determines whether -lcrypto
# is used and if we get it wrong we'll get a silent dependency on
# builtin openssl on platforms where that exists, which isn't good.
.if ${OPSYS} != "NetBSD" || ${OPSYS} != "OpenBSD" || \
    ${OPSYS} != "FreeBSD" || ${OPSYS} != "DragonFly"
.include "../../security/openssl/buildlink3.mk"
.endif

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>