[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / dnsdoctor

File: [cvs.NetBSD.org] / pkgsrc / net / dnsdoctor / Attic / Makefile (download)

Revision 1.2, Sat Mar 4 21:30:18 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.1: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.2 2006/03/04 21:30:18 jlam Exp $
#

DISTNAME=		dnsdoctor-1.0.0
CATEGORIES=		net
MASTER_SITES=		http://www.dnsdoctor.org/download/src/
EXTRACT_SUFX=		.tgz

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.dnsdoctor.org/
COMMENT=		DNS zones misconfigurations or inconsistencies diagnostic tool

DEPENDS+=		ruby${RUBY_VER}-base>=${RUBY_REQD}:../../lang/ruby${RUBY_VER}-base

WRKSRC=		${WRKDIR}/dnsdoctor

RUBY_VERSION_SUPPORTED=	18
NO_BUILD=	yes

DDOC_HTML_PATH?=	/dnsdoctor
EGDIR=			share/examples
DDOCEGDIR=		${EGDIR}/dnsdoctor
# No we don't want to use PKG_SYSCONFSUBDIR
DDOCCONFDIR=		${PKG_SYSCONFDIR}/dnsdoctor
OWN_DIRS=		${PKG_SYSCONFDIR}/dnsdoctor

DDOC_INSTALLER_RB_ARGS+=	-DRUBY=${RUBY:Q}
DDOC_INSTALLER_RB_ARGS+=	-DPREFIX=${PREFIX:Q}
DDOC_INSTALLER_RB_ARGS+=	-DEGDIR=${PREFIX:Q}/${EGDIR:Q}
DDOC_INSTALLER_RB_ARGS+=	-DETCDIR=${PKG_SYSCONFDIR:Q}
DDOC_INSTALLER_RB_ARGS+=	-DHTML_PATH=${DDOC_HTML_PATH:Q}

CONF_FILES+=	${DDOCEGDIR}/afnic.profile ${DDOCCONFDIR}/afnic.profile
CONF_FILES+=	${DDOCEGDIR}/de.profile ${DDOCCONFDIR}/de.profile
CONF_FILES+=	${DDOCEGDIR}/default.profile ${DDOCCONFDIR}/default.profile
CONF_FILES+=	${DDOCEGDIR}/reverse.profile ${DDOCCONFDIR}/reverse.profile
CONF_FILES+=	${DDOCEGDIR}/rootservers ${DDOCCONFDIR}/rootservers
CONF_FILES+=	${DDOCEGDIR}/dnsdoctor.conf ${DDOCCONFDIR}/dnsdoctor.conf

do-configure:
	cd ${WRKSRC} && \
	${RUBY} ./installer.rb	${DDOC_INSTALLER_RB_ARGS} configure configinfo

do-install:
	cd ${WRKSRC} &&	\
	${RUBY} ./installer.rb ${DDOC_INSTALLER_RB_ARGS} all
	${INSTALL_DATA} ${WRKSRC}/www/dnsdoctor.conf \
	  ${PREFIX}/${DDOCEGDIR}/httpd-dnsdoctor.conf

.include "../../lang/ruby/rubyversion.mk"
.include "../../mk/bsd.pkg.mk"