File:
[cvs.NetBSD.org] /
pkgsrc /
net /
bittorrent /
Attic /
Makefile
Revision
1.45:
download - view:
text,
annotated -
select for diffs
Tue Oct 23 17:18:12 2012 UTC (12 years, 1 month ago) by
asau
Branches:
MAIN
CVS tags:
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
# $NetBSD: Makefile,v 1.45 2012/10/23 17:18:12 asau Exp $
.include "Makefile.common"
PKGNAME= ${DISTNAME:S/BitT/bitt/}
PKGREVISION= 6
CONFLICTS+= bittornado-[0-9]*
CONFLICTS+= BitTornado-[0-9]*
DEPENDS+= ${PYPKGPREFIX}-cursespanel-[0-9]*:../../devel/py-cursespanel
USE_TOOLS+= msgfmt xgettext msgmerge
SUBST_CLASSES+= sha
SUBST_MESSAGE.sha= Fixing references to deprecated sha module.
SUBST_STAGE.sha= pre-configure
SUBST_FILES.sha= BitTorrent/ConvertedMetainfo.py
SUBST_FILES.sha+= BitTorrent/NewVersion.py
SUBST_FILES.sha+= BitTorrent/PeerID.py
SUBST_FILES.sha+= BitTorrent/StorageWrapper.py
SUBST_FILES.sha+= BitTorrent/download.py
SUBST_FILES.sha+= BitTorrent/makemetafile.py
SUBST_FILES.sha+= BitTorrent/parsedir.py
SUBST_FILES.sha+= khashmir/khash.py
SUBST_FILES.sha+= khashmir/khashmir.py
SUBST_FILES.sha+= khashmir/utkhashmir.py
SUBST_FILES.sha+= torrentinfo-console.py
SUBST_SED.sha= -e "s/^from sha import .*/from hashlib import sha1 as sha/"
.include "../../lang/python/application.mk"
.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>