[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / bittorrent-gui

File: [cvs.NetBSD.org] / pkgsrc / net / bittorrent-gui / Attic / Makefile (download)

Revision 1.5, Mon Mar 29 23:39:43 2004 UTC (20 years ago) by wiz
Branch: MAIN
Changes since 1.4: +1 -2 lines

Update to 3.4.1a:
The tracker works under Python 2.2 and supports 3.3 clients properly.
The client is unchanged.

# $NetBSD: Makefile,v 1.5 2004/03/29 23:39:43 wiz Exp $
#

.include "../../net/bittorrent/Makefile.common"

PKGNAME=	${DISTNAME:S/BitTorrent/bittorrent-gui/}

COMMENT+=	(wxGTK GUI)

DEPENDS+=	bittorrent>=3.4:../../net/bittorrent

NO_BUILD=	# defined

PYTHON_PATCH_SCRIPTS= btcompletedirgui.py btdownloadgui.py

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/btcompletedirgui.py ${PREFIX}/bin
	${INSTALL_SCRIPT} ${WRKSRC}/btdownloadgui.py ${PREFIX}/bin

.include "../../lang/python/application.mk"
.include "../../x11/py-wxWindows/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"