[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / bittorrent-gui

File: [cvs.NetBSD.org] / pkgsrc / net / bittorrent-gui / Attic / Makefile (download)

Revision 1.38, Sun Jan 1 14:43:49 2017 UTC (4 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.37: +2 -2 lines

Add python-3.6 to incompatible versions.

# $NetBSD: Makefile,v 1.38 2017/01/01 14:43:49 wiz Exp $

.include "../../net/bittorrent/Makefile.common"

PKGNAME=	${DISTNAME:S/BitTorrent/bittorrent-gui/}
PKGREVISION=	12

COMMENT+=	(GTK+ GUI)

DEPENDS+=	bittorrent>=${PKGVERSION_NOREV}:../../net/bittorrent
DEPENDS+=	${PYPKGPREFIX}-gtk2>=2.6:../../x11/py-gtk2

REPLACE_PYTHON= bittorrent maketorrent
PYTHON_VERSIONS_INCOMPATIBLE=	34 35 36 # py-gtk2

CONFLICTS+=	bittornado-gui-[0-9]*

ICONS_DIR=		share/pixmaps/BitTorrent-${PKGVERSION:C/nb.*//}/icons
INSTALLATION_DIRS=	bin ${ICONS_DIR} ${ICONS_DIR}/default ${ICONS_DIR}/old

NO_BUILD=	yes

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/bittorrent ${DESTDIR}${PREFIX}/bin
	${INSTALL_SCRIPT} ${WRKSRC}/maketorrent ${DESTDIR}${PREFIX}/bin
	${INSTALL_DATA} ${WRKSRC}/images/icons/default/* \
	  ${DESTDIR}${PREFIX}/${ICONS_DIR}/default
	${INSTALL_DATA} ${WRKSRC}/images/icons/old/* \
	  ${DESTDIR}${PREFIX}/${ICONS_DIR}/old

.include "../../lang/python/application.mk"
.include "../../mk/bsd.pkg.mk"