File:  [cvs.NetBSD.org] / pkgsrc / net / bird / Makefile.common
Revision 1.2: download - view: text, annotated - select for diffs
Tue Oct 23 17:18:11 2012 UTC (12 years, 1 month ago) by asau
Branches: MAIN
CVS tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile.common,v 1.2 2012/10/23 17:18:11 asau Exp $
# used by net/bird/Makefile
# used by net/bird6/Makefile

DISTNAME=	bird-1.3.6
PKGNAME=	${DISTNAME:S/bird/bird${BIRD6}/}
CATEGORIES=	net
MASTER_SITES=	ftp://bird.network.cz/pub/bird/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://bird.network.cz/
COMMENT=	The BIRD Internet Routing Daemon
LICENSE=	gnu-gpl-v2

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake flex bison
USE_GNU_READLINE=	yes

CONFIGURE_ARGS+=	--localstatedir=/var
BIRD6?=			# empty
PLIST_SUBST+=		BIRD6=${BIRD6}

FILESDIR=               ${.CURDIR}/../bird/files
PATCHDIR=               ${.CURDIR}/../bird/patches
DISTINFO_FILE=		${.CURDIR}/../bird/distinfo
PLIST_SRC=		${.CURDIR}/../bird/PLIST
DESCR_SRC=		${.CURDIR}/../bird/DESCR

RCD_SCRIPTS+=		bird${BIRD6}

EGDIR=			${PREFIX}/share/examples/bird${BIRD6}
ALL_ENV+=		EGDIR=${EGDIR}
CONF_FILES=		${EGDIR}/bird${BIRD6}.conf ${PKG_SYSCONFDIR}/bird${BIRD6}.conf

.include "../../devel/readline/buildlink3.mk"
.include "../../devel/ncurses/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>