[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / bind9

File: [cvs.NetBSD.org] / pkgsrc / net / bind9 / Attic / Makefile (download)

Revision 1.67, Wed Mar 16 13:56:24 2005 UTC (19 years ago) by tron
Branch: MAIN
Changes since 1.66: +3 -2 lines

- Rename rc script "named" to "named9" to avoid conflicts with NetBSD's
  builtin script.
- Don't set "pidfile" in "named9.sh" because it breaks change rooted
  configurations.
- Disable inlining in "lib/dns/rbt.c" on PowerPC systems because certain
  GCC version create broken code for that file.
Bump package revision because of the above changes.

# $NetBSD: Makefile,v 1.67 2005/03/16 13:56:24 tron Exp $

DISTNAME=	bind-${BIND_VERSION}
PKGNAME=	bind-${BIND_VERSION}pl1
PKGREVISION=	1
CATEGORIES=	net
MASTER_SITES=	ftp://ftp.isc.org/isc/bind9/${BIND_VERSION}/

PATCH_SITES=		${MASTER_SITES}
PATCHFILES=		9.3.0-patch1
PATCH_DIST_STRIP=	-p1

MAINTAINER=	tron@NetBSD.org
HOMEPAGE=	http://www.isc.org/sw/bind/
COMMENT=	Version 9 of the Berkeley Internet Name Daemon, implementation of DNS

BIND_VERSION=	9.3.0
DIST_SUBDIR=	bind/${BIND_VERSION}

# IPv6 ready, automatically detected
.include "../../mk/bsd.prefs.mk"
BUILD_DEFS+=	USE_INET6
# No need to set USE_INET6, will auto-detect.

USE_BUILDLINK3=		yes
USE_LIBTOOL=		yes
USE_PKGINSTALL=		yes

GNU_CONFIGURE=	yes
CONFIGURE_ARGS+=--with-libtool=yes \
		--sysconfdir=/etc \
		--localstatedir=${VARBASE}
#LDFLAGS+=	${COMPILER_RPATH_FLAG}${LOCALBASE}/pthreads/lib -L${LOCALBASE}/pthreads/lib
# use external OpenSSL.  comment out the following line and the buildlink
# include at the bottom to use OpenSSL shipped with BIND9.
CONFIGURE_ARGS+=--with-openssl=${SSLBASE}

PTHREAD_OPTS+=	native

# include/isc/ipv6.h is installed on non-ipv6 platforms
.if defined(USE_INET6) && (${USE_INET6} == "YES")
PLIST_SUBST+=	IPV6H="@comment "
.else
PLIST_SUBST+=	IPV6H=
.endif

PLIST_SRC=	${WRKDIR}/PLIST
RCD_SCRIPTS=	lwresd named9

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/arm
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/draft
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/misc
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/rfc
	${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bind9
	${INSTALL_DATA} ${WRKSRC}/doc/arm/* ${PREFIX}/share/doc/bind9/arm
	${INSTALL_DATA} ${WRKSRC}/doc/draft/* ${PREFIX}/share/doc/bind9/draft
	${INSTALL_DATA} ${WRKSRC}/doc/misc/* ${PREFIX}/share/doc/bind9/misc
	${INSTALL_DATA} ${WRKSRC}/doc/rfc/* ${PREFIX}/share/doc/bind9/rfc
	${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
	(cd ${PREFIX}; ${FIND} share/doc/bind9 -type f -print ) >> ${PLIST_SRC}
	(cd ${PREFIX}; ${FIND} share/doc/bind9 -type d -print ) | \
		${SED} -e 's/^/@dirrm /' | ${SORT} -r >> ${PLIST_SRC}

.include "../../mk/pthread.buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

.if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "none") || \
	!empty(MACHINE_PLATFORM:MNetBSD-*-vax) || \
	!empty(MACHINE_PLATFORM:MNetBSD-*-m68k)
CONFIGURE_ARGS+=	--disable-threads
.else
CONFIGURE_ARGS+=	--enable-threads
.endif