[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / bind9

Annotation of pkgsrc/net/bind9/Makefile, Revision 1.66

1.66    ! tron        1: # $NetBSD: Makefile,v 1.65 2005/01/26 09:32:31 tron Exp $
1.1       hubertf     2:
1.52      itojun      3: DISTNAME=      bind-${BIND_VERSION}
1.65      tron        4: PKGNAME=       bind-${BIND_VERSION}pl1
1.1       hubertf     5: CATEGORIES=    net
1.52      itojun      6: MASTER_SITES=  ftp://ftp.isc.org/isc/bind9/${BIND_VERSION}/
1.1       hubertf     7:
1.66    ! tron        8: PATCH_SITES=           ${MASTER_SITES}
        !             9: PATCHFILES=            9.3.0-patch1
        !            10: PATCH_DIST_STRIP=      -p1
        !            11:
1.62      tron       12: MAINTAINER=    tron@NetBSD.org
1.65      tron       13: HOMEPAGE=      http://www.isc.org/sw/bind/
1.27      wiz        14: COMMENT=       Version 9 of the Berkeley Internet Name Daemon, implementation of DNS
1.6       itojun     15:
1.62      tron       16: BIND_VERSION=  9.3.0
1.39      wiz        17: DIST_SUBDIR=   bind/${BIND_VERSION}
                     18:
1.6       itojun     19: # IPv6 ready, automatically detected
                     20: .include "../../mk/bsd.prefs.mk"
                     21: BUILD_DEFS+=   USE_INET6
1.39      wiz        22: # No need to set USE_INET6, will auto-detect.
1.1       hubertf    23:
1.58      snj        24: USE_BUILDLINK3=                yes
1.41      grant      25: USE_LIBTOOL=           yes
1.66    ! tron       26: USE_PKGINSTALL=                yes
1.41      grant      27:
1.1       hubertf    28: GNU_CONFIGURE= yes
1.20      hubertf    29: CONFIGURE_ARGS+=--with-libtool=yes \
1.5       hubertf    30:                --sysconfdir=/etc \
1.64      minskim    31:                --localstatedir=${VARBASE}
1.60      jlam       32: #LDFLAGS+=     ${COMPILER_RPATH_FLAG}${LOCALBASE}/pthreads/lib -L${LOCALBASE}/pthreads/lib
1.39      wiz        33: # use external OpenSSL.  comment out the following line and the buildlink
                     34: # include at the bottom to use OpenSSL shipped with BIND9.
                     35: CONFIGURE_ARGS+=--with-openssl=${SSLBASE}
1.1       hubertf    36:
1.45      seb        37: PTHREAD_OPTS+= native
                     38:
1.42      grant      39: # include/isc/ipv6.h is installed on non-ipv6 platforms
1.47      hubertf    40: .if defined(USE_INET6) && (${USE_INET6} == "YES")
1.54      tron       41: PLIST_SUBST+=  IPV6H="@comment "
1.47      hubertf    42: .else
1.54      tron       43: PLIST_SUBST+=  IPV6H=
1.42      grant      44: .endif
                     45:
1.25      itojun     46: PLIST_SRC=     ${WRKDIR}/PLIST
1.66    ! tron       47: RCD_SCRIPTS=   lwresd named
1.25      itojun     48:
1.1       hubertf    49: post-install:
1.28      hubertf    50:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9
                     51:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/arm
                     52:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/draft
                     53:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/misc
                     54:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/bind9/rfc
1.1       hubertf    55:        ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bind9
                     56:        ${INSTALL_DATA} ${WRKSRC}/doc/arm/* ${PREFIX}/share/doc/bind9/arm
                     57:        ${INSTALL_DATA} ${WRKSRC}/doc/draft/* ${PREFIX}/share/doc/bind9/draft
                     58:        ${INSTALL_DATA} ${WRKSRC}/doc/misc/* ${PREFIX}/share/doc/bind9/misc
                     59:        ${INSTALL_DATA} ${WRKSRC}/doc/rfc/* ${PREFIX}/share/doc/bind9/rfc
1.25      itojun     60:        ${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
                     61:        (cd ${PREFIX}; ${FIND} share/doc/bind9 -type f -print ) >> ${PLIST_SRC}
                     62:        (cd ${PREFIX}; ${FIND} share/doc/bind9 -type d -print ) | \
1.38      taca       63:                ${SED} -e 's/^/@dirrm /' | ${SORT} -r >> ${PLIST_SRC}
1.1       hubertf    64:
1.58      snj        65: .include "../../mk/pthread.buildlink3.mk"
                     66: .include "../../security/openssl/buildlink3.mk"
1.1       hubertf    67: .include "../../mk/bsd.pkg.mk"
1.45      seb        68:
1.63      jklos      69: .if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "none") || \
                     70:        !empty(MACHINE_PLATFORM:MNetBSD-*-vax) || \
                     71:        !empty(MACHINE_PLATFORM:MNetBSD-*-m68k)
1.45      seb        72: CONFIGURE_ARGS+=       --disable-threads
                     73: .else
                     74: CONFIGURE_ARGS+=       --enable-threads
                     75: .endif

CVSweb <webmaster@jp.NetBSD.org>