[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / aria2

File: [cvs.NetBSD.org] / pkgsrc / net / aria2 / Makefile (download)

Revision 1.34, Tue Jul 3 19:39:47 2012 UTC (11 years, 8 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.33: +2 -3 lines

Update to 0.15.1

Changelog:
aria2 1.15.1
============

Release Note
------------

This release fixes the bug that prevents --bt-lpd-interface from
working. If some options sent by RPC request are not acceptable for
the download type, they are now simply ignored instead of rejecting
RPC request entirely. The aria2 RPC server now returns 4XX error code
if the request is not valid in the HTTP level. To improve packaging,
--with-bashcompletiondir configure option was added. This option
overrides where the aria2c bash_completion file is going to be
installed. All manual pages are now generated by Sphinx.

Changes
-------

* Return appropriate HTTP status code on RPC failure.  In this change,
  we return 404 if the request path is neither /json-rpc nor /rpc. If
  XML feature is not enabled and /rpc is requested, return 404.  If
  XML parser failed, return 400. JSON parser failure has been handled
  well in the existing code.

* Ignore unacceptable options in RPC request instead of throwing
  error.  This change allows RPC client to send same options for the
  different type of downloads.

* Handle sockaddr_in.sin_len and sockaddr_in6.sin6_len.  Check
  sockaddr_in.sin_len and sockaddr_in6.sin6_len are available and
  assign values to them properly.  This change fixes unit test error
  and most error related to getnameinfo() on netbsd.

* Removed dependency on inet_aton.  Implemented inetPton as a
  replacement of inet_aton. inetPton is implemented using
  net::getBinAddr.  This change fixes bug#3525424.

* Added --with-bashcompletiondir configure option.  By default,
  bash_completion file named aria2c is installed to the directory
  $prefix/share/doc/aria2/bash_completion.  To change the install
  directory of the file, use --with-bashcompletiondir option.

* Converted README.asciidoc into README.rst

* Use Sphinx for aria2 manual page documentation.  The source files
  for manual pages are placed under doc/manual-src.  The manual pages
  are generated under doc/manual-src/$LANG/_build. The HTML version
  manual page was dropped from the distribution archive.

* Fixed the bug which prevents --bt-lpd-interface from working.
  Fixes bug#3520125

# $NetBSD: Makefile,v 1.34 2012/07/03 19:39:47 ryoon Exp $
#

DISTNAME=	aria2-1.15.1
CATEGORIES=	net
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=aria2/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://aria2.sourceforge.net/
COMMENT=	Multi-threaded, multi-protocol, flexible download accelerator
LICENSE=	gnu-gpl-v2

PKG_DESTDIR_SUPPORT=	user-destdir

GNU_CONFIGURE=		yes
USE_LANGUAGES=		c c++
USE_PKGLOCALEDIR=	yes

CONFIGURE_ARGS+=	--enable-bittorrent
CONFIGURE_ARGS+=	--enable-metalink
CONFIGURE_ARGS+=	--with-included-gettext=no
CONFIGURE_ARGS+=	--with-libexpat
CONFIGURE_ARGS+=	--without-libxml2

GCC_REQD+=		3.4
TEST_TARGET=		check
USE_FEATURES=		getopt_long snprintf

.include "../../mk/compiler.mk"

.if !empty(PKGSRC_RUN_TEST:M[Yy][Ee][Ss])
BUILDLINK_DEPMETHOD.cppunit=	build
BUILDLINK_API_DEPENDS.cppunit+=	cppunit>=1.10.2
.  include "../../devel/cppunit/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-xmltest
.endif

.include "options.mk"

.include "../../devel/zlib/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../net/libcares/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"