[BACK]Return to distinfo CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / GeoIP

File: [cvs.NetBSD.org] / pkgsrc / net / GeoIP / distinfo (download)

Revision 1.15, Wed Oct 19 11:59:25 2016 UTC (7 years, 5 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.14: +5 -6 lines

Update net/GeoIP to 1.6.9.
Based on a PR by Jussi Sallinen.

1.6.9 2016-01-11

- Fix a regression introduced in version 1.6.8, which caused
  GeoIP_database_info to erroneously return NULL.

1.6.8 2016-01-11

- Allow compilation on older systems by relaxing the autoconf and automake
  minimum versions. Thank you, Jose Rubio!
- Avoid potential problems in multi-threaded environments by consistently using
  pread() rather than read().
- Fix various small issues reported by clang's static analyser.

1.6.7 2015-10-30

- Fixed a MSVC parser stack overflow when parsing `regionName.c` and
 `timeZone.c`. Fix by elliotlo. GitHub #64.
- Updated region codes and timezones.
- When using `GEOIP_MEMORY_CACHE` with an invalid database file, the search
  tree traversal could attempt to read memory outside of the memory allocated
  for the memory cache, resulting in a segmentation fault. A check was added
  to ensure that the traversal code does not try to read beyond the end of the
  file, whether in memory, memory mapped, or on disk.
- Previously the return values from file reads were ignored. We now check
  these values to ensure that there were no errors.


1.6.6 2015-07-28

- Replaced usage of deprecated fileno, read, and lseek on Visual Studio 2005+
  with their ISO C++ conformant replacements.
- A warning about using a double as a float was fixed.
- Fixed segfault when doing a lookup on an empty database.
- Fixed a memcheck error from valgrind in the `_check_mtime`
  function.
- Fixed `_check_mtime` to check the return value of `gettimeofday` rather than
  just assuming it worked.


1.6.5 2015-02-25

- A segmentation fault in `geoiplookup` was fixed when the utility was passed
  an invalid database.
- Additional validation was added for validation of the size used in the
  creation of the index cache.
- Changed the code to only look up country codes by using functions which
  ensure that we do not try to look past the end of an array.


1.6.4 2015-01-12

- Update Fips codes
- Several issues with the MinGW build were fixed.
- Use a constructor in pread.c to ensure the critical section is always
  initialized.
- Added missing include of `io.h` on Windows.
- Fixed `configure` warning that `'missing' script is too old or missing`.
- Previously `nmake /f Makefile.vc clean` would fail on Windows. This was
  fixed.
- Obsolete win32 and NetWare make files were removed.
- Numerous documentation updates.


1.6.3 2014-10-29

- Added a GEOIP_SILENCE flag. Include this flag when calling GeoIP_open to
  prevent any messages from being written to stderr.
- Mitigate a possible race condition when running under threads in the
  GeoIP_cleanup function.
- Added some recommendations to the docs on using this library in a
  threaded application.
- Fixed some bugs discovered by coverity, including failure to check some
  system call return values and making sure all strings are
  null-terminated.


1.6.2 2014-07-08

- Two files required for building on Win32 were missing from the 1.6.1
  release. These files were added. There are no changes affecting other
  platforms.


1.6.1 2014-06-26

- Improve Win32 support
- Update FIPS codes


1.6.0 2013-10-29

- Remove geoipupdate


1.5.2 2013-10-29

- Update region and time zones
- Fix benchmark script
- Remove autogenerated files ltmain.sh, man/geoip*.1
- Explain how to download free geolite databases in the README.md and
  GeoIP.conf.default
- geoipupdate returns 1 on error 0 on success instead of the error code
- README is replaced by README.md
- Add support for OS X Mavericks


1.5.1 2013-05-14

- Update time_zone for Ontario, Canada
- geoiplookup and geoiplookup6 exit code is 0 when user asked for help
- Added -h option to geoiplookup6
- Do not load the database file if nodes and file size do not make
  sense.
- Keep README and man pages in pure ascii.
- It doesn't make sense to use GEOIP_INDEX_MODE with small databases
  like GEOIP_COUNTRY_EDITION. Instead of undefined behaviour we handle
  it silently as GEOIP_MEMORY_MODE
- Update FIPS codes for Greece


1.5.0 2013-02-21

- Rename custom_directory to GeoIP_custom_directory.
- Make sure the database match the requested type. This is helpful for
  Databases with the same default name and the general geoiplookup form
  (geoiplookup without a specific database)
- apps/geoiplookup6.c use the ipnum instead of the hostname for lookups.
- Use configure.ac instead of configure.in
- Region lookup is a bit faster
- Add pkg-config file
- Updates required to build a Windows DLL under MinGW
- Make API thread safe
- geoiplookup's default charset is UTF8
  -l change the charset back to iso8859-1
- geoipupdate skips \r otherwise it might be part of the last
  product_id
- Update time zones
- Update Region codes
- Remove the unused CITYCONFIDENCE* database types
- bootstrap rebuilds ltmain.sh
- Update README.OSX for Lion
- Change Macedonia to Macedonia, The Former Yugoslav Republic of
- Add region_name to geoiplookup GEOIP_CITY_EDITION_REV1
- Add region_name to geoiplookup GEOIP_CITY_EDITION_REV0
- Add a --disable-data-files option. This allows you to build and install
  the library without having a data/GeoIP.dat file. This is useful when
  building the library from a checkout of the source tree, rather than a
  tarball
- Add GEOIP_ACCURACYRADIUS_EDITION and GEOIP_ACCURACYRADIUS_EDITION_V6
- Add more database types GEOIP_COUNTRYCONF_EDITION,
  GEOIP_CITYCONF_EDITION, GEOIP_REGIONCONF_EDITION and
  GEOIP_POSTALCONF_EDITION
- Fix default filenames for GEOIP_NETSPEED_EDITION_REV1 and
  GEOIP_NETSPEED_EDITION_REV1_V6

$NetBSD: distinfo,v 1.15 2016/10/19 11:59:25 fhajny Exp $

SHA1 (GeoIP-1.6.9.tar.gz) = ac0deb2309c14d5763e82fa4139de1f3193ab6b1
RMD160 (GeoIP-1.6.9.tar.gz) = 244fa293f86bc24df6a4b7a6643f111830faf1ed
SHA512 (GeoIP-1.6.9.tar.gz) = d9fc385db994d48066fb18e98ebaa882f80c04faf3d3e59004e3f05f455fd8c4b95041aeb5f197f3c2352ffe5c5913c58f0353fa16d2a1780cb0ccb5b7e8b986
Size (GeoIP-1.6.9.tar.gz) = 926978 bytes