[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / DarwinStreamingServer

Annotation of pkgsrc/net/DarwinStreamingServer/Makefile, Revision 1.10

1.10    ! wiz         1: # $NetBSD: Makefile,v 1.9 2011/08/14 14:14:40 obache Exp $
1.1       adam        2:
1.3       adam        3: DISTNAME=      DarwinStreamingSrvr5.5.5-Source
                      4: PKGNAME=       DarwinStreamingServer-5.5.5
1.10    ! wiz         5: PKGREVISION=   4
1.1       adam        6: CATEGORIES=    net multimedia
1.6       zafer       7: MASTER_SITES=  http://static.macosforge.org/dss/downloads/
1.1       adam        8:
                      9: MAINTAINER=    adam@NetBSD.org
1.6       zafer      10: HOMEPAGE=      http://dss.macosforge.org/
1.1       adam       11: COMMENT=       Open source version of Apple QuickTime Streaming Server
1.5       wiz        12: LICENSE=       apple-public-source-license
1.1       adam       13:
                     14: RESTRICTED=    Under APSL (see http://www.opensource.apple.com/apsl/).
                     15: NO_BIN_ON_CDROM=${RESTRICTED}
                     16: NO_BIN_ON_FTP= ${RESTRICTED}
                     17:
                     18: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     19:
                     20: USE_LANGUAGES= c c++
                     21:
                     22: MAKE_FILE=     Makefile.POSIX
                     23: MAKE_ENV+=     CCOMP=${CC:Q} CPLUS=${CXX:Q} LINKER=${CXX:Q}
                     24: MAKE_ENV+=     COMPILER_FLAGS=${CFLAGS:Q} INCLUDE_FLAG="-include"
                     25: MAKE_ENV+=     CORE_LINK_LIBS="-pthread -lm -lcrypt -lstdc++"
                     26: MAKE_ENV+=     SHARED="-shared" MODULE_LIBS="-lgcc -lstdc++"
                     27:
                     28: BUILD_DIRS=    CommonUtilitiesLib
                     29: BUILD_DIRS+=   QTFileLib
                     30: BUILD_DIRS+=   .
                     31: BUILD_DIRS+=   APIModules/QTSSRefMovieModule
                     32: BUILD_DIRS+=   APIModules/QTSSDemoAuthorizationModule.bproj
                     33: BUILD_DIRS+=   APIModules/QTSSRawFileModule.bproj
                     34: BUILD_DIRS+=   APIModules/QTSSSpamDefenseModule.bproj
                     35: BUILD_DIRS+=   APIModules/QTSSHomeDirectoryModule
                     36: BUILD_DIRS+=   StreamingProxy.tproj
                     37: BUILD_DIRS+=   qtpasswd.tproj
                     38: BUILD_DIRS+=   PlaylistBroadcaster.tproj
                     39: BUILD_DIRS+=   MP3Broadcaster
                     40: BUILD_DIRS+=   QTFileTools/QTBroadcaster.tproj
                     41: BUILD_DIRS+=   QTFileTools/QTFileInfo.tproj
                     42: BUILD_DIRS+=   QTFileTools/QTFileTest.tproj
                     43: BUILD_DIRS+=   QTFileTools/QTRTPFileTest.tproj
                     44: BUILD_DIRS+=   QTFileTools/QTRTPGen.tproj
                     45: BUILD_DIRS+=   QTFileTools/QTSDPGen.tproj
                     46: BUILD_DIRS+=   QTFileTools/QTSampleLister.tproj
                     47: BUILD_DIRS+=   QTFileTools/QTTrackInfo.tproj
                     48:
                     49: INSTALLATION_DIRS+=    libexec/StreamingServerModules
                     50: INSTALLATION_DIRS+=    share/examples/streaming
                     51: INSTALLATION_DIRS+=    share/streaming
                     52: INSTALLATION_DIRS+=    share/streaming/AdminHtml
                     53: INSTALLATION_DIRS+=    share/streaming/AdminHtml/images
                     54: INSTALLATION_DIRS+=    share/streaming/AdminHtml/includes
                     55: INSTALLATION_DIRS+=    share/streaming/AdminHtml/html_en
                     56: INSTALLATION_DIRS+=    share/streaming/movies
                     57: INSTALLATION_DIRS+=    share/streaming/playlists
                     58:
                     59: PKG_USERS=     qtss:qtss
                     60: PKG_GROUPS=    qtss
                     61: PKG_GECOS.qtss=        Darwin Streaming Server user
                     62:
                     63: INTERACTIVE_STAGE=     fetch build
                     64:
                     65: FETCH_MESSAGE= "Darwin Streaming Server is available as a free download"
                     66: FETCH_MESSAGE+=        "under the APSL. Downloading the source code components"
                     67: FETCH_MESSAGE+=        "requires APSL registration."
                     68: FETCH_MESSAGE+=        "You should fetch the source code manually from"
                     69: FETCH_MESSAGE+=        "${MASTER_SITES}${DISTFILES} and put into"
                     70: FETCH_MESSAGE+=        "${DISTDIR}/${DISTFILES} directory."
                     71:
                     72: REPLACE_PERL+= WebAdmin/WebAdminHtml/broadcaster_lib.pl
                     73: REPLACE_PERL+= WebAdmin/WebAdminHtml/parse_xml.cgi
                     74: REPLACE_PERL+= WebAdmin/WebAdminHtml/playlist-lib.pl
                     75: REPLACE_PERL+= WebAdmin/WebAdminHtml/relayxmlparser.pl
                     76: REPLACE_PERL+= WebAdmin/WebAdminHtml/startplaylists.pl
                     77: REPLACE_PERL+= WebAdmin/WebAdminHtml/view_broadcast.cgi
                     78: REPLACE_PERL+= WebAdmin/src/streamingadminserver.pl
                     79: REPLACE_PERL+= WinNTSupport/WinPasswdAssistant.pl
                     80:
                     81: CONF_FILES=    ${PKG_SYSCONFDIR:Q}/streaming/qtgroups ${PKG_SYSCONFDIR:Q}/streaming/qtgroups
                     82: CONF_FILES+=   ${PKG_SYSCONFDIR:Q}/streaming/qtusers ${PKG_SYSCONFDIR:Q}/streaming/qtusers
                     83: CONF_FILES+=   ${PKG_SYSCONFDIR:Q}/streaming/relayconfig.xml-Sample ${PKG_SYSCONFDIR:Q}/streaming/relayconfig.xml
                     84: CONF_FILES+=   ${PKG_SYSCONFDIR:Q}/streaming/streamingloadtool.conf ${PKG_SYSCONFDIR:Q}/streaming/streamingloadtool.conf
                     85: CONF_FILES+=   ${PKG_SYSCONFDIR:Q}/streaming/streamingserver.xml-POSIX ${PKG_SYSCONFDIR:Q}/streaming/streamingserver.xml
                     86:
                     87: SUBST_CLASSES+=                makefile
                     88: SUBST_STAGE.makefile=  post-patch
                     89: SUBST_MESSAGE.makefile=        Fixing Makefiles
                     90: SUBST_FILES.makefile+= APIModules/QTSSDemoAuthorizationModule.bproj/Makefile.POSIX
                     91: SUBST_FILES.makefile+= APIModules/QTSSHomeDirectoryModule/Makefile.POSIX
                     92: SUBST_FILES.makefile+= APIModules/QTSSRawFileModule.bproj/Makefile.POSIX
                     93: SUBST_FILES.makefile+= APIModules/QTSSRefMovieModule/Makefile.POSIX
                     94: SUBST_FILES.makefile+= APIModules/QTSSSpamDefenseModule.bproj/Makefile.POSIX
1.3       adam       95: SUBST_FILES.makefile+= APIStubLib/makefile.apistublib.POSIX
1.1       adam       96: SUBST_FILES.makefile+= CommonUtilitiesLib/Makefile.POSIX
                     97: SUBST_FILES.makefile+= HTTPUtilitiesLib/Makefile.POSIX
                     98: SUBST_FILES.makefile+= MP3Broadcaster/Makefile.POSIX
                     99: SUBST_FILES.makefile+= Makefile.POSIX
                    100: SUBST_FILES.makefile+= PlaylistBroadcaster.tproj/Makefile.POSIX
                    101: SUBST_FILES.makefile+= QTFileLib/Makefile.POSIX
                    102: SUBST_FILES.makefile+= QTFileTools/QTBroadcaster.tproj/Makefile.POSIX
                    103: SUBST_FILES.makefile+= QTFileTools/QTFileInfo.tproj/Makefile.POSIX
                    104: SUBST_FILES.makefile+= QTFileTools/QTFileTest.tproj/Makefile.POSIX
                    105: SUBST_FILES.makefile+= QTFileTools/QTRTPFileTest.tproj/Makefile.POSIX
                    106: SUBST_FILES.makefile+= QTFileTools/QTRTPGen.tproj/Makefile.POSIX
                    107: SUBST_FILES.makefile+= QTFileTools/QTSDPGen.tproj/Makefile.POSIX
                    108: SUBST_FILES.makefile+= QTFileTools/QTSampleLister.tproj/Makefile.POSIX
                    109: SUBST_FILES.makefile+= QTFileTools/QTTrackInfo.tproj/Makefile.POSIX
                    110: SUBST_FILES.makefile+= StreamingProxy.tproj/Makefile.POSIX
                    111: SUBST_FILES.makefile+= qtpasswd.tproj/Makefile.POSIX
1.3       adam      112: SUBST_SED.makefile+=   -e "s|-O[023]||"
1.1       adam      113:
                    114: SUBST_CLASSES+=                path
                    115: SUBST_STAGE.path=      post-patch
                    116: SUBST_MESSAGE.path=    Fixing paths
                    117: SUBST_FILES.path+=     defaultPaths.h
                    118: SUBST_FILES.path+=     WebAdmin/src/streamingadminserver.pl
                    119: SUBST_FILES.path+=     streamingserver.xml-POSIX
                    120: SUBST_SED.path+=       -e "s|/etc/streaming|${PKG_SYSCONFDIR}/streaming|"
                    121: SUBST_SED.path+=       -e "s|/movies|/share/streaming/movies|"
                    122: SUBST_SED.path+=       -e "s|/usr/local|${PREFIX}|"
1.2       adam      123: SUBST_SED.path+=       -e "s|/sbin/StreamingServer|/libexec/StreamingServer|"
1.1       adam      124: SUBST_SED.path+=       -e "s|/var/streaming/AdminHtml|${PREFIX}/share/streaming/AdminHtml|"
                    125: SUBST_SED.path+=       -e "s|/var/streaming/playlists|${PREFIX}/share/streaming/playlists|"
                    126: SUBST_SED.path+=       -e "s|/var/streaming/logs|${VARBASE}/log/streaming|"
                    127:
                    128: SUBST_CLASSES+=                conf
                    129: SUBST_STAGE.conf=      post-patch
                    130: SUBST_MESSAGE.conf=    Fixing configuration file
                    131: SUBST_FILES.conf+=     WebAdmin/streamingadminserver.conf
                    132: SUBST_SED.conf+=       -e "s|/Library/QuickTimeStreaming/AdminHtml|${PREFIX}/share/streaming/AdminHtml|"
                    133: SUBST_SED.conf+=       -e "s|/Library/QuickTimeStreaming/playlists|${PREFIX}/share/streaming/playlists|"
                    134: SUBST_SED.conf+=       -e "s|/Library/QuickTimeStreaming/Logs|${VARBASE}/log/streaming|"
                    135: SUBST_SED.conf+=       -e "s|/usr/sbin/QuickTime|${PREFIX}/sbin/Darwin|"
                    136:
                    137: post-extract:
                    138:        rm -rf ${WRKSRC}/*PackageMetaData
                    139:
1.7       abs       140: PKG_DESTDIR_SUPPORT=   user-destdir
                    141:
1.1       adam      142: do-install:
1.7       abs       143:        ${INSTALL_PROGRAM} ${WRKSRC}/DarwinStreamingServer ${DESTDIR}${PREFIX}/sbin
                    144:        ${INSTALL_PROGRAM} ${WRKSRC}/PlaylistBroadcaster.tproj/PlaylistBroadcaster ${DESTDIR}${PREFIX}/bin
                    145:        ${INSTALL_PROGRAM} ${WRKSRC}/MP3Broadcaster/MP3Broadcaster ${DESTDIR}${PREFIX}/bin
                    146:        ${INSTALL_PROGRAM} ${WRKSRC}/qtpasswd.tproj/qtpasswd ${DESTDIR}${PREFIX}/bin
                    147:        ${INSTALL_PROGRAM} ${WRKSRC}/APIModules/QTSSHomeDirectoryModule/QTSSHomeDirectoryModule ${DESTDIR}${PREFIX}/libexec/StreamingServerModules
                    148:        ${INSTALL_PROGRAM} ${WRKSRC}/APIModules/QTSSRefMovieModule/QTSSRefMovieModule ${DESTDIR}${PREFIX}/libexec/StreamingServerModules
                    149:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTBroadcaster.tproj/QTBroadcaster ${DESTDIR}${PREFIX}/bin
                    150:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTFileTest.tproj/QTFileTest ${DESTDIR}${PREFIX}/bin
                    151:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTRTPFileTest.tproj/QTRTPFileTest ${DESTDIR}${PREFIX}/bin
                    152:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTRTPGen.tproj/QTRTPGen ${DESTDIR}${PREFIX}/bin
                    153:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTSampleLister.tproj/QTSampleLister ${DESTDIR}${PREFIX}/bin
                    154:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTSDPGen.tproj/QTSDPGen ${DESTDIR}${PREFIX}/bin
                    155:        ${INSTALL_PROGRAM} ${WRKSRC}/QTFileTools/QTTrackInfo.tproj/QTTrackInfo ${DESTDIR}${PREFIX}/bin
                    156:        ${INSTALL_SCRIPT} ${WRKSRC}/APIModules/QTSSHomeDirectoryModule/createuserstreamingdir ${DESTDIR}${PREFIX}/bin
                    157:        ${INSTALL_DATA} ${WRKSRC}/streamingserver.xml-POSIX ${DESTDIR}${PREFIX}/share/examples/streaming
                    158:        ${INSTALL_DATA} ${WRKSRC}/relayconfig.xml-Sample ${DESTDIR}${PREFIX}/share/examples/streaming
                    159:        ${INSTALL_DATA} ${WRKSRC}/qtusers ${DESTDIR}${PREFIX}/share/examples/streaming
                    160:        ${INSTALL_DATA} ${WRKSRC}/qtgroups ${DESTDIR}${PREFIX}/share/examples/streaming
                    161:        ${INSTALL_DATA} ${WRKSRC}/Documentation/readme.txt ${DESTDIR}${PREFIX}/share/streaming
                    162:        ${INSTALL_DATA} ${WRKSRC}/Documentation/3rdPartyAcknowledgements.rtf ${DESTDIR}${PREFIX}/share/streaming
                    163:        ${INSTALL_SCRIPT} ${WRKSRC}/WebAdmin/src/streamingadminserver.pl ${DESTDIR}${PREFIX}/sbin
                    164:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/*.pl ${DESTDIR}${PREFIX}/share/streaming/AdminHtml
                    165:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/*.cgi ${DESTDIR}${PREFIX}/share/streaming/AdminHtml
                    166:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/*.html ${DESTDIR}${PREFIX}/share/streaming/AdminHtml
                    167:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/images/*.gif ${DESTDIR}${PREFIX}/share/streaming/AdminHtml/images
                    168:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/includes/*.js ${DESTDIR}${PREFIX}/share/streaming/AdminHtml/includes
                    169:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/html_en/messages ${DESTDIR}${PREFIX}/share/streaming/AdminHtml/html_en
                    170:        ${INSTALL_DATA} ${WRKSRC}/WebAdmin/WebAdminHtml/html_en/genres ${DESTDIR}${PREFIX}/share/streaming/AdminHtml/html_en
                    171:        ${INSTALL_DATA} ${WRKSRC}/sample* ${DESTDIR}${PREFIX}/share/streaming/movies
1.1       adam      172:
                    173: .include "../../lang/perl5/buildlink3.mk"
                    174: .include "../../mk/pthread.buildlink3.mk"
                    175: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>