The NetBSD Project

CVS log for pkgsrc/multimedia/x265/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / x265

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.42: download - view: text, markup, annotated - select for diffs
Sun Nov 24 06:55:24 2024 UTC (3 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
Diff to: previous 1.41: preferred, colored
Changes since revision 1.41: +2 -2 lines
x265: updated to 4.1

Version 4.1
===========

New feature
-----------
1. Aom Film-Grain characteristics as a SEI message to support Film Grain Synthesis.

API changes
-----------
1. API Support to enable VBV end feature.
2. Reverted the 4.0 api changes.
3. Added command line parameters for Aom film grain characteristics as a SEI message to the bitstream (--aom-film-grain).
4. Added support to configure Bitrate, CRF, and QP at frame level, along with CLI support for frame-level RC configuration (--frame-rc)
5. Declared few params(numapools, csvfn, scalingLists etc) with fixed size to fix memory leaks

Optimizations
-------------
1. Eliminated redundant pointer copies in lowresMC and lowresQPelCost, improving encoding performance by up to 0.9% on modern CPUs.
2. Mcstf optimization - Improved mcstf performance by moving mcstf computation to lookahead and search range optimization.

Bug fixes
---------
1. mcstf crash when using multiple frame threads.
2. CLI parsing for MV-HEVC Encode.
3. segfault and decoder crash in scc.
4. compilation issue in clang.
5. potential stack buffer overflow issues.
6. documentation for b-intra, max-merge, limit-refs and qg-size
7. memory leak fixes for sei, zones, sao, hme, vbv, sbrc, mcstf, alpha, multiview, scc, two pass, rskip, film grain, aq-mode, scaling_list, fades, analysis save and load etc

Known issues
------------
1. Inconsistent output with recon option
2. Output mismatch between analysis save & load with cutree for reuse-levels < 10

Revision 1.41: download - view: text, markup, annotated - select for diffs
Sun Sep 15 08:22:29 2024 UTC (6 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.40: preferred, colored
Changes since revision 1.40: +2 -3 lines
x265: updated to 4.0

Version 4.0
Release date - 13th September, 2024.

New feature

Alpha Channel feature.
Screen Content Coding (SCC).
MV-HEVC feature.

Enhancements to existing features

Added support for the VMAF v3.x.

API changes

Add command line parameter for Alpha Channel feature :option:`--alpha`.
Add command line parameter for SCC feature :option:`--scc 1`.
Add command line parameters for the MV-HEVC feature :option:`--multiview-config "multiview_config.txt"`.

Optimizations

Arm SIMD optimizations: Several time-consuming scalar C functions now have SIMD implementations on Arm platforms. Existing Arm SIMD implementations have also been optimized. These optimizations result in up to 57% faster encoding compared to release 3.6.
Arm SIMD optimizations include use of Armv8.4 DotProd, Armv8.6 I8MM, and Armv9 SVE2 instruction set extensions. The following algorithms now have optimized SIMD implementations: SAD, SSE, DCT, SAO, convolution, quantization, intra_planar, intraFilter, intrapred DC and IDCT16x16.

Bug fixes

Fix for y4m pipe input broken.
Fix SCC crash on multipass encode.
Fix mcstf when :option:`--bframes` value was less than 5.
Fix lowpass DCT for high bit depth.
Added build support for Visual Studio 17.
Fix issue in default code flow and memory leak.
Framethreads tuning for Windows ARM devices.
Fix scc crash on multipass encode.

Revision 1.40: download - view: text, markup, annotated - select for diffs
Sun Aug 25 06:19:05 2024 UTC (6 months, 4 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.39: preferred, colored
Changes since revision 1.39: +9 -9 lines
*: replace CMAKE_ARGS with CMAKE_CONFIGURE_ARGS

Revision 1.39: download - view: text, markup, annotated - select for diffs
Fri Apr 5 13:45:50 2024 UTC (11 months, 2 weeks ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.38: preferred, colored
Changes since revision 1.38: +10 -2 lines
multimedia/x265: Follow upstream tarball replace

Revision 1.38: download - view: text, markup, annotated - select for diffs
Fri Apr 5 09:22:33 2024 UTC (11 months, 2 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.37: preferred, colored
Changes since revision 1.37: +9 -9 lines
x265: updated to 3.6

Version 3.6
===========

Release date - 4th April, 2024.

New feature
-----------
1. Segment based Ratecontrol (SBRC) feature
2. Motion-Compensated Spatio-Temporal Filtering
3. Scene-cut aware qp - BBAQ (Bidirectional Boundary Aware Quantization)
4. Histogram-Based Scene Change Detection
5. Film-Grain characteristics as a SEI message to support Film Grain Synthesis(FGS)
6. Add temporal layer implementation(Hierarchical B-frame implementation)

Enhancements to existing features
---------------------------------
1. Added Dolby Vision 8.4 Profile Support


API changes
-----------
1. Add Segment based Ratecontrol(SBRC) feature: "--[no-]sbrc".
2. Add command line parameter for mcstf feature: "--[no-]mctf".
3. Add command line parameters for the scene cut aware qp feature: "--scenecut-aware-qp" and "--masking-strength".
4. Add command line parameters for Histogram-Based Scene Change Detection: "--hist-scenecut".
5. Add film grain characteristics as a SEI message to the bitstream: "--film-grain <filename>"
6. cli: add new option --cra-nal (Force nal type to CRA to all frames expect for the first frame, works only with keyint 1)

Optimizations
---------------------
ARM64 NEON optimizations:- Several time-consuming C functions have been optimized for the targeted platform - aarch64. The overall performance increased by around 20%.
SVE/SVE2 optimizations


Bug fixes
---------
1. Linux bug to utilize all the cores
2. Crash with hist-scenecut build when source resolution is not multiple of minCuSize
3. 32bit and 64bit builds generation for ARM
4. bugs in zonefile feature (Reflect Zonefile Parameters inside Lookahead, extra IDR issue, Avg I Slice QP value issue etc..)
5. Add x86 ASM implementation for subsampling luma
6. Fix for abrladder segfault with load reuse level 1
7. Reorder miniGOP based on temporal layer hierarchy and add support for more B frame
8. Add MacOS aarch64 build support
9. Fix boundary condition issue for Gaussian filter

Revision 1.37: download - view: text, markup, annotated - select for diffs
Fri Jan 26 03:16:46 2024 UTC (13 months, 4 weeks ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.36: preferred, colored
Changes since revision 1.36: +8 -1 lines
multimedia/x265: Fix cross-build.

Revision 1.36: download - view: text, markup, annotated - select for diffs
Tue Jan 24 18:36:31 2023 UTC (2 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.35: preferred, colored
Changes since revision 1.35: +2 -2 lines
*: convert to cmake/build.mk

Revision 1.35: download - view: text, markup, annotated - select for diffs
Sat Jun 12 08:18:14 2021 UTC (3 years, 9 months ago) by cirnatdan
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.34: preferred, colored
Changes since revision 1.34: +2 -2 lines
x265: Disable assembly on FreeBSD

according to patch submitted by Yoshihiro Ota in P$ pkg/56236

Revision 1.34: download - view: text, markup, annotated - select for diffs
Sat Apr 10 08:36:03 2021 UTC (3 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.33: preferred, colored
Changes since revision 1.33: +13 -11 lines
x265: updated to 3.5

Version 3.5

New feature

Real-time VBV for ABR (Average BitRate) encodes in –pass 2 using --vbv-live-multi-pass: Improves VBV compliance with no significant impact on coding efficiency.

Enhancements to existing features

Improved hist-based scene cut algorithm: Reduces false positives by leveraging motion and scene transition info.
Support for RADL pictures at IDR scene cuts: Improves coding efficiency with no significant impact on performance.
Bidirectional scene cut aware Frame Quantizer Selection: Saves bits than forward masking with no noticeable perceptual quality difference.

API changes

Additions to x265_param structure to support the newly added features and encoder enhancements.
New x265_param options --min-vbv-fullness and --max-vbv-fullness to control min and max VBV fullness.

Bug fixes

Incorrect VBV lookahead in --analysis-load + --scale-factor.
Encoder hang when VBV is used with slices.
QP spikes in the row-level VBV rate-control when WPP enabled.
Encoder crash in --abr-ladder.

Revision 1.33: download - view: text, markup, annotated - select for diffs
Thu Oct 29 23:58:07 2020 UTC (4 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.32: preferred, colored
Changes since revision 1.32: +3 -1 lines
x265: include bsd.prefs.mk before checking platform

Revision 1.32: download - view: text, markup, annotated - select for diffs
Thu Oct 29 21:47:39 2020 UTC (4 years, 4 months ago) by nia
Branches: MAIN
Diff to: previous 1.31: preferred, colored
Changes since revision 1.31: +2 -2 lines
x265: fix operator

Revision 1.31: download - view: text, markup, annotated - select for diffs
Thu Oct 29 21:47:00 2020 UTC (4 years, 4 months ago) by nia
Branches: MAIN
Diff to: previous 1.30: preferred, colored
Changes since revision 1.30: +8 -2 lines
x265: Avoid text relocations on i386

PR pkg/55766

Revision 1.30: download - view: text, markup, annotated - select for diffs
Sat May 30 06:10:40 2020 UTC (4 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.29: preferred, colored
Changes since revision 1.29: +2 -2 lines
x265: updated to 3.4

Version 3.4

New features
------------
Edge-aware quadtree partitioning to terminate CU depth recursion based on edge information. --rskip level 2 enables the feature and --rskip-edge-threshold denotes the minimum expected edge-density percentage within the CU, below which the recursion is skipped. Experimental feature.
Application-level feature --abr-ladder for automating efficient ABR ladder generation. Shows ~65% savings in the over-all turn-around time required for the generation of a typical Apple HLS ladder in Intel(R) Xeon(R) Platinum 8280 CPU @ 2.70GHz over a sequential ABR-ladder generation approach that leverages save-load architecture.

Enhancements to existing features
---------------------------------
Improved efficiency in 2-pass rate-control algorithm. The savings in the bitrate is ~1.72% with visual improvement in quality in the initial 1-2 secs.

Encoder enhancements
--------------------
Faster ARM64 encodes enabled by ASM contributions from Huawei. The speed-up over no-asm version for 1080p encodes @ medium preset is ~15% in a 16 core H/W.
Strict VBV conformance in zone encoding.

Bug fixes
---------
Multi-pass encode failures with --frame-dup.
Corrupted bitstreams with --hist-scenecut when input depth and internal bit-depth differ.
Incorrect analysis propagation in multi-level save-load architecture.
Failure in detecting NUMA packages installed in non-standard directories.

Revision 1.29: download - view: text, markup, annotated - select for diffs
Mon Mar 30 15:40:15 2020 UTC (4 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.28: preferred, colored
Changes since revision 1.28: +2 -3 lines
x265: updated to 3.3

Version 3.3

New features
Adaptive frame duplication to identify and skip encoding of near-identical frames and signal the duplication info to the decoder via pic_struct SEI. frame-dup to enable frame duplication and --dup-threshold to set the threshold for frame similarity (optional).
Boundary aware quantization to cut off bits from frames following scene-cut. This leverages the inability of HVS to perceive fine details during scene changes and saves bits. --scenecut-aware-qp , --scenecut-window and --max-qp-delta to enable boundary aware frame quantization, to set window size (optional) and to set QP offset (optional).
Improved scene-cut detection using edge and chroma histograms. --hist-scenecut to enable the feature and --hist-threshold (optional) to provide threshold for determining scene cuts.

Enhancements to existing features
--hme-range to modify search range for HME levels L0, L1, and L2.
Improved performance of AQ mode 4 by reducing memory foot print.
Introduced --analysis-save-reuse-level and --analysis-load-reuse-level to de-couple reuse levels of --analysis-save and --analysis-load. Turnaround time of ABR encoding can be reduced by properly leveraging these options.

Encoder enhancements
Improved VBV lookahead to eliminate blocky artifacts in Intra frames coming towards end of the title.

API changes
New API function x265_encoder_reconfig_zone() to invoke zone reconfiguration dynamically.
Renamed --hdr to --hdr10. --hdr will be deprecated in the upcoming major release.
Renamed --hdr-opt to --hdr10-opt. --hdr-opt will be deprecated in the upcoming major release.
Additions to x265_param structure to support the newly added features and encoder enhancements.

Revision 1.28: download - view: text, markup, annotated - select for diffs
Thu Dec 5 09:32:49 2019 UTC (5 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +2 -2 lines
x265: updated to 3.2.1

3.2.1:
No release notes.

Revision 1.27: download - view: text, markup, annotated - select for diffs
Tue Oct 1 11:44:46 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +2 -2 lines
x265: updated to 3.2

Version 3.2

New features
1. 3-level hierarchical motion estimation using :option:`--hme` and :option:`--hme-search`.
2. New AQ mode (:option:`--aq-mode` 4) with variance and edge information.
3. :option:`selective-sao` to selectively enable SAO at slice level.

Enhancements to existing features
1. New implementation of :option:`--refine-mv` with 3 refinement levels.

Encoder enhancements
1. Improved quality in the frames following dark scenes in ABR mode.

API changes
1. Additions to x265_param structure to support the newly added features :option:`--hme`, :option:`--hme-search` and :option:`selective-sao`.

Bug fixes
1. Fixed encoder crash with :option:`--zonefile` during failures in encoder_open().
2. Fixed JSON11 build errors with HDR10+ on MacOS high sierra.
3. Signalling out of range scaling list data fixed.
4. Inconsistent output fix for 2-pass rate-control with cutree ON.

Known issues
1. Build dependency on changeset cf37911 of SVT-HEVC.

Revision 1.26: download - view: text, markup, annotated - select for diffs
Wed Jul 10 09:00:57 2019 UTC (5 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +2 -2 lines
x265: updated to 3.1.1

Version 3.1

New features
* x265 can invoke SVT-HEVC library for encoding through --svt.
* x265 can now accept interlaced inputs directly (no need to separate fields), and sends it to the encoder with proper fps and frame-size through --field.
* --fades can detect and handle fade-in regions. This option will force I-slice and initialize RC history for the brightest frame after fade-in.

API changes
* A new flag to signal MasterDisplayParams and maxCll/Fall separately

Encoder enhancements
* Improved the performance of inter-refine level 1 by skipping the evaluation of smaller CUs when the current block is decided as “skip” by the save mode.
* New AVX2 primitives to improve the performance of encodes that enable --ssim-rd.
* Improved performance in medium preset with negligible loss in quality.

Bug fixes
* Bug fixes for zones.
* Fixed wrap-around from MV structure overflow occurred around 8K pixels or over.
* Fixed issues in configuring cbQpOffset and crQpOffset for 444 input
* Fixed cutree offset computation in 2nd pass encodes.

Known issues
* AVX512 main12 asm disabling.
* Inconsistent output with 2-pass due to cutree offset sharing.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Fri Jan 25 09:01:13 2019 UTC (6 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +2 -2 lines
x265: updated to 3.0

Version 3.0

New features
option:: ‘–dolby-vision-profile <integer|float>’ generates bitstreams confirming to the specified Dolby Vision profile. Currently profile 5, profile 8.1 and profile 8.2 enabled, Default 0 (disabled)
option:: ‘–dolby-vision-rpu’ File containing Dolby Vision RPU metadata. If given, x265’s Dolby Vision metadata parser will fill the RPU field of input pictures with the metadata
read from the file. The library will interleave access units with RPUs in the bitstream. Default NULL (disabled).
option:: ‘–zonefile <filename>’ specifies a text file which contains the boundaries of the zones where each of zones are configurable.
option:: ‘–qp-adaptation-range’ Delta-QP range by QP adaptation based on a psycho-visual model. Default 1.0.
option:: ‘–refine-ctu-distortion <0/1>’ store/normalize ctu distortion in analysis-save/load. Default 0.
Experimental feature option:: ‘–hevc-aq’ enables adaptive quantization
It scales the quantization step size according to the spatial activity of one coding unit relative to frame average spatial activity. This AQ method utilizes the minimum variance of sub-unit in each coding unit to represent the coding unit’s spatial complexity.

Encoder enhancements
Preset: change param defaults for veryslow and slower preset. Replace slower preset with defaults used in veryslow preset and change param defaults in veryslow preset as per experimental results.
AQ: change default AQ mode to auto-variance
Cutree offset reuse: restricted to analysis reuse-level 10 for analysis-save -> analysis-load
Tune: introduce –tune animation option which improves encode quality for animated content
Reuse CU depth for B frame and allow I, P frame to follow x265 depth decision

Bug fixes
RC: fix rowStat computation in const-vbv
Dynamic-refine: fix memory reset size.
Fix linking issue on non x86 platform
Encoder: Do not include CLL SEI message if empty
Fix build error in VMAF lib

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sat Oct 6 12:12:48 2018 UTC (6 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +4 -2 lines
x265: updated to 2.9

Version 2.9

New features
1. Support for chunked encoding
   :option:`--chunk-start and --chunk-end`
   Frames preceding first frame of chunk in display order will be encoded, however, they will be discarded in the bitstream.
   Frames following last frame of the chunk in display order will be used in taking lookahead decisions, but, they will not be encoded.
   This feature can be enabled only in closed GOP structures. Default disabled.
2. Support for HDR10+ version 1 SEI messages.

Encoder enhancements
1. Create API function for allocating and freeing x265_analysis_data.
2. CEA 608/708 support: Read SEI messages from text file and encode it using userSEI message.

Bug fixes
1. Disable noise reduction when vbv is enabled.
2. Support minLuma and maxLuma values changed by the commandline.

Revision 1.23: download - view: text, markup, annotated - select for diffs
Tue Jul 31 19:13:10 2018 UTC (6 years, 7 months ago) by rjs
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +3 -1 lines
Only need nasm when building for x86.

Revision 1.22: download - view: text, markup, annotated - select for diffs
Mon May 21 20:03:56 2018 UTC (6 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
x265: updated to 2.8

Version 2.8

New features
1. :option:--asm avx512 used to enable AVX-512 in x265. Default disabled.
    For 4K main10 high-quality encoding, we are seeing good gains; for other resolutions and presets, we don't recommend using this setting for now.

2. :option:--dynamic-refine dynamically switches between different inter refine levels. Default disabled.
    It is recommended to use :option:--refine-intra 4' with dynamic refinement for a better trade-off between encode efficiency and performance than using static refinement.

3. :option:--single-sei
    Encode SEI messages in a single NAL unit instead of multiple NAL units. Default disabled.

4. :option:--max-ausize-factor controls the maximum AU size defined in HEVC specification.
    It represents the percentage of maximum AU size used. Default is 1.

5. VMAF (Video Multi-Method Assessment Fusion)
   Added VMAF support for objective quality measurement of a video sequence.
   Enable cmake option ENABLE_LIBVMAF to report per frame and aggregate VMAF score. The frame level VMAF score does not include temporal scores.
   This is supported only on linux for now.

Encoder enhancements
1. Introduced refine-intra level 4 to improve quality.
2. Support for HLG-graded content and pic_struct in SEI message.

Bug Fixes
1. Fix 32 bit build error (using CMAKE GUI) in Linux.
2. Fix 32 bit build error for asm primitives.
3. Fix build error on mac OS.
4. Fix VBV Lookahead in analysis load to achieve target bitrate.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Fri Mar 9 12:08:08 2018 UTC (7 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +4 -4 lines
x265: updated to 2.7

Version 2.7

New features
1. :option:--gop-lookahead can be used to extend the gop boundary(set by --keyint). The GOP will be extended, if a scene-cut frame is found within this many number of frames.
2. Support for RADL pictures added in x265.
   :option:--radl can be used to decide number of RADL pictures preceding the IDR picture.

Encoder enhancements
1. Moved from YASM to NASM assembler. Supports NASM assembler version 2.13 and greater.
2. Enable analysis save and load in a single run. Introduces two new cli options --analysis-save <filename> and --analysis-load <filename>.
3. Comply to HDR10+ LLC specification.
4. Reduced x265 build time by more than 50% by re-factoring ipfilter.asm.

Bug fixes
1. Fixed inconsistent output issue in deblock filter and --const-vbv.
2. Fixed Mac OS build warnings.
3. Fixed inconsistency in pass-2 when weightp and cutree are enabled.
4. Fixed deadlock issue due to dropping of BREF frames, while forcing slice types through qp file.

Revision 1.20: download - view: text, markup, annotated - select for diffs
Thu Nov 30 07:38:55 2017 UTC (7 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +3 -3 lines
x265: updated to 2.6

Version 2.6
===========

New features
------------
1. x265 can now refine analysis from a previous HEVC encode (using options :option:`--refine-inter`, and :option:`--refine-intra`), or a previous AVC encode (using option :option:`--refine-mv-type`). The previous encode's information can be packaged using the *x265_analysis_data_t*  data field available in the *x265_picture* object.
2. Basic support for segmented (or chunked) encoding added with :option:`--vbv-end` that can specify the status of CPB at the end of a segment. String this together with :option:`--vbv-init` to encode a title as chunks while maintaining VBV compliance!
3. :option:`--force-flush` can be used to trigger a premature flush of the encoder. This option is beneficial when input is known to be bursty, and may be at a rate slower than the encoder.
4. Experimental feature :option:`--lowpass-dct` that uses truncated DCT for transformation.

Encoder enhancements
--------------------
1. Slice-parallel mode gets a significant boost in performance, particularly in low-latency mode.
2. x265 now officially supported on VS2017.
3. x265 now supports all depths from mono0 to mono16 for Y4M format.

API changes
-----------
1. Options that modified PPS dynamically (:option:`--opt-qp-pps` and :option:`--opt-ref-list-length-pps`) are now disabled by default to enable users to save bits by not sending headers. If these options are enabled, headers have to be repeated for every GOP.
2. Rate-control and analysis parameters can dynamically be reconfigured simultaneously via the *x265_encoder_reconfig* API.
3. New API functions to extract intermediate information such as slice-type, scenecut information, reference frames, etc. are now available. This information may be beneficial to integrating applications that are attempting to perform content-adaptive encoding. Refer to documentation on *x265_get_slicetype_poc_and_scenecut*, and *x265_get_ref_frame_list* for more details and suggested usage.
4. A new API to pass supplemental CTU information to x265 to influence analysis decisions has been added. Refer to documentation on *x265_encoder_ctu_info* for more details.

Bug fixes
---------
1. Bug fixes when :option:`--slices` is used with VBV settings.
2. Minor memory leak fixed for HDR10+ builds, and default x265 when pools option is specified.
3. HDR10+ bug fix to remove dependence on poc counter to select meta-data information.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Fri Jul 14 07:56:57 2017 UTC (7 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
Version 2.5

Encoder enhancements
--------------------
1. Improved grain handling with :option:`--tune` grain option by throttling VBV operations to limit QP jumps.
2. Frame threads are now decided based on number of threads specified in the :option:`--pools`, as opposed to the number of hardware threads available. The mapping was also adjusted to improve quality of the encodes with minimal impact to performance.
3. CSV logging feature (enabled by :option:`--csv`) is now part of the library; it was previously part of the x265 application. Applications that integrate libx265 can now extract frame level statistics for their encodes by exercising this option in the library.
4.  Globals that track min and max CU sizes, number of slices, and other parameters have now been moved into instance-specific variables. Consequently, applications that invoke multiple instances of x265 library are no longer restricted to use the same settings for these parameter options across the multiple instances.
5. x265 can now generate a seprate library that exports the HDR10+ parsing API. Other libraries that wish to use this API may do so by linking against this library. Enable ENABLE_HDR10_PLUS in CMake options and build to generate this library.
6. SEA motion search receives a 10% performance boost from AVX2 optimization of its kernels.
7. The CSV log is now more elaborate with additional fields such as PU statistics, average-min-max luma and chroma values, etc. Refer to documentation of :option:`--csv` for details of all fields.
8. x86inc.asm cleaned-up for improved instruction handling.

API changes
-----------
1. New API x265_encoder_ctu_info() introduced to specify suggested partition sizes for various CTUs in a frame. To be used in conjunction with :option:`--ctu-info` to react to the specified partitions appropriately.
2. Rate-control statistics passed through the x265_picture object for an incoming frame are now used by the encoder.
3. Options to scale, reuse, and refine analysis for incoming analysis shared through the x265_analysis_data field in x265_picture for runs that use :option:`--analysis-reuse-mode` load; use options :option:`--scale`, :option:`--refine-mv`, :option:`--refine-inter`, and :option:`--refine-intra` to explore.
4. VBV now has a deterministic mode. Use :option:`--const-vbv` to exercise.

Bug fixes
---------
1. Several fixes for HDR10+ parsing code including incompatibility with user-specific SEI, removal of warnings, linking issues in linux, etc.
2. SEI messages for HDR10 repeated every keyint when HDR options (:option:`--hdr-opt`, :option:`--master-display`) specified.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Apr 25 18:29:57 2017 UTC (7 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
Version 2.4
===========

Encoder enhancements
--------------------
1. HDR10+ supported. Dynamic metadata may be either supplied as a bitstream via the userSEI field of x265_picture, or as a json jile that can be parsed by x265 and inserted into the bitstream; use :option:`--dhdr10-info` to specify json file name, and :option:`--dhdr10-opt` to enable optimization of inserting tone-map information only at IDR frames, or when the tone map information changes.
2. Lambda tables for 8, 10, and 12-bit encoding revised, resulting in significant enhancement to subjective  visual quality.
3. Enhanced HDR10 encoding with HDR-specific QP optimzations for chroma, and luma planes of WCG content enabled; use :option:`--hdr-opt` to activate.
4. Ability to accept analysis information from other previous encodes (that may or may not be x265), and selectively reuse and refine analysis for encoding subsequent passes enabled with the :option:`--refine-level` option.
5. Slow and veryslow presets receive a 20% speed boost at iso-quality by enabling the :option:`--limit-tu` option.
6. The bitrate target for x265 can now be dynamically reconfigured via the reconfigure API.
7. Performance optimized SAO algorithm introduced via the :option:`--limit-sao` option; seeing 10% speed benefits at faster presets.

API changes
-----------
1. x265_reconfigure API now also accepts rate-control parameters for dynamic reconfiguration.
2. Several additions to data fields in x265_analysis to support :option:`--refine-level`: see x265.h for more details.

Bug fixes
---------
1. Avoid negative offsets in x265 lambda2 table with SAO enabled.
2. Fix mingw32 build error.
3. Seek now enabled for pipe input, in addition to file-based input
4. Fix issue of statically linking core-utils not working in linux.
5. Fix visual artifacts with :option:`--multi-pass-opt-distortion` with VBV.
6. Fix bufferFill stats reported in csv.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Sat Feb 25 08:32:18 2017 UTC (8 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
Version 2.3
===========

Encoder enhancements
--------------------
1. New SSIM-based RD-cost computation for improved visual quality, and efficiency; use :option:`--ssim-rd` to exercise.
2. Multi-pass encoding can now share analysis information from prior passes (in addition to rate-control information) to improve performance and quality of subsequent passes; to your multi-pass command-lines that use the :option:`--pass` option, add :option:`--multi-pass-opt-distortion` to share distortion information, and :option:`--multi-pass-opt-analysis` to share other analysis information.
3. A dedicated thread pool for lookahead can now be specified with :option:`--lookahead-threads`.
4. option:`--dynamic-rd` dynamically increase analysis in areas where the bitrate is being capped by VBV; works for both CRF and ABR encodes with VBV settings.
5. The number of bits used to signal the delta-QP can be optimized with the :option:`--opt-cu-delta-qp` option; found to be useful in some scenarios for lower bitrate targets.
6. Experimental feature option:`--aq-motion` adds new QP offsets based on relative motion of a block with respect to the movement of the frame.

API changes
-----------
1. Reconfigure API now supports signalling new scaling lists.
2. x265 application's csv functionality now reports time (in milliseconds) taken to encode each frame.
3. :option:`--strict-cbr` enables stricter bitrate adherence by adding filler bits when achieved bitrate is lower than the target; earlier, it was only reacting when the achieved rate was higher.
4. :option:`--hdr` can be used to ensure that max-cll and max-fall values are always signaled (even if 0,0).

Bug fixes
---------
1. Fixed incorrect HW thread counting on MacOS platform.
2. Fixed scaling lists support for 4:4:4 videos.
3. Inconsistent output fix for :option:`--opt-qp-pss` by removing last slice's QP from cost calculation.
4. VTune profiling (enabled using ENABLE_VTUNE CMake option) now also works with 2017 VTune builds.

Revision 1.16: download - view: text, markup, annotated - select for diffs
Thu Jan 19 18:52:19 2017 UTC (8 years, 2 months ago) by agc
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +3 -3 lines
Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Jan 1 16:31:44 2017 UTC (8 years, 2 months ago) by adam
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -5 lines
Version 2.2

Encoder enhancements
--------------------
1. Enhancements to TU selection algorithm with early-outs for improved speed; use :option:`--limit-tu` to exercise.
2. New motion search method SEA (Successive Elimination Algorithm) supported now as :option: `--me` 4
3. Bit-stream optimizations to improve fields in PPS and SPS for bit-rate savings through :option:`--[no-]opt-qp-pps`, :option:`--[no-]opt-ref-list-length-pps`, and :option:`--[no-]multi-pass-opt-rps`.
4. Enabled using VBV constraints when encoding without WPP.
5. All param options dumped in SEI packet in bitstream when info selected.
6. x265 now supports POWERPC-based systems. Several key functions also have optimized ALTIVEC kernels.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Oct 10 17:13:42 2016 UTC (8 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +4 -1 lines
Distfile has been changed

Revision 1.13: download - view: text, markup, annotated - select for diffs
Mon Oct 3 12:29:15 2016 UTC (8 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Changes 2.1:
Unknown

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun Aug 21 11:42:02 2016 UTC (8 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Version 2.0:
Bug fixes.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Feb 9 12:04:56 2016 UTC (9 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +3 -3 lines
Changes 1.9:
Bug fixes.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sun Oct 25 13:51:09 2015 UTC (9 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -3 lines
Changes 1.8:
* Bug fixes

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri May 29 12:03:06 2015 UTC (9 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Changes 1.7:
Bug fixes.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Apr 6 20:58:35 2015 UTC (9 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +6 -8 lines
x265 1.6 has been released.  The changes from the 1.5 release are mostly
performance oriented, with heavy improvements for AVX2 capable platforms
(Haswell and later Intel CPUs) and work efficiency improvements for
multiple-socket machines.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Feb 28 23:45:29 2015 UTC (10 years ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -1 lines
Always build PIC. Bump revision.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Feb 12 09:02:42 2015 UTC (10 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +3 -3 lines
Changes 1.5:
search: use chroma reconQt buffer instead of recon picture (not yet updated)
This fixes non-determinism when psy-rd is enabled

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Nov 29 21:27:06 2014 UTC (10 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -4 lines
Changes 1.4:
* encoder: emit an Active Parameter Sets SEI in stream headers if interlaced
* encoder: give more warnings when features are automatically disabled
* api: allow --psy-rdoq values up to 50; it can be beneficial for film grain
* docs: improve --pmode documentation, the feature is fully functional
* analysis: do not allow top-skip and depth earlyout in --pmode with --rd 5/6
* asm: correct wrong index name
* docs: update preset table and various command line options
* fix rd=0,1
* analysis: fix for --rd 0, do not assume a CU is only inter or intra
* analysis: rect cost compare typo fix for pmode
* search: ensure RDOQ entropy state is always initialized for chroma intra

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 9 14:06:43 2014 UTC (10 years, 5 months ago) by wiz
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -3 lines
Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Aug 27 05:51:39 2014 UTC (10 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -3 lines
Changes 1.3:
encoder: disable --cu-lossless until coding errors can be fixed

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Jul 15 16:48:55 2014 UTC (10 years, 8 months ago) by adam
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -3 lines
Changes 1.2:
* TEncCU: bug fix
* Remove the xCheckBestMode call, add in a ccontext save.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Jul 2 11:46:21 2014 UTC (10 years, 8 months ago) by adam
Branches: MAIN
x265 is an open-source project and free application library for encoding video
streams into the H.265/High Efficiency Video Coding (HEVC) format.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>