File:  [cvs.NetBSD.org] / pkgsrc / multimedia / smpeg / Makefile
Revision 1.33: download - view: text, annotated - select for diffs
Sun Nov 3 17:12:04 2019 UTC (5 years, 4 months ago) by rillig
Branches: MAIN
CVS tags: HEAD
multimedia: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

# $NetBSD: Makefile,v 1.33 2019/11/03 17:12:04 rillig Exp $
#

DISTNAME=	smpeg-0.4.4
PKGREVISION=	17
CATEGORIES=	devel multimedia
MASTER_SITES=	#

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.lokigames.com/development/smpeg.php3
COMMENT=	SDL MPEG Player Library
LICENSE=	gnu-lgpl-v2

USE_TOOLS+=	gmake
GNU_CONFIGURE=	yes
USE_LANGUAGES=	c c++
USE_LIBTOOL=	yes

CPPFLAGS+=	-Dunix=1

# smpeg sources (glmovie.c & glmovie-tile.c) assume <malloc.h> exists.
# Create a fake one for platforms that don't have it.
#
post-wrapper:
	if ${TEST} ! -f /usr/include/malloc.h; then			\
		${ECHO} "#include <stdlib.h>"				\
			> ${BUILDLINK_DIR}/include/malloc.h;		\
	fi

.include "../../mk/bsd.prefs.mk"

.if ${MACHINE_ARCH} == "i386"
.  if ${OPSYS} != "Darwin" && \
     empty(MACHINE_PLATFORM:MNetBSD-[89].*-i386)
CONFIGURE_ARGS+=	--enable-mmx
.  endif
.endif

MAKE_ENV.SunOS+=	SunOS_LDFLAGS="-shared -mimpure-text"

.include "options.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>