The NetBSD Project

CVS log for pkgsrc/multimedia/ruby-gnome2-gstreamer/Attic/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / ruby-gnome2-gstreamer

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.28, Sat Sep 14 18:11:36 2019 UTC (2 years ago) by tsutsui
Branch: MAIN
CVS Tags: HEAD
Changes since 1.27: +1 -1 lines
FILE REMOVED

ruby-gnome: Update to 3.3.8, and rename package names to match gems.

Also reorganize several dependencies in Makefile and buildlink3.mk.
See the following post for details:
 https://mail-index.netbsd.org/pkgsrc-users/2019/09/07/msg029327.html
 https://mail-index.netbsd.org/pkgsrc-users/2019/09/13/msg029356.html

Upstream changes (from NEWS):

== Ruby-GNOME 3.3.8: 2019-09-10

This is a partially GLib 2.62.0 support release.

=== Changes

==== All

  * Improvements

    * Changed our project name to Ruby-GNOME from Ruby-GNOME2.
      [GitHub#1277][Suggested by kojix2]
      [GitHub#1291][Patch by kojix2]

    * Stopped to release (({.tar.gz})) because they are no longer
      used.

==== Ruby/GLib2

  * Improvements

    * (({GLib.convert})): Changed to set correct encoding.

    * (({GLib::FILENAME_ENCODING})): Added.

    * Changed to use the same enum object for the same enum value.

    * (({GLib::Enum.find})): Added.

    * (({GLib::Bytes#initialize})): Changed to reuse (({String})) data
      even if the given (({String})) isn't frozen.

    * (({GLib::Bytes.try_convert})): Added.

    * (({GLib::Enum.try_convert})): Added.

    * (({GLib::Flags.try_convert})): Added.

    * (({GLib::Type.try_convert})): Added.

    * (({GLib::MkEnums.create})): Added support for flags to enum
      definition.
      [GitHub#1295][Patch by Mamoru TASAKA]

==== Ruby/GIO2

  * Fixes

    * Renamed to (({Gio::Icon#hash})) from (({Gio::Icon.hash})).
      [GitHub#1293][Reported by Erik Czumadewski]

==== Ruby/GObjectIntrospection

  * Improvements

    * Introduced (({try_convert})) protocol.

==== Ruby/CairoGObject

  * Improvements

    * (({Cairo::Context.try_convert})): Added.

    * (({Cairo::Device.try_convert})): Added.

    * (({Cairo::Pattern.try_convert})): Added.

    * (({Cairo::Surface.try_convert})): Added.

    * (({Cairo::ScaledFont.try_convert})): Added.

    * (({Cairo::FontFace.try_convert})): Added.

    * (({Cairo::FontOptions.try_convert})): Added.

    * (({Cairo::Region.try_convert})): Added.

=== Thanks

  * kojix2

  * Erik Czumadewski

  * Mamoru TASAKA

Revision 1.27 / (download) - annotate - [select for diffs], Sun Jan 27 02:23:40 2019 UTC (2 years, 7 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.26: +1 -2 lines
Diff to previous 1.26 (colored)

ruby-gnome2: update to 3.3.1.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.3.1: 2019-01-09

This is a release that improves GObject Introspection support.

=== Changes

==== Ruby/GLib2

  * Improvements

    * (({rbgobj_remove_relative()})): Added support for removing a
      relative added by (({rbgobj_add_relative()})).

    * Stopped to use raw (({Hash})) to guard objects from GC.

    * (({GLib::Idle.remove})): Deprecated. Use
      (({GLib::Source.remove})) instead.

  * Fixes

    * Fixed typos in samples.
      [GitHub#1267][Patch by kojix2]

==== Ruby/CairoGObject

  * Improvements

    * Started to require cairo gem 1.16.2 or later.

==== Ruby/GObjectIntrospection

  * Improvements

    * Added support for input object validation.

    * Added support for callback with module function such as
      (({Gdk.threads_add_idle})).
      [GitHub#1256][Reported by xetum]

    * Added support for converting (({GHash<utf8, GObject>})).

    * Added support for transfer full (({GHash})).

    * Added support for freeing array of primitive types.
      [GitHub#1266][Patch by Yosuke Shiro]

    * Improved suitable method detection for array and list.

    * Added support for converting an array of (({GObject})).

    * Added support for renaming compare operations:

      * (({not_equal})): (({!=}))

      * (({less_than})): (({<}))

      * (({less_than_or_equal})): (({<=}))

      * (({greater_than})): (({>}))

      * (({greater_than_or_equal})): (({>=}))

==== Ruby/GdkPixbuf2

  * Fixes

    * Fixed markup.
      [GitHub#1250][Patch by kojix2]

    * Fixed a bug that data passed to (({GdkPixbuf::Pixbuf.new(data:
      array)})) is corrupt by GC.

==== Ruby/Pango

  * Improvements

    * (({Pango::Layout#get_pixel_extents})): Added for backward
      compatibility.

    * (({Pango::Rectangle#ascent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#descent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#lbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#rbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#left_bearing})): Added.

    * (({Pango::Rectangle#right_bearing})): Added.

==== Ruby/GTK2

  * Fixes

    * Fixed typos in samples.
      [GitHub#1268][Patch by kojix2]

==== Ruby/GTK3

  * Improvements

    * Updated sample to work on HiDPI environment.
      [GitHub#1246][Patch by noanoa07]

    * Updated samples.
      [GitHub#1258][GitHub#1259][GitHub#1260][Patch by kojix2]

==== Ruby/RSVG2

  * Fixes

    * Fixed typos.
      [GitHub#1253][Patch by kojix2]

    * Removed needless rsvg2 gem dependency for Windows.
      [GitHub#1261][Reported by noanoa07]

==== Ruby/GEGL

  * Fixes

    * Fixed a typo in README.
      [GitHub#1263][Patch by kojix2]

=== Thanks

  * noanoa07

  * kojix2

  * xetum

  * Yosuke Shiro

Revision 1.26 / (download) - annotate - [select for diffs], Wed Feb 21 17:00:00 2018 UTC (3 years, 7 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.25: +1 -3 lines
Diff to previous 1.25 (colored)

ruby-gnome: Remove package CONFLICTS that conflict with themselves.

Revision 1.25 / (download) - annotate - [select for diffs], Sun Jun 11 05:51:41 2017 UTC (4 years, 3 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.24: +3 -1 lines
Diff to previous 1.24 (colored)

Move MAINTAINER line to each gem package.

Also retire from maintainership of packages that I don't need and
have less motivation.

Revision 1.24 / (download) - annotate - [select for diffs], Sat Apr 16 17:41:04 2016 UTC (5 years, 5 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.23: +1 -2 lines
Diff to previous 1.23 (colored)

Update ruby-gnome2 packages to 3.0.8.

Upstream changes:
(from https://github.com/ruby-gnome2/ruby-gnome2/blob/3.0.8/NEWS)

= Ruby-GNOME2 3.0.8: 2016-04-03

It's a release that improves GTK+ 3 support.

=== Changes

==== All

  * Droped Ruby 2.0.0 support.
  * Travis: use Trusty beta image.
    [Patch by Hiroshi Hatake]
  * Added AltLinux to supported OSes.
    [Patch by Malo Skrylevo]

==== Ruby/GLib2

  * Improvements
    * Added (({RVAL2CSTR_PTR_ACCEPT_NIL})).
    * Added (({RVAL2CSTR_RAW})).
    * Added (({RVAL2CSTR_RAW_ACCEPT_NIL})).
    * Supported (({GLib::Variant.new(value, type)})).
    * Added (({GLib::Regex})) class.
      [Patch by cedlemo]
    * Supported more variant types in (({rbg_variant_to_ruby})).
     [Patch by Aurelien Jacobs]
    * Supported array in (({rg_ruby_to_variant})).
      [Patch by Aurelien Jacobs]
    * Added (({GLib::Regex#split})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo})) class.
      [Patch by cedlemo]
    * Added (({GLib::Regex#max_backref})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#capture_count})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#has_cr_or_lf?})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#max_lookbehind})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#string_number})).
      [Patch by cedlemo]
    * Added (({GLib::Regex.escape_string})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match?})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match_all})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#split})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#replace})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#check_replacement})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#replace_eval})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#partial_match})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#fetch})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#[]})).
    * Added (({GLib::MatchInfo#fetch_pos})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#fetch_position})).
    * Added (({GLib::MatchInfo#fetch_all})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#next})).
      [Patch by cedlemo]

  * Fixes
    * Fixed a bug that raw string is converted to UTF-8.
    * Fixed handling of 64 bits (({FIXNUM})) variant initialization.

==== Ruby/GObjectIntrospection

  * Improvements
    * Supported allocated output parameter.
    * Supported dynamic callback.
    * Supported enum as output value.
    * Added function type name in error message.
    * Added (({RB_ZALLOC})).
    * Supported freeing GType-ed union.
      [GitHub#700][Reported by cedlemo]
    * Added (({GI::Repository#get_version})).
  * Fixes
    * Fixed a bug that block is always ignored in singleton method.
      [ruby-gnome2-devel-ja][Reported by Yuuki Harano]

==== Ruby/GIO2

  * Improvements
    * Supported (({Gio::Application.new(:arguments => [...]})).
      [GitHub#519][Reported by Mamoru TASAKA]
    * Started to use dynamic callback.

==== Ruby/GTK3

  * Improvements
    * Supported (({Gtk::Clipboard#request_text})).
      [ruby-gnome2-devel-en][Reported by Detlef Reichl]
    * Supported (({Gtk::Clipboard#request_contents})).
    * Supported (({Gtk::Clipboard#request_image})).
    * Supported (({Gtk::Clipboard#request_targets})).
    * Supported (({Gtk::Clipboard#request_rich_text})).
    * Supported (({Gtk::Clipboard#request_uris})).
    * Updated main demo application.
      [Patch by cedlemo]
    * Updated and finished sample tutorial.
      [Patch by cedlemo]
    * Supported (({Gtk::TreeModel#set_sort_func})).
      [GitHub#596][Reported by Christopher L. Ramsey]
    * Supported (({Gtk::Box#set_child_packing})).
      [GitHub#602][Reported by Ibrahim Tencer]
    * Updated stack demo.
      [Patch by cedlemo]
    * Added scale demo.
      [Patch by cedlemo]
    * Updated theming style classes demo.
      [Patch by cedlemo]
    * Created entry buffer demo.
      [Patch by cedlemo]
    * Made (({Gtk::EntryBuffer#new more rubyish})).
      [Patch by cedlemo]
    * Added markup demo.
      [Patch by cedlemo]
    * Added headerbar demo.
      [Patch by cedlemo]
    * Updated css accordion demo.
      [Patch by cedlemo]
    * Added pickers demo.
      [Patch by cedlemo]
    * Updated links demo.
      [Patch by cedlemo]
    * Added overlay demo.
      [Patch by cedlemo]
    * Added textmask demo.
      [Patch by cedlemo]
    * Added sidebar demo.
      [Patch by cedlemo]
    * Updated spinner demo.
      [Patch by cedlemo]
    * Updated entry completion demo.
      [Patch by cedlemo]
    * Added revealer demo.
      [Patch by cedlemo]
    * Updated expander demo.
      [Patch by cedlemo]
    * Added overlay2 demo.
      [Patch by cedlemo]
    * Updated colorsel demo.
      [Patch by cedlemo]
    * (({rbgobj_gc_mark_instance})) has to be called
      for the (({Gtk::TreeSelection})).
      [Patch by Hiroyuki Ito]
    * Updated css basics demo.
      [Patch by cedlemo]
    * Made (({Gtk::TreeModel#iter_nth_child})) and
      (({Gtk::TreeModel#iter_children})) work like
      (({#get_value})).
    * Added methods to Gtk::TreeIter:
        * (({Gtk::TreeIter#previous!}))
        * (({Gtk::TreeIter#has_child?}))
        * (({Gtk::TreeIter#n_children}))
        * (({Gtk::TreeIter#nth_child}))
        * (({Gtk::TreeIter#children})).
      [Patch by Hiroyuki Ito]
    * Added support for (({Gtk::TreeSelection})).
      [Patch by dutchhome]
    * Updated builder demo.
      [Patch by cedlemo]
    * Updated css pixbufs demo.
      [Patch by cedlemo]
    * Updated button box demo.
      [Patch by cedlemo]
    * Created css shadows demo.
      [Patch by cedlemo]
    * Updated infobar demo.
      [Patch by cedlemo]
    * Added support for MenuPositionFunc in
      (({Gtk::Menu#popup})).
      [GitHub#61][Reported by Abby Archer]
    * Made (({Gtk::Widget#translate_coordinates})) more
      rubyish.
      [Patch by cedlemo]
    * Added support for (({EntryCompletionMatchFunc})).
      [Patch by Hiroyuki Ito]
    * Updated iconview edit demo.
      [Patch by cedlemo]
    * Updated sizegroup demo.
      [Patch by cedlemo]
    * Updated cursors demo.
      [Patch by cedlemo]
    * Made (({Gtk::MenuItem#new})) like
      (({Gtk::CheckMenuItem#new})).
      [Patch by Hiroyuki Ito]
    * Move the (({#set_values})) implementation to
      (({Gtk::TreeModel})) instead of (({Gtk::ListStore})).
      [GitHub#659][Reported by detlef]
    * Updated search entry2 demo.
      [Patch by cedlemo]
    * Updated menus demo.
      [Patch by cedlemo]
    * Updated css multiplebgs demo.
      [Patch by cedlemo]
    * Added auto generated callback for AssistantPageFunc.
    * Added auto generated callback for BuilderConnectFunc.
    * Updated model button demo.
      [Patch by cedlemo]
    * Updated dialog demo.
      [Patch by cedlemo]
    * Added another example sample for (({Gtk::TreeStore})).
      [Patch by cedlemo]
    * Added the methods:
        * (({Gtk::TreePath#next!}))
        * (({Gtk::TreePath#prev!}))
        * (({Gtk::TreePath#up!}))
        * (({Gtk::TreePath#down!})).
      [Patch by cedlemo]
    * Added (({Gtk::TreeIter#first_child})).
      [Patch by cedlemo]
    * Updated filtermodel demo.
      [Patch by cedlemo]
    * Updated popover demo.
      [Patch by cedlemo]
    * Supported (({Gtk::Builder#connect_signals})).
    * Added new sample icons-theme-viewer.rb.
      [Patch by cedlemo]
    * Added new sample menus_from_resources.rb.
      [Patch by cedlemo]
    * Updated printing demo.
      [Patch by cedlemo]
    * Updated assistant demo.
      [Patch by cedlemo]
    * Updated panes demo.
      [Patch by cedlemo]
    * Updated font features demo.
      [Patch by cedlemo]

  * Fixes:
    * Fixed a bug that (({Gtk::Widget.set_connect_func})) doesn't work.
      [GitHub#703][Reported by cedlemo]

==== Ruby/Poppler

  * Improvements:
    * Removed needless (({POPPLER_TYPE_ORIENTATION})) binding.
      [GiHub#653][Reported by Rob Brackett]

==== Ruby/WebKit2GTK

  * Improvements:
    * Supported old WebKit2GTK+.

=== Thanks

  * Detlef Reichl
  * Mamoru TASAKA
  * cedlemo
  * Christopher L. Ramsey
  * Hiroyuki Ito
  * dutchhome Jon Raiford
  * Rob Brackett
  * Abby Archer
  * Yuuki Harano
  * detlef
  * Aurelien Jacobs
  * Hiroshi Hatake
  * Malo Skrylevo

Revision 1.23 / (download) - annotate - [select for diffs], Sun Jan 24 05:03:24 2016 UTC (5 years, 7 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.22: +8 -5 lines
Diff to previous 1.22 (colored)

Switch ruby-gnome2 packages to using gem.

Bump PKGREVISIONs to denote gem'fy and PLIST changes.
Also take maintainership.

Discussed with and ok'ed by wiz@ on pkgsrc-users@:
 http://mail-index.netbsd.org/pkgsrc-users/2016/01/thread1.html#022813

Revision 1.22 / (download) - annotate - [select for diffs], Thu Jun 20 09:12:14 2013 UTC (8 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.21: +1 -3 lines
Diff to previous 1.21 (colored)

revert `say good-bye to ruby-1.8', it should not be done dureing a freeze.

Revision 1.21 / (download) - annotate - [select for diffs], Wed Jun 19 13:40:29 2013 UTC (8 years, 3 months ago) by obache
Branch: MAIN
Changes since 1.20: +3 -1 lines
Diff to previous 1.20 (colored)

say good-by to Ruby-1.8.

Revision 1.20 / (download) - annotate - [select for diffs], Wed May 8 12:47:05 2013 UTC (8 years, 4 months ago) by obache
Branch: MAIN
Changes since 1.19: +6 -7 lines
Diff to previous 1.19 (colored)

Update ruby-gnome2 to 2.0.0.

GObject Introspection based bindings on Windows support release!

=== Changes

==== NEWS

  * Fixes
    * Fixed a typo. [Reported by Masafumi Yokoyama]
    * FIxed a typo. [Reported by Toyo Abe]

==== Ruby/GLib2

  * Improvements
    * Moved lib/gnome2-*.rb files to lib/gnome2/ directory.
    * Supported GLib 2.34. [Reported by OBATA Akio]

==== Ruby/GdkPixbuf2

  * Fixes
    * [windows] Fixed PNG can't be handled problem.
      [ruby-gnoem2-devel-ja] [Reported by Masafumi Yokoyama]

==== Ruby/GDK3

  * Improvements
    * [windows] Removed needless Greybird theme.
      [ruby-gnome2-devel-en] [Reported by Regis d'Aubarede]
    * Added Gdk::Window#create_cairo_context
      [ruby-gnome2-devel-en] [Reported by Detlef Reichl]

==== Ruby/GTK3

  * Improvements
    * Updated samples.
      [GitHub #140][GitHub #141][GitHub #144]
      [Patch by Simon Arnaud]
      [GitHub #142][GitHub #143][GitHub #145][GitHub #146][GitHub #148]
      [Patch by Detlef Reichl]

==== Ruby/GObjectIntrospection

  * Improvements
    * [windows] Supported!

==== Ruby/GStreamer

  * Improvements
    * Supported GStreamer 1.0!
    * Migrated to GObject Introspection bindings!
    * Dropped GStreamer 0.10 support.

==== Ruby/Clutter

  * Improvements
    * [windows] Supported!

==== Ruby/ClutterGTK

  * Improvements
    * [windows] Supported!

Revision 1.19 / (download) - annotate - [select for diffs], Thu Feb 7 13:41:56 2013 UTC (8 years, 7 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.18: +1 -2 lines
Diff to previous 1.18 (colored)

Update ruby-gnome2 to 1.2.1.
(and add gtk3, gdk3, gtksourceview3 and gobject-introspection binding).
based on PR 47529.

== Ruby-GNOME2 1.2.1: 2013-01-30

GTK+ 3 support on Mac OS X release!

=== Changes

==== Ruby/GLib2

  * Improvements
    * Supported custom sudo prompt on auto native package install.
      [GitHub:126] [Suggested by Yorick Peterse]
    * Started to support JRuby. (It is not completed yet.)
      [GitHub:125] [Reported by vpereira]
    * Accepted unsigned long int size GType.
    * Removed DL support.
    * Don't call deprecated g_type_init() for GLib >= 2.35.1.

==== Ruby/GTK2

  * Fixes
    * Fixed a memory leak related Gtk::TreeIter.
      [GitHub:128] [Patch by Toshiaki Asai]

==== Ruby/GTK3

  * Fixes
    * Fixed a memory leak related Gtk::TreeIter.
      [GitHub:128] [Patch by Toshiaki Asai]
    * Fixed a crash bug caused by symbol conflict with Ruby/GDK3 on
      Mac OS X.
      [GitHub:127] [Reported by Sergio Campama] [Helped by Watson]

==== Ruby/GDK3

  * Improvements
    * [windows] Bundled Greybird theme.
      [Suggested by Regis d'Aubarede]

==== Ruby/GooCanvas

  * Improvements
    * Added Goo::Canvas#get_items_at [GitHub:124] [Patch by David Maciejak]

==== Ruby/WebKitGTK

  * Added

==== Ruby/GtkSourceView3

  * Improvements
    * Supported Windows.

=== Thanks

  * David Maciejak
  * Yorick Peterse
  * vpereira
  * Toshiaki Asai
  * Sergio Campama
  * Watson
  * Regis d'Aubarede

== Ruby-GNOME2 1.2.0: 2013-01-24

GTK+ 3 support release!

=== Changes

==== All

  * Added ruby-gtk3 package. Here is a list:
    * Ruby/GLib2
    * Ruby/ATK
    * Ruby/Pango
    * Ruby/GdkPixbuf2
    * Ruby/GDK3
    * Ruby/GTK3

==== Ruby/GLib2

  * Improvements
    * Supported custom VALUE <-> GBoxed conversion
    * Supported VALUE <-> GBoxed conversion by RVAL2GOBJ
    * Added GLib::Source::REMOVE
    * Added GLib::Source::CONTINUE
    * Added rbgobj_make_boxed_raw()
    * Added GLib::Value for internal use
    * [windows] Updated to the latest GLib: 2.28.8-1 -> 2.34.3
  * Changes
    * Removed deprecated GLib::Win32.get_package_installation_directory
    * Removed deprecated GLib::Win32.get_package_installation_subdirectory
    * Added user_data to RGConvertTable callbacks
    * rbgobj_convert_define() copies passed RGConvertTable
    * Removed deprecated G_DEF_FUNDAMENTAL. Use RG_DEF_CONVERSION instead

==== Ruby/GIO2

  * Improvements
    * Installed headers

==== Ruby/ATK

  * Improvements
    * [windows] Updated to the latest ATK: 1.32.0 -> 2.6.0

==== Ruby/Pango

  * Improvements
    * [windows] Updated to the latest Pango: 1.28.3 -> 1.32.6

==== Ruby/GdkPixbuf2

  * Improvements
    * [windows] Updated to the latest gdk-pixbuf: 2.24.0 -> 2.26.5

==== Ruby/GTK2

  * Improvements
    * Removed needless not copy flag from Allocation
    * [windows] Updated to the latest GTK+ 2: 2.24.8 -> 2.24.14

==== Ruby/GDK3

  * Improvements
    * [windows] Supported: 3.6.4

==== Ruby/GTK3

  * Improvements
    * Removed needless not copy flag from Allocation
    * [windows] Supported: 3.6.4

==== Ruby/GObjectIntrospection

  * Improvements
    * Supported over loaded method
    * Supported over loaded constructor
    * Supported GBoxed object
    * Supported char *
    * Supported GInterface
    * Supported CallableInfo
    * Supported may be null
    * Supported union object
    * Supported not GBoxed struct
    * Supported out parameter
    * Supported C array
    * Added "?" suffix to predicate method name
    * Supported SourceFunc callback
    * Supported GValue
    * Added GObjectIntrospection::Loader.register_boxed_class_converter
    * Supported inout parameter
    * Supported binary data array
  * Changes
    * ArgInfo#[] -> ArgInfo#get_arg

==== Ruby/CairoGObject

  * Added

==== Ruby/Clutter

  * Added

==== Ruby/ClutterGtk

  * Added

== Ruby-GNOME2 1.1.9: 2012-12-29

This is a experimental GObjectIntrospection support release.

=== Changes

==== Ruby/GLib2

  * Improvements
    * Renamed G_DEF_CLASS4 to G_DEF_CLASS_WITH_PARENT.
      G_DEF_CLASS4 is still usable but it is deprecated.

==== Ruby/GObjectIntrospection

  * Added. It is still experimental.

== Ruby-GNOME2 1.1.8: 2012-12-19

This is a bug fix release for Ruby 2.0.0.

=== Changes

==== All

  * Fixes
    * Fixed a bug that *.so isn't installed with Ruby 2.0.0.

== Ruby-GNOME2 1.1.7: 2012-12-10

This is a package for Windows fix release.

=== Changes

==== Ruby/GTK2

  * Fixes
    * Bundled GTK+ 2.24.8-1 instead of GTK+ 2.24.10-1.
      [Reported by Mahoro Shimura]

=== Thanks

  * Mahoro Shimura

== Ruby-GNOME2 1.1.6: 2012-12-02

This is Ruby 2.0.0 support release!

=== Changes

==== All

  * Fixes
    * Fixed install error on Ruby 2.0.0.
      [ruby-gnome2-devel-en] Recent Ruby: 'depend' files must be changed
      [Reported by Carlo E. Prelz]

==== Ruby/GLib2

  * Improvements
    * Improved portability a bit. '$,' is used instead of rb_output_fs.
      [GktHub:#117] [Reported by Marvin Gülker]

==== Ruby/GIO2

  * Fixes
    * Fixed a crash bug on i386. [Reported by TAKATSU Tomonari]

==== Ruby/GTK2

  * Improvements
    * Added Gtk::TreeModel#iter_root. [GitHub:121] [Patch by dmaciejak]
    * Added Gtk::TreeModel#iter_next. [GitHub:121] [Patch by dmaciejak]

==== Ruby/GdkPixbuf2

  * Fixes
    * Fixed build errors with old gdk-pixbuf.

==== Ruby/Poppler

  * Improvements
    * Added missing required Poppler version.
      [Suggested by Grant Schoep]
      [ruby-gnome2-devel-en] poppler, build fails, incorrect
      required_pkg_config_package?

  * Fixes
    * Fixed a wrong package name on Red Hat and Fedora.
      [Reported by Grant Schoep]
      [ruby-gnome2-devel-en] poppler, build fails, incorrect
      required_pkg_config_package?

  * Changes
    * Disabled auto Poppler install for Homebrew. It requires
      --with-glib option but auto install with --with-glib option
      isn't supported yet.

==== Ruby/GooCanvas

  * Improvements
    * Added Goo::Canvas#update. [GitHub:119] [Patch by dmaciejak]
    * Added Goo::Canvas#request_update. [GitHub:119] [Patch by dmaciejak]
    * Added Goo::Canvas#convert_from_pixels. [GitHub:123] [Patch by dmaciejak]
    * Added Goo::Canvas#convert_to_pixels. [GitHub:123] [Patch by dmaciejak]
    * Added Goo::Canvas#get_item_at. [GitHub:123] [Patch by dmaciejak]
    * Added Goo::Canvas#bounds. [GitHub:123] [Patch by dmaciejak]

==== Ruby/GStreamer

  * Improvements
    * Don't pass -h and --help to GStreamer.
      [GitHub:#118] [Reported by dmaciejak]

=== Thanks

  * TAKATSU Tomonari
  * dmaciejak
  * Grant Schoep
  * Carlo E. Prelz
  * Marvin Gülker

Revision 1.18 / (download) - annotate - [select for diffs], Mon Oct 8 09:21:12 2012 UTC (8 years, 11 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.17: +1 -3 lines
Diff to previous 1.17 (colored)

Drop PKG_DESTDIR_SUPPORT setting, "user-destdir" is default these days.

Revision 1.17 / (download) - annotate - [select for diffs], Sat Sep 15 10:05:53 2012 UTC (9 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.16: +2 -1 lines
Diff to previous 1.16 (colored)

recursive bump from libffi shlib major bump
(additionaly, reset PKGREVISION of qt4-* sub packages from base qt4 update)

Revision 1.16 / (download) - annotate - [select for diffs], Sun Jul 22 09:29:16 2012 UTC (9 years, 2 months ago) by obache
Branch: MAIN
Changes since 1.15: +1 -2 lines
Diff to previous 1.15 (colored)

Update ruby-gnome2 to 1.1.4.

== Ruby-GNOME2 1.1.4: 2012-07-21

This is a easy to install release!

=== Changes

==== All

  * Improvements
    * Supported automatic required native packages install.

==== Ruby/GLib2

  * Improvements
    * mkenums: Supported "/* < flags > */" tag.
    * mkenums: Supported two or more upper case characters such as "IO".
      * Before: GIOStatus -> g_iostatus
      * After:  GIOStatus -> g_io_status
    * GIOCondition: Changed to GLib::Boxed object from integer.
    * GLib::Source#attach doesn't require context.

  * Fixes
    * Fixed wrong type conversion for GIOCondition.

==== Ruby/GIO2

  * Improvements
    * Gio::Socket#create_source: Supported callback.

  * Fixes
    * Fixed return values.
    * Fixed wrong type conversions.

==== Ruby/GTK2

  * Improvements
    * Re-supported GTK+ 2.10.0. [GitHub:115] [Patch by Grant Schoep]

  * Fixes
    * Fixed a typo in test script.
      [GitHub:109] [Reported by kimura wataru]

==== Ruby/GStreamer

  * Fixes
    * Fixed a test failure with GStreamer 0.10.36.
      [GitHub:111] [Reported by mtasaka]

Revision 1.15 / (download) - annotate - [select for diffs], Thu Jun 14 07:44:15 2012 UTC (9 years, 3 months ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.14: +2 -1 lines
Diff to previous 1.14 (colored)

Recursive PKGREVISION bump for libxml2 buildlink addition.

Revision 1.14 / (download) - annotate - [select for diffs], Sat Apr 14 04:27:50 2012 UTC (9 years, 5 months ago) by obache
Branch: MAIN
Changes since 1.13: +1 -2 lines
Diff to previous 1.13 (colored)

Update ruby-gnome2 to 1.1.3.

== Ruby-GNOME2 1.1.3: 2012-04-08

This is a bug fix release of 1.1.2.

=== Changes

==== Ruby/GLib2

  * Improvements
    * Added required Ruby version into gemspec.
    * [GitHub#106] glib-mkenums.rb supported macro lines in header.
      This change is required for building with GLib 2.31.20.
      [Reported by mtasaka]
    * [GitHub#107] Supported tests on PPC.
      [Reported by mtasaka]
  * Fixes
    * Fixed handler_id type.

==== Ruby/GTK2

  * Improvements
    * Added Gtk::TreeViewColumn#set_sort_column_id and
      Gtk::TreeViewColumn#sort_column_id= for GTK+ < 2.18.
      [ruby-gnome2-devel-en] Gtk::TreeViewColumn
      [Reported by grant schoep]
    * Added Gtk::InfoBar.
    * Added Gtk::MessageType.
    * Added Gtk::ResponseType.
  * Fixes
    * Fixed build failure with GTK+ < 2.12.
      [ruby-gnome2-devel-en] compile problems gtk2, ruby-gnome2-all-1.1.2
      [Reported by grant schoep]
    * Fixed require failure with GTK+ < 2.14.
      [ruby-gnome2-devel-en] NameError: undefined method
      `color_selection' for class `Gtk::ColorSelectionDialog'
      [Reported by grant schoep]

==== Ruby/Poppler

  * Improvements
    * [GitHub#97] Added Poppler::Page#text_layout.
      [Patch by Andrey Kutejko]
    * [SF.net#3495948] Removed needless poppler-cairo check.
      [Reported by Pino Toscano]
  * Fixes
    * [GitHub#96] Fixed valid state of child index iterator.
      [Patch by Andrey Kutejko]
    * [GitHub#97] Fixed parameter check of Poppler::Page#get_text.
      [Patch by Andrey Kutejko]

==== Ruby/VTE

  * Fixes
    * Fixed build failure with VTE < 0.24.

==== Ruby/GStreamer

  * Improvements
    * Added Gst::Element#seek_simple.
  * Fixes
    * [GitHub#95] Fixed async test.
      [Reported by mtasaka]

Revision 1.13 / (download) - annotate - [select for diffs], Sat Mar 3 00:13:41 2012 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Recursive bump for pcre-8.30* (shlib major change)

Revision 1.12 / (download) - annotate - [select for diffs], Mon Feb 6 12:41:07 2012 UTC (9 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

Revbump for
a) tiff update to 4.0 (shlib major change)
b) glib2 update 2.30.2 (adds libffi dependency to buildlink3.mk)

Enjoy.

Revision 1.11 / (download) - annotate - [select for diffs], Wed Jan 11 13:47:31 2012 UTC (9 years, 8 months ago) by obache
Branch: MAIN
Changes since 1.10: +3 -3 lines
Diff to previous 1.10 (colored)

Update ruby-gnome2 to 1.1.0.

== Ruby-GNOME2 1.1.0: 2012-01-05

This is a source cleanup release.

=== Changes

==== Ruby/GLib2

  * Improvements
    * [GitHub#65] Supported GLib 2.31. [Reported by mtasaka]
    * Supported comparing between GLib::Enum/GLib::Flags and Symbol.
  * Fixes
    * [GitHub#1] Fix GLib::Spawn regression.
      [Patch by Geoff Youngs]
    * Plugged memory leaks.
    * Fixed a crash by GC on Ruby 1.9.
  * Changes
    * Remove optional Ruby-GetText-Package dependency.

==== Ruby/GTK2

  * Improvements
    * [ruby-gnome2-devel-en] FileChooserDialog raising warnings on Windows:
      Added hicolor-icon-theme into gem on Windows.
      [Suggested by wNikolai Weibull]
  * Fixes
    * Fixed a crash by GC.
    * Plugged memory leaks.
    * Fixed Gdk::GC#colormap= uses wrong value.
    * Fixed Gtk::TextBuffer#serialize uses wrong value.

==== Ruby/Pango

  * Fixes
    * Plugged memory leaks.

==== Ruby/GdkPixbuf

  * Improvements
    * Gdk::Pixbuf.new supports hash argument.
  * Fixes
    * Plugged memory leaks.

==== Ruby/GStreamer

  * Improvements
    * Supported Windows gem.
    * Improved memory management.
  * Fixes
    * [GitHub#86] Gstreamer: test_caps test fails. [Reported by mtasaka]
    * [GitHub#87] GStreamer: test_span test fails. [Reported by mtasaka]
    * [GitHub#87] GStreamer: test_create_clock test fails.
      [Reported by mtasaka]
    * [GitHub#89] GStreamer: test_fraction_range_new test fails.
      [Reported by mtasaka]
    * [GitHub#91] GStreamer: test_state "sometimes" fails.
      [Reported by mtasaka]

==== Ruby/Poppler

  * Fixes
    * Fixed a wrong conversion in Poppler::Document#find_dest.
      [Reported by Chloé Desoutter]

Revision 1.10 / (download) - annotate - [select for diffs], Sun Jun 12 11:43:34 2011 UTC (10 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.9: +1 -2 lines
Diff to previous 1.9 (colored)

Update ruby-gnome2 to 0.90.9.

== Ruby-GNOME2 0.90.9: 2011-06-11

NOTE: 0.90.x releases are for 1.0.0 major release.

This is the last release of 0.90.x series. The next release
will be 1.0.0!

=== Changes

==== All

  * Fixes
    * Fix a bug in version numbers.
      [Grant Schoep, Vincent Carmona]
    * Support 'bundle install' .

==== Ruby/GLib2

  * Improvements
    * Support GLib::IOChannel.new(fd) and GLib::IOChannel#fd on Windows.
    * GLib::IOChannel#write returns written byte not self.
      [backward incompatible]

==== Ruby/GTK2

  * Fixes
    * fix misc/bindings.rb sample (ruby 1.9).
      [Vincent Carmona]
    * [#3305589] fix Gtk::Window#add_accel_group misses
      a reference to accel group.
      [Piotr Korzuszek, Kouhei Sutou]
    * Support cairo related samples in Ruby 1.9.
      [Jon, Kouhei Sutou]

==== Ruby/GStreamer

  * Improvements
    * add Gst::Registry.update method.
      [Vincent Carmona]

==== Ruby/VTE

  * Fixes
    * [#3199587] fix pc install.
      [OBATA Akio, Kouhei Sutou]

==== Ruby/Poppler

  * Fixes
    * [#3292118] don't run needless tests.
      [Mamoru Tasaka, Kouhei Sutou]

==== Ruby/GtkSourceView2

  * Improvements
    * support Windows.
      [S.Kitagawa]

Revision 1.9 / (download) - annotate - [select for diffs], Fri Apr 22 13:44:18 2011 UTC (10 years, 5 months ago) by obache
Branch: MAIN
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

recursive bump from gettext-lib shlib bump.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Mar 4 13:14:06 2011 UTC (10 years, 6 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

Update ruby-gnome2 to 0.90.8.

== Ruby-GNOME2 0.90.8: 2011-03-04

NOTE: 0.90.x releases are for 1.0.0 major release.

A bug fix release of 0.90.7.

=== Changes

==== All

  * Fixes
    * 'make distclean' does not removed pkg-config files.

==== Ruby/GLib2

  * Fixes
    * fix non-gem rcairo detection. [#3178228]
      [OBATA Akio, Kouhei Sutou]

==== Ruby/Atk

  * Fixes
    * fix 'make distclean' cleans needed a file.
      [Vincent Carmona]

==== Ruby/Pango

  * Fixes
    * fix 'make distclean' cleans needed a file.
      [Vincent Carmona]

==== Ruby/GTK2

  * Fixes
    * fix require order.
      [id:kenhys]
    * [#3046538] fix crash by GC at exit.
      [Vincent Carmona, Kouhei Sutou]
    * gtk-demo samples with ruby 1.9 (excepted cairo ones).
      [Vincent Carmona]

==== Ruby/GooCanvas

  * Fixes
    * fix pc install. [#3178294]
      [OBATA Akio, Kouhei Sutou]

==== Ruby/GStreamer

  * Improvements
    * improve missing message.
      [Vincent Carmona]
    * add Gst::InstallPlugins.
      [Vincent Carmona, Kouhei Sutou]

  * Fixes
    * fix pc install. [#3178294]
      [OBATA Akio, Kouhei Sutou]
    * don't use rbgprivate.h. [#3188442]
      [Mamoru Tasaka, Kouhei Sutou]

==== Ruby/GtkMozEmbed

  * Fixes
    * fix pc install. [#3178294]
      [OBATA Akio, Kouhei Sutou]

==== Ruby/GtkSourceView2

  * Fixes
    * fix pc install. [#3178294]
      [OBATA Akio, Kouhei Sutou]

Revision 1.6.2.1 / (download) - annotate - [select for diffs], Sun Feb 27 00:26:24 2011 UTC (10 years, 6 months ago) by tron
Branch: pkgsrc-2010Q4
Changes since 1.6: +2 -1 lines
Diff to previous 1.6 (colored) next main 1.7 (colored)

Pullup ticket #3361 - requested by taca
archivers/ruby-libarchive: dependence update
comms/ruby-termios: dependence update
converters/ruby-uconv: dependence update
databases/ruby-do_sqlite3: dependence update
databases/ruby-ldap: dependence update
databases/ruby-mysql: dependence update
databases/ruby-odbc: dependence update
databases/ruby-pg: dependence update
databases/ruby-postgresql: dependence update
databases/ruby-qdbm: dependence update
databases/ruby-sqlite: dependence update
databases/ruby-sqlite3: dependence update
databases/ruby-tokyocabinet: dependence update
devel/ruby-SDL: dependence update
devel/ruby-debug-base: dependence update
devel/ruby-eet: dependence update
devel/ruby-eventmachine: dependence update
devel/ruby-ffi: dependence update
devel/ruby-gnome2-atk: dependence update
devel/ruby-gnome2-bonobo: dependence update
devel/ruby-gnome2-bonoboui: dependence update
devel/ruby-gnome2-gconf: dependence update
devel/ruby-gnome2-gio: dependence update
devel/ruby-gnome2-glib: dependence update
devel/ruby-gnome2-libglade: dependence update
devel/ruby-gnome2-pango: dependence update
devel/ruby-linecache: dependence update
devel/ruby-memcache: dependence update
devel/ruby-ncurses: dependence update
devel/ruby-priority-queue: dependence update
devel/ruby-racc: dependence update
devel/ruby-rbtree: dependence update
devel/ruby-rcov: dependence update
devel/ruby-rcsparse: dependence update
devel/ruby-subversion: dependence update
devel/ruby-thrift: dependence update
graphics/ruby-RMagick: dependence update
graphics/ruby-clutter-cairo: dependence update
graphics/ruby-clutter-core: dependence update
graphics/ruby-clutter-gtk: dependence update
graphics/ruby-gd: dependence update
graphics/ruby-gnome2-gdkpixbuf: dependence update
graphics/ruby-gnome2-gnomecanvas: dependence update
graphics/ruby-gnome2-goocanvas: dependence update
graphics/ruby-gnome2-gtkglext: dependence update
graphics/ruby-gnome2-libart: dependence update
graphics/ruby-gnome2-rsvg: dependence update
graphics/ruby-imlib2: dependence update
graphics/ruby-opengl: dependence update
graphics/ruby-rcairo: dependence update
inputmethod/ruby-zinnia: dependence update
lang/ruby: dependence update
lang/ruby18-base: security update
lang/ruby19-base: security update
mail/ruby-tmail: dependence update
math/ruby-rb-gsl: dependence update
multimedia/ruby-clutter-gst: dependence update
multimedia/ruby-gnome2-gstreamer: dependence update
multimedia/ruby-ming: dependence update
print/ruby-gnome2-gnomeprint: dependence update
print/ruby-gnome2-gnomeprintui: dependence update
print/ruby-gnome2-poppler: dependence update
security/ruby-password: dependence update
security/ruby-tcpwrap: dependence update
sysutils/ruby-quota: dependence update
textproc/ruby-bluecloth: dependence update
textproc/ruby-cabocha: dependence update
textproc/ruby-eruby: dependence update
textproc/ruby-ferret: dependence update
textproc/ruby-hpricot: dependence update
textproc/ruby-itex2MML: dependence update
textproc/ruby-json: dependence update
textproc/ruby-libxml: dependence update
textproc/ruby-mecab: dependence update
textproc/ruby-native-hyperestraier: dependence update
textproc/ruby-nokogiri: dependence update
textproc/ruby-oniguruma: dependence update
textproc/ruby-redcloth: dependence update
textproc/ruby-sary: dependence update
textproc/ruby-xmlparser: dependence update
textproc/ruby-xslt: dependence update
textproc/ruby-yamcha: dependence update
www/mongrel: dependence update
www/ruby-clearsilver: dependence update
www/ruby-fcgi: dependence update
www/ruby-gnome2-gtkhtml2: dependence update
www/ruby-gnome2-gtkmozembed: dependence update
www/ruby-patron: dependence update
www/thin: dependence update
x11/ruby-gnome2-gnome: dependence update
x11/ruby-gnome2-gtk: dependence update
x11/ruby-gnome2-gtksourceview: dependence update
x11/ruby-gnome2-gtksourceview2: dependence update
x11/ruby-gnome2-panelapplet: dependence update
x11/ruby-gnome2-vte: dependence update

Revisions pulled up:
- archivers/ruby-libarchive/Makefile				1.2
- comms/ruby-termios/Makefile					1.23
- converters/ruby-uconv/Makefile				1.19
- databases/ruby-do_sqlite3/Makefile				1.2
- databases/ruby-ldap/Makefile					1.7
- databases/ruby-mysql/Makefile					1.34 via patch
- databases/ruby-odbc/Makefile					1.10 via patch
- databases/ruby-pg/Makefile					1.6
- databases/ruby-postgresql/Makefile				1.37
- databases/ruby-qdbm/Makefile					1.12
- databases/ruby-sqlite/Makefile				1.3
- databases/ruby-sqlite3/Makefile				1.15
- databases/ruby-tokyocabinet/Makefile				1.24
- devel/ruby-SDL/Makefile					1.9 via patch
- devel/ruby-debug-base/Makefile				1.7
- devel/ruby-eet/Makefile					1.8
- devel/ruby-eventmachine/Makefile				1.7
- devel/ruby-ffi/Makefile					1.3
- devel/ruby-gnome2-atk/Makefile				1.8
- devel/ruby-gnome2-bonobo/Makefile				patch
- devel/ruby-gnome2-bonoboui/Makefile				patch
- devel/ruby-gnome2-gconf/Makefile				patch
- devel/ruby-gnome2-gio/Makefile				1.3 via patch
- devel/ruby-gnome2-glib/Makefile				1.11
- devel/ruby-gnome2-libglade/Makefile				patch
- devel/ruby-gnome2-pango/Makefile				1.18 via patch
- devel/ruby-linecache/Makefile					1.5
- devel/ruby-memcache/Makefile					1.4
- devel/ruby-ncurses/Makefile					1.9
- devel/ruby-priority-queue/Makefile				1.6
- devel/ruby-racc/Makefile					1.18
- devel/ruby-rbtree/Makefile					1.6
- devel/ruby-rcov/Makefile					1.5
- devel/ruby-rcsparse/Makefile					1.10
- devel/ruby-subversion/Makefile				1.28
- devel/ruby-thrift/Makefile					1.4 via patch
- graphics/ruby-RMagick/Makefile				1.76 via patch
- graphics/ruby-clutter-cairo/Makefile				1.8 via patch
- graphics/ruby-clutter-core/Makefile				1.11 via patch
- graphics/ruby-clutter-gtk/Makefile				1.8 via patch
- graphics/ruby-gd/Makefile					1.34 via patch
- graphics/ruby-gnome2-gdkpixbuf/Makefile			1.20 via patch
- graphics/ruby-gnome2-gnomecanvas/Makefile			patch
- graphics/ruby-gnome2-goocanvas/Makefile			1.12 via patch
- graphics/ruby-gnome2-gtkglext/Makefile			patch
- graphics/ruby-gnome2-libart/Makefile				patch
- graphics/ruby-gnome2-rsvg/Makefile				1.21 va patch
- graphics/ruby-imlib2/Makefile					1.24 va patch
- graphics/ruby-opengl/Makefile					1.31
- graphics/ruby-rcairo/Makefile					1.22 via patch
- inputmethod/ruby-zinnia/Makefile				1.3
- lang/ruby/buildlink3.mk					1.13
- lang/ruby/rubyversion.mk					1.58-1.59
- lang/ruby18-base/distinfo					1.47
- lang/ruby19-base/DEINSTALL					1.2
- lang/ruby19-base/Makefile					1.7
- lang/ruby19-base/PLIST					1.4
- lang/ruby19-base/distinfo					1.4
- lang/ruby19-base/patches/patch-string.c			1.1
- mail/ruby-tmail/Makefile					1.19
- math/ruby-rb-gsl/Makefile					1.9
- multimedia/ruby-clutter-gst/Makefile				1.9 via patch
- multimedia/ruby-gnome2-gstreamer/Makefile			1.7
- multimedia/ruby-ming/Makefile					1.15 via patch
- print/ruby-gnome2-gnomeprint/Makefile				patch
- print/ruby-gnome2-gnomeprintui/Makefile			patch
- print/ruby-gnome2-poppler/Makefile				1.19 via patch
- security/ruby-password/Makefile				1.5
- security/ruby-tcpwrap/Makefile				1.18
- sysutils/ruby-quota/Makefile					1.21
- textproc/ruby-bluecloth/Makefile				1.5
- textproc/ruby-cabocha/Makefile				1.3
- textproc/ruby-eruby/Makefile					1.26
- textproc/ruby-ferret/Makefile					1.6
- textproc/ruby-hpricot/Makefile				1.8
- textproc/ruby-itex2MML/Makefile				1.7
- textproc/ruby-json/Makefile					1.9
- textproc/ruby-libxml/Makefile					1.7
- textproc/ruby-mecab/Makefile					1.6
- textproc/ruby-native-hyperestraier/Makefile			1.6
- textproc/ruby-nokogiri/Makefile				1.4
- textproc/ruby-oniguruma/Makefile				1.6
- textproc/ruby-redcloth/Makefile				1.14
- textproc/ruby-sary/Makefile					1.7
- textproc/ruby-xmlparser/Makefile				1.15
- textproc/ruby-xslt/Makefile					1.7
- textproc/ruby-yamcha/Makefile					1.3
- www/mongrel/Makefile						1.13 via patch
- www/ruby-clearsilver/Makefile					1.15
- www/ruby-fcgi/Makefile					1.15
- www/ruby-gnome2-gtkhtml2/Makefile				patch
- www/ruby-gnome2-gtkmozembed/Makefile				1.17 via patch
- www/ruby-patron/Makefile					1.5
- www/thin/Makefile						1.8 via patch
- x11/ruby-gnome2-gtk/Makefile					1.25 via patch
- x11/ruby-gnome2-gtksourceview/Makefile			patch via 1.12
- x11/ruby-gnome2-gtksourceview2/Makefile			patch
- x11/ruby-gnome2-panelapplet/Makefile				patch
- x11/ruby-gnome2-vte/Makefile					1.16 via patch
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:31:06 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: rubyversion.mk

Log Message:
* Start upate of ruby18 and ruby19 packags.
* Remove redundant GEM_HOME definition from PLIST.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:35:38 UTC 2011

Modified Files:
	pkgsrc/lang/ruby18-base: distinfo

Log Message:
Update ruby18-base package to 1.8.7.334 (Ruby 1.8.7p334).

* The FileUtils Vulnerability

	http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* The $SAFE Vulnerability

Fri Feb 18 21:18:55 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* test/ruby/test_exception.rb (TestException::test_to_s_taintness_propagation):
	  Test for below.

Fri Feb 18 21:18:55 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* error.c (exc_to_s): untainted strings can be tainted via
	  Exception#to_s, which enables attackers to overwrite sane strings.
	  Reported by: Yusuke Endoh <mame at tsg.ne.jp>.

	* error.c (name_err_to_s): ditto.

Fri Feb 18 21:17:22 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* lib/fileutils.rb (FileUtils::remove_entry_secure): there is a
	  race condition in the case where the given path is a directory,
	  and some other user can move that directory, and create a
	  symlink while this method is executing.
	  Reported by: Nicholas Jefferson <nicholas at pythonic.com.au>

Fri Feb 18 19:46:46 2011  NAKAMURA Usaku  <usa@ruby-lang.org>

	* win32/win32.c (init_stdhandle): backport mistake of r29382.
	  some code are needless in ruby 1.8.
	  [ruby-core:34579]

Fri Feb 18 19:22:17 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* configure.in: revert revision r29854.	 This revision introduced
	  binary incompatibilities on some circumstances.  The bug that
	  revision was fixing gets reopened by this reversion.
	  [ruby-dev:43152] cf. [Bug #2553]
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:44:11 UTC 2011

Modified Files:
	pkgsrc/lang/ruby19-base: DEINSTALL Makefile PLIST distinfo
Added Files:
	pkgsrc/lang/ruby19-base/patches: patch-string.c

Log Message:
Update ruby19-base package to 1.9.2pl180 (Ruby 1.9.2 p180).

* The FileUtils Vulnerability

    http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* Add a patch r30779 from repository; a bug of utf-8 string handling.

For more detail changes of Ruby 1.9.2pl180, please refer:
	http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_180/ChangeLog
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 15:00:34 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: buildlink3.mk rubyversion.mk

Log Message:
Introduce RUBY_ABI_VERSION and use it BUILDLINK_ABI_DEPENDS.

There are ABI incompatibility amaong Ruby 1.8.7 patchlevel 302, 330 and 334,
So it would be handle if such problem in future.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 16:01:24 UTC 2011

Modified Files:
	pkgsrc/archivers/ruby-libarchive: Makefile
	pkgsrc/comms/ruby-termios: Makefile
	pkgsrc/converters/ruby-uconv: Makefile
	pkgsrc/databases/ruby-do_sqlite3: Makefile
	pkgsrc/databases/ruby-ldap: Makefile
	pkgsrc/databases/ruby-mysql: Makefile
	pkgsrc/databases/ruby-odbc: Makefile
	pkgsrc/databases/ruby-pg: Makefile
	pkgsrc/databases/ruby-postgresql: Makefile
	pkgsrc/databases/ruby-qdbm: Makefile
	pkgsrc/databases/ruby-sqlite: Makefile
	pkgsrc/databases/ruby-sqlite3: Makefile
	pkgsrc/databases/ruby-tokyocabinet: Makefile
	pkgsrc/devel/ruby-SDL: Makefile
	pkgsrc/devel/ruby-debug-base: Makefile
	pkgsrc/devel/ruby-eet: Makefile
	pkgsrc/devel/ruby-eventmachine: Makefile
	pkgsrc/devel/ruby-ffi: Makefile
	pkgsrc/devel/ruby-gnome2-atk: Makefile
	pkgsrc/devel/ruby-gnome2-gio: Makefile
	pkgsrc/devel/ruby-gnome2-glib: Makefile
	pkgsrc/devel/ruby-gnome2-pango: Makefile
	pkgsrc/devel/ruby-linecache: Makefile
	pkgsrc/devel/ruby-memcache: Makefile
	pkgsrc/devel/ruby-ncurses: Makefile
	pkgsrc/devel/ruby-priority-queue: Makefile
	pkgsrc/devel/ruby-racc: Makefile
	pkgsrc/devel/ruby-rbtree: Makefile
	pkgsrc/devel/ruby-rcov: Makefile
	pkgsrc/devel/ruby-rcsparse: Makefile
	pkgsrc/devel/ruby-subversion: Makefile
	pkgsrc/devel/ruby-thrift: Makefile
	pkgsrc/graphics/ruby-RMagick: Makefile
	pkgsrc/graphics/ruby-clutter-cairo: Makefile
	pkgsrc/graphics/ruby-clutter-core: Makefile
	pkgsrc/graphics/ruby-clutter-gtk: Makefile
	pkgsrc/graphics/ruby-gd: Makefile
	pkgsrc/graphics/ruby-gnome2-gdkpixbuf: Makefile
	pkgsrc/graphics/ruby-gnome2-goocanvas: Makefile
	pkgsrc/graphics/ruby-gnome2-rsvg: Makefile
	pkgsrc/graphics/ruby-imlib2: Makefile
	pkgsrc/graphics/ruby-opengl: Makefile
	pkgsrc/graphics/ruby-rcairo: Makefile
	pkgsrc/inputmethod/ruby-zinnia: Makefile
	pkgsrc/mail/ruby-tmail: Makefile
	pkgsrc/math/ruby-rb-gsl: Makefile
	pkgsrc/multimedia/ruby-clutter-gst: Makefile
	pkgsrc/multimedia/ruby-gnome2-gstreamer: Makefile
	pkgsrc/multimedia/ruby-ming: Makefile
	pkgsrc/print/ruby-gnome2-poppler: Makefile
	pkgsrc/security/ruby-password: Makefile
	pkgsrc/security/ruby-tcpwrap: Makefile
	pkgsrc/sysutils/ruby-quota: Makefile
	pkgsrc/textproc/ruby-bluecloth: Makefile
	pkgsrc/textproc/ruby-cabocha: Makefile
	pkgsrc/textproc/ruby-eruby: Makefile
	pkgsrc/textproc/ruby-ferret: Makefile
	pkgsrc/textproc/ruby-hpricot: Makefile
	pkgsrc/textproc/ruby-itex2MML: Makefile
	pkgsrc/textproc/ruby-json: Makefile
	pkgsrc/textproc/ruby-libxml: Makefile
	pkgsrc/textproc/ruby-mecab: Makefile
	pkgsrc/textproc/ruby-native-hyperestraier: Makefile
	pkgsrc/textproc/ruby-nokogiri: Makefile
	pkgsrc/textproc/ruby-oniguruma: Makefile
	pkgsrc/textproc/ruby-redcloth: Makefile
	pkgsrc/textproc/ruby-sary: Makefile
	pkgsrc/textproc/ruby-xmlparser: Makefile
	pkgsrc/textproc/ruby-xslt: Makefile
	pkgsrc/textproc/ruby-yamcha: Makefile
	pkgsrc/www/mongrel: Makefile
	pkgsrc/www/ruby-clearsilver: Makefile
	pkgsrc/www/ruby-fcgi: Makefile
	pkgsrc/www/ruby-gnome2-gtkmozembed: Makefile
	pkgsrc/www/ruby-patron: Makefile
	pkgsrc/www/thin: Makefile
	pkgsrc/x11/ruby-gnome2-gtk: Makefile
	pkgsrc/x11/ruby-gnome2-gtksourceview2: Makefile
	pkgsrc/x11/ruby-gnome2-vte: Makefile

Log Message:
Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.7 / (download) - annotate - [select for diffs], Mon Feb 21 16:01:18 2011 UTC (10 years, 7 months ago) by taca
Branch: MAIN
Changes since 1.6: +2 -1 lines
Diff to previous 1.6 (colored)

Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Oct 23 12:45:11 2010 UTC (10 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base
Branch point for: pkgsrc-2010Q4
Changes since 1.5: +3 -1 lines
Diff to previous 1.5 (colored)

Update ruby-gnome2 to 0.90.3.

= NEWS

== Ruby-GNOME2 0.90.3: 2010-10-23

NOTE: 0.90.x releases are for 1.0.0 major release.

  * Support String encoding in Ruby 1.9.
  * RVAL2CSTR2 and CSTR2RVAL2 are deprecated.
  * Ruby/GIO2 is imported as an experimental library.

=== Changes

==== All

  * Support String encoding.
    [Guillaume Cottenceau, Neil Roberts, Kouhei Sutou]
  * Don't install *.pc by default. Set pkgconfigdir make
    varialbe like 'make pkgconfigdir=/usr/lib/pkgconfig'.

==== Ruby/GLib2

  * Improvements:
    * declare argument types.
      [Nobuyoshi Nakada, Kouhei Sutou]

==== Ruby/GIO2

  * Imported as an experimental library.
    [Nikolai Weibull]

==== Ruby/GTK2

  * Improvements:
    * keep backward compatibility around GDK key
      symbols introduced at GTK+ 2.20.
      "[ruby-gnome2-devel-en] Constants names change in Gdk::KeyVal"
      [Vincent Carmona]
    * move gdk-pixbuf and cairo related methods from Ruby/GdkPixbuf2.
      "[ruby-gnome2-devel-en] gtk2 dependency to gdkpixbuf2"
      [Andrea Dallera, Kouhei Sutou]
  * Bug fixes:
    * fix GType conversion in Gtk::ItemFactory.new on 64bit
      platform.
      [Grant McLean, Steve Wills, Kouhei Sutou]

==== Ruby/GdkPixbuf2

  * Improvements:
    * move gdk-pixbuf and cairo related methods to Ruby/GTK2.
      "[ruby-gnome2-devel-en] gtk2 dependency to gdkpixbuf2"
      [Andrea Dallera, Kouhei Sutou]
    * change .pc filename from ruby-gdkpixbuf2 to
      ruby-gdk-pixbuf2.

==== Ruby/RSVG2

  * Bug fixes:
    * add missing libcroco dependency on Windows.
      [U.Nakamura, Kouhei Sutou]

==== Ruby/Poppler

  * Improvements:
    * support Popper 0.15.0. [#3079667]
      [Mamoru Tasaka, Kouhei Sutou]

  * Bug fixes:
    * add missing libjpeg dependency on Windows.
      [U.Nakamura, Kouhei Sutou]
    * fix installed Ruby/GLib2 gem can't be detected.
      [kdmsnr, Kouhei Sutou]

=== Thanks

  * U.Nakamura
  * kdmsnr
  * Mamoru Tasaka
  * Guillaume Cottenceau
  * Vincent Carmona
  * Grant McLean
  * Steve Wills
  * Andrea Dallera
  * Nobuyoshi Nakada
  * Neil Roberts

== Ruby-GNOME2 0.90.2: 2010-09-26

NOTE: 0.90.x releases are for 1.0.0 major release.

A RubyGems package fix release.

=== Changes

==== All

  * fix path.
    [kimura wataru, Kouhei Sutou]

==== Ruby/GTK2

  * Bug fixes:
    * fix gtk2/base.rb is missing in gem.
      [S.Kitagawa, Kouhei Sutou]

==== Ruby/GIO2

  * Bug fixes:
    * fix a typo in .pc name. [#3075619]
      [O01eg, Kouhei Sutou]

==== Ruby/RSVG2

  * Bug fixes:
    * also check rb_cairo.h availability. [#3075617]
      [O01eg, Kouhei Sutou]

=== Thanks

  * S.Kitagawa
  * O01eg
  * kimura wataru

Revision 1.5 / (download) - annotate - [select for diffs], Thu Sep 23 15:36:01 2010 UTC (11 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.4: +2 -3 lines
Diff to previous 1.4 (colored)

Update ruby-gnome2 to 0.90.1.

= NEWS

== Ruby-GNOME2 0.90.1: 2010-09-23

NOTE: 0.90.x releases are for 1.0.0 major release.

A install bug fix release of 0.90.0.

=== Changes

==== Ruby/ATK

  * Bug fixes:
    * fix .pc install path.
      [OBATA Akio, Kouhei Sutou]

==== Ruby/GTK2

  * Bug fixes:
    * fix .pc install path.
      [OBATA Akio, Kouhei Sutou]

==== Ruby/Pango

  * Bug fixes:
    * fix .pc install path.
      [OBATA Akio, Kouhei Sutou]

==== Ruby/Poppler

  * Bug fixes:
    * fix .pc install path.
      [OBATA Akio, Kouhei Sutou]

==== Ruby/RSVG

  * Bug fixes:
    * fix .pc install path.
      [OBATA Akio, Kouhei Sutou]

=== Thanks

  * OBATA Akio

== Ruby-GNOME2 0.90.0: 2010-09-23

NOTE: 0.90.x releases are for 1.0.0 major release.

RubyGems support!

=== Changes

==== Ruby/GTK2

  * Bug fixes:
    * [ruby-gnome2-devel-en] Gtk 2.20, Gtk::Builder and 'name'
      add Gtk::Buildable#builder_name/set_builder_name.
      [Simon Arnaud, Kouhei Sutou]

=== Thanks

  * Simon Arnaud

Revision 1.4 / (download) - annotate - [select for diffs], Sat Apr 17 06:40:44 2010 UTC (11 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Update ruby-gnome2 to 0.19.4.

== Ruby-GNOME2 0.19.4: 2011-04-17

NOTE: 0.19.x releases are development series.

This release has many bug fixes and some improvements. The
fixed bugs include a memory leak bug on GC. If your
application live long time, you should upgrade.

=== Changes

==== Ruby/GLib2

  * Bug fixes:
    * fixed type_register on Ruby 1.9.
      [Simon Arnaud, Kouhei Sutou]
    * fixed memory leak in GC.
      [Kouhei Sutou]

==== Ruby/GTK2

  * Bug fixes:
    * [#2865895] support GdkWindow's cursor property.
      NOTE: GTK+ 2.18.0 is unsupported version.
      [Guillaume Cottenceau, Mamoru Tasaka]
    * Gtk::MenuItem.new accepts nil as a label.
      [Kazuhiro NISHIYAMA, Kouhei Sutou]
    * fixed wrong conversion in Gtk::TreePath#<=>.
      [Takeuchi Yusuke, Kouhei Sutou]
    * fix Gtk::RecentInfo#application_info's double free bug.
      [Kouhei Sutou]
  * Improvements:
    * Gdk::Window#invalidate accepts nil as 'area'
      argument. It means 'invalidates whole window'.
      [Hiroyuki Ito]
    * Gtk::Clipbord#request_text sets UTF-8 encoding in Ruby
      1.9.
      [Rg Rg, Kouhei Sutou]
    * add Gtk::TreePath#==.
      [Takeuchi Yusuke, Kouhei Sutou]

==== Ruby/Pango

  * Improvements:
    * add Pango::Gravity.
      [Hiroyuki Ito, Kouhei Sutou]

==== Ruby/GdkPixbuf

  * add Gdk::Pixbuf#pixels=.
    [Michal Suchanek]

==== Ruby/GStreamer

  * Bug fixes:
    * [#2920997] fix argument type. [Johan Kiviniemi]
  * [#2924886] implement Gst::MessageTag#parse. [Vincent Carmona]

==== Ruby/GtkMozEmbed

  * Bug Fixes:
    * [#2924766] fix -Wl,-rpath syntax. [OBATA Akio]
    * [#2925285] Gtk::MozEmbed#chrome_mask fails.
      [tobi, Kouhei Sutou]
    * support XULRunner 1.9.2. [OBATA Akio]

=== Thanks

  * Guillaume Cottenceau
  * Mamoru Tasaka
  * Michal Suchanek
  * Simon Arnaud
  * Kazuhiro NISHIYAMA
  * Johan Kiviniemi
  * OBATA Akio
  * Hiroyuki Ito
  * Rg Rg
  * Vincent Carmona
  * tobi
  * Takeuchi Yusuke
  * ...

Revision 1.3 / (download) - annotate - [select for diffs], Mon Oct 12 03:09:32 2009 UTC (11 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Update ruby-gnome2 to 0.19.3.

== Ruby-GNOME2 0.19.3: 2009-09-24

NOTE: 0.19.x releases are development series.

This release is a bug fix release of 0.19.2.

=== Changes

===== Ruby/GLib2

  * Bug fix:
    * really fix
      'empty $(vendorarchdir) related build problem on CentOS 5.3 x86_64.'
      [Simon Arnaud, Kouhei Sutou]

=== Thanks

  * Simon Arnaud

== Ruby-GNOME2 0.19.2: 2009-09-23

NOTE: 0.19.x releases are development series.

This release is a bug fix release of 0.19.1.

=== Changes

==== Ruby/GLib2

  * Bug fixes:
    * empty $(vendorarchdir) related build problem on CentOS 5.3 x86_64.
      [Toshiyuki Suzumura, Kouhei Sutou]
    * [#2862022] fix multi thread blocking with Ruby
      1.8.6-p368 or later and 1.8.7-p173 or later.
      [Roy Wright, Andrea Dallera, Kouhei Sutou]
    * [Debian #502262] work Ruby thread with GTK+.
      [Johan Walles, Kouhei Sutou]

==== Ruby/GTK2

  * Bug fixes:
    * [#2679744] fix a typo:
      Gtk::Widget#set_scroll_adjustment ->
      Gtk::Widget#set_scroll_adjustments.
      [Kentaro Fukuchi, Kouhei Sutou]

==== Ruby/GtkMozEmbed

  * Bug fixes:
    * fix .pc detection.
      [OBATA Akio, Kouhei Sutou]

=== Thanks

  * OBATA Akio
  * Toshiyuki Suzumura
  * Roy Wright
  * Andrea Dallera
  * Johan Walles
  * Kentaro Fukuchi

Revision 1.2 / (download) - annotate - [select for diffs], Tue Oct 28 13:43:58 2008 UTC (12 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Update ruby-gnome2 to 0.18.1.

== Ruby-GNOME2 0.18.1: 2008-10-23

This release is bug fix release of 0.18.0.

=== Changes

Ruby/GTK2:
  * fix a bug that init function is deleted. [Kouhei Sutou]

Revision 1.1 / (download) - annotate - [select for diffs], Wed Sep 17 00:21:49 2008 UTC (13 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3

Update ruby-gnome2 to 0.17.0 release.

pkgsrc changes:
   * Add some additional modules:
    	devel/ruby-gnome2-bonobo
    	devel/ruby-gnome2-bonoboui
    	devel/ruby-gnome2-gconf
    	devel/ruby-gnome2-libglade
    	graphics/ruby-gnome2-gtkglext
    	multimedia/ruby-gnome2-gstreamer
    	print/ruby-gnome2-gnomeprintui
    	sysutils/ruby-gnome2-gnomevfs
    	www/ruby-gnome2-gtkhtml2
    	www/ruby-gnome2-gtkmozembed
    	x11/ruby-gnome2-gtksourceview
    	x11/ruby-gnome2-vte
   * Fixed detection of rcairo. It had been broken since switched to gem.
     patch-a{c,h,i,j,k,l.m}
     (It Already in upstream trunk)
   * Add patches for allow to load gem rcairo.
     patch-a{n,o,p}
   * Fixed overwritten glib module when installing modules require generated
     header of glib module.
     Modify to install the header as part of glib module and use bl3.mk.
   * clean up dependency
   * Add test target for modules having unit test.
   * Modified patch-a{a,b,d,f,g} to acceptable by upstream.

Ruby-GNOME2-0.17.0 (2008-09-07)

  Release notes:
  * This Release supports Ruby 1.8.7 and has many bug fixes and
    new bound functions.

  Main changes:
  * Ruby/GLib:
    - [#2060606] Crash when removing ruby applet from gnome panel with 0.7rc1
      [Kouhei Sutou]

  * Ruby/GTK:
    - [#2025651] FTBFS with gtk+ 2.13.5 [Cesare Tirabassi, Kouhei Sutou]

    - [#2043970] Segfaults on 64-bit Linux [Neil Roberts, Kouhei Sutou]

  * Ruby/Pango:
    - [#2043970] Pango::FontDescription#weight= seg fault [Kouhei Sutou]

  * Many other changes, GC bugs, Segfault fixes. See corresponding ChangeLog
    for detailed information on changes and contributors.

    Special thanks for your contributions to: (list in no particular order)
    - Neil Roberts
    - Cesare Tirabassi
    - Arnaud Cornet

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>