[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / ns-flash

File: [cvs.NetBSD.org] / pkgsrc / multimedia / ns-flash / Attic / Makefile (download)

Revision 1.27, Sun Dec 23 22:27:15 2007 UTC (16 years, 3 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.26: +2 -3 lines

Update flash player packages to the latest version (9.0.115).
Done during 2007Q4 freeze because the old distfile is no longer available.

New audio/video options
    * H.264/HE-AAC codec support
Improved Performance
    * Multi-core support
    * Multi-threaded video decoding
    * Image scaling
    * Flash Player cache
    * Flash Media Server buffering
Universal Reach
    * Full screen mode for Linux
    * Accessibility support for the plugin
    * Mac Os X Leopard support

Fixed in this version:

    * On Linux, modal dialogs displayed by Flash Player stay in front of browser windows but do not prevent interaction with the browser as they should. (191331)
    * On certain SUSE 9.2 installations using the standalone player only, trying to Open a browser from the standalone player with SeaMonkey open will cause the player to hang. (193383)
    * On Linux, networking operations in the standalone player are currently slow. (193158)
    * On Linux, when the mouse is hovering over Flash content, keyboard input is not sent to the browser. (194265)
    * Full-screen mode is not supported in the Opera Browser on Macintosh systems. (189140)
    * Full-screen mode is now supported on Linux.
    * The plugin version of Flash Player does not fire flash.events.Event.RENDER when wmode is set as transparent. (198515)
    * Full-screen can be used when wmode is set (202290)
    * Passing large amounts of XML through External Interface is significantly faster (206828)
    * ExternalInterface now works with HTML objects that contain dots within the object name (199614)

# $NetBSD: Makefile,v 1.27 2007/12/23 22:27:15 tnn Exp $

CATEGORIES=		multimedia www
MASTER_SITES=		http://fpdownload.macromedia.com/get/flashplayer/current/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.flash.com/
COMMENT=		MacroMedia Flash Player Netscape plugin

# Must update communicator/navigator to at least 4.76nb1
CONFLICTS+=		communicator<=4.76nb1
CONFLICTS+=		navigator<=4.76nb1

LICENSE=		flash-license
RESTRICTED=		Redistribution not permitted
NO_SRC_ON_FTP=		${RESTRICTED}
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}

WRKSRC=			${WRKDIR}/${WRKNAME}
BUILD_DIRS=		# empty
DIST_SUBDIR=		flash/${FLASH_VERS}

CRYPTO=			yes

EMUL_PLATFORMS=		linux-i386
EMUL_PLATFORMS+=	solaris-sparc
EMUL_MODULES.linux=	compat gtk2 x11
EMUL_REQD=		suse>=9.0

.include "../../mk/bsd.prefs.mk"

.if ${EMUL_PLATFORM} == "solaris-sparc"
FLASH_VERS=		7.0r67
PKGREVISION=		2
DISTUNAME=		solaris
DISTNAME=		install_flash_player_7_${DISTUNAME}_sparc
WRKNAME=		install_flash_player_7_${DISTUNAME}
.else  # if ${EMUL_PLATFORM} == "linux-i386"
# Defaults so lintpkgsrc is happy
FLASH_VERS=		9.0r115
DISTUNAME=		linux
DISTNAME=		install_flash_player_9_${DISTUNAME}
WRKNAME=		install_flash_player_9_${DISTUNAME}
.endif

PKGNAME=		ns-flash-${FLASH_VERS:S/r/./}

NS_PLUGINS_DIR=		${PREFIX}/lib/netscape/plugins

.include "options.mk"

do-install:
	${INSTALL_DATA_DIR} ${NS_PLUGINS_DIR}
	${INSTALL_DATA} ${WRKSRC}/libflashplayer.so ${NS_PLUGINS_DIR}

.include "../../mk/bsd.pkg.mk"