[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / mplayer-share

Annotation of pkgsrc/multimedia/mplayer-share/Makefile.common, Revision 1.3

1.3     ! jmmv        1: # $NetBSD: Makefile.common,v 1.2 2004/02/17 05:28:31 xtraeme Exp $
1.1       jmmv        2: #
                      3:
                      4: MPLAYER_DIST_VERSION=  1.0pre3
                      5:
                      6: # This variable is used in all packages which depend on this package
                      7: MPLAYER_PKG_VERSION=   1.0rc3
                      8:
                      9: DISTNAME=              MPlayer-${MPLAYER_DIST_VERSION}
                     10: CATEGORIES?=           multimedia
                     11: MASTER_SITES=          http://www.mplayerhq.hu/MPlayer/releases/ \
                     12:                        http://www2.mplayerhq.hu/MPlayer/releases/ \
                     13:                        ftp://ftp.mplayerhq.hu/MPlayer/releases/ \
                     14:                        ftp://ftp2.mplayerhq.hu/MPlayer/releases/
                     15: EXTRACT_SUFX=          .tar.bz2
                     16: DIST_SUBDIR=           mplayer-${MPLAYER_PKG_VERSION}
                     17:
                     18: MAINTAINER?=           tech-pkg@NetBSD.org
                     19: HOMEPAGE?=             http://www.mplayerhq.hu/
                     20:
                     21: PATCHDIR=              ${.CURDIR}/../../multimedia/mplayer-share/patches
                     22:
                     23: NO_BIN_ON_CD=          "a dependency is restricted"
                     24: NO_BIN_ON_FTP=         "a dependency is restricted"
                     25: NO_SRC_ON_FTP=         "prohibited by USAs DMCA"
                     26:
1.3     ! jmmv       27: USE_BUILDLINK3=                YES
1.1       jmmv       28: USE_GNU_TOOLS+=                make
                     29: HAS_CONFIGURE=         YES
                     30:
                     31: PTHREAD_OPTS+=         require
                     32:
                     33: CONFIGURE_ARGS+=       --prefix="${PREFIX}" \
                     34:                        --with-extraincdir="${LOCALBASE}/include" \
                     35:                        --with-extralibdir="${LOCALBASE}/lib" \
1.2       xtraeme    36:                        --with-x11incdir="${X11BASE}/include" \
                     37:                        --with-x11libdir="${X11BASE}/lib" \
1.1       jmmv       38:                        --disable-mpdvdkit \
                     39:
                     40: # The configure script attempts to test-execute compiled programs in /tmp,
                     41: # but that directory may be mounted as noexec; work this around by setting
                     42: # TMPDIR to ${WRKDIR}
                     43: CONFIGURE_ENV+=                TMPDIR=${WRKDIR}
                     44:
                     45: .include "../../mk/bsd.prefs.mk"
                     46:
                     47: .if ${MACHINE_ARCH} == "i386"
                     48: CONFIGURE_ARGS+=       --with-win32libdir="${LOCALBASE}/lib/win32"
                     49: .  if ${MPLAYER_ENABLE_RUNTIME_CPU_DETECTION} == YES
                     50: CONFIGURE_ARGS+=       --enable-runtime-cpudetection
                     51: .  endif
                     52: BUILD_DEFS+=           MPLAYER_ENABLE_RUNTIME_CPU_DETECTION
                     53: .endif
                     54:
                     55: .if ${MACHINE_ARCH} == "i386" || ${MACHINE_ARCH} == "powerpc" || ${MACHINE_ARCH} == "alpha"
                     56: CONFIGURE_ARGS+=       --with-reallibdir="${LOCALBASE}/lib/RealPlayer8-Codecs"
                     57: .endif
                     58:
                     59: .if defined(BUILDLINK_PREFIX.cdparanoia)
                     60: CONFIGURE_ARGS+=       --with-cdparanoiaincdir="${BUILDLINK_PREFIX.cdparanoia}/include/cdparanoia"
                     61: .endif
                     62:
                     63: .if ${OPSYS} == "SunOS" && !empty(MPLAYER_USE_MEDIALIB:M[Yy][Ee][Ss])
                     64: CONFIGURE_ARGS+=       --enable-mlib
                     65: .else
                     66: CONFIGURE_ARGS+=       --disable-mlib
                     67: .endif
                     68:
                     69: # Keep this list in sync with the one in bsd.pkg.defaults.mk, where
                     70: # MPLAYER_DISABLE_DRIVERS is explained.
                     71: MPLAYER_DRIVERS=       arts            audio/arts \
                     72:                        esd             audio/esound \
                     73:                        nas             audio/nas \
                     74:                        sdl             devel/SDL
                     75:
                     76: # arts is currently broken on Solaris.
                     77: .if ${OPSYS} == "SunOS"
                     78: MPLAYER_DISABLE_DRIVERS=       arts
                     79: .endif
                     80:
                     81: .if defined(PKGNAME) && !empty(PKGNAME:M*encoder*)
                     82: MPLAYER_DISABLE_DRIVERS=arts esd nas sdl
                     83: .else
                     84: BUILD_DEFS+=           MPLAYER_DISABLE_DRIVERS
                     85: .endif
                     86: .for drv pkg in ${MPLAYER_DRIVERS}
                     87: .  if empty(MPLAYER_DISABLE_DRIVERS:M${drv})
                     88: CONFIGURE_ARGS+=       --enable-${drv}
                     89: .  else
                     90: CONFIGURE_ARGS+=       --disable-${drv}
                     91: .  endif
                     92: .endfor

CVSweb <webmaster@jp.NetBSD.org>