[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / libass

File: [cvs.NetBSD.org] / pkgsrc / multimedia / libass / Makefile (download)

Revision 1.4, Mon Jan 21 13:24:52 2013 UTC (11 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.3: +4 -4 lines

Update to 0.10.1; bump ABI depends due to new fribidi dependency.

libass (0.10.1)
 * Fix letter spacing
 * Add \rSTYLENAME syntax support (GC #43)
 * Fix border generation and border style reset (GC #56)
 * Fix various issues with bug-for-bug compatibility of
   transformations (\fax, \fay, etc.) to VSFilter (GC #46, GC #42)
 * Fix drawing parsing (GC #47)
 * Various fixes to shaper (GC #54, GC #55, GC#59)
 * Fix change detection
 * Add ass_set_line_position API to set a vertical subtitle offset
 * Fix scaling of drawing baseline offset (\pbo) values
 * Fix skipping of zero-width characters for FriBiDi shaper
 * Use LTR text base direction by default, similar to VSFilter

libass (0.10.0)
 * Bidirectional layout and Arabic shaping via FriBidi (GC #13)
 * OpenType shaping via HarfBuzz-ng (GC #13)
 * Add API for shaper configuration
 * Add support for `Language' Script Info property, this can be used for
   hinting the text language
 * Vertical layout improvements
   * Use `vert' and `vkna' OpenType features for vertical glyph variants
   * Position rotated glyphs onto baseline
 * Parse font encoding property for base text direction hinting
 * Refactor cache system
 * Use generic outlines in place of FreeType glyphs
 * Direct outline bitmap rendering
 * Fix whitespace trimming (GC #35)
 * Do not render border if there's no shadow or glyph (GC #29)
 * Adjust spacing after a italic to non-italic style change (GC #37)
 * Fix fade timing
 * Fix x positioning with borders (GC #27)
 * Build system tweaks

# $NetBSD: Makefile,v 1.4 2013/01/21 13:24:52 wiz Exp $
#

DISTNAME=	libass-0.10.1
CATEGORIES=	multimedia
MASTER_SITES=	http://libass.googlecode.com/files/
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://code.google.com/p/libass/
COMMENT=	Portable subtitle renderer for the ASS/SSA subtitle format
LICENSE=	isc

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	pkg-config

PKGCONFIG_OVERRIDE+=	libass.pc.in

BUILDLINK_API_DEPENDS.fribidi+=	fribidi>=0.19.0
.include "../../converters/fribidi/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../textproc/enca/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"