[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / libass

File: [cvs.NetBSD.org] / pkgsrc / multimedia / libass / Makefile (download)

Revision 1.15, Sun Dec 13 10:25:48 2015 UTC (8 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.14: +2 -2 lines

Release 0.13.1:
Much faster duplicate event check in ass_process_chunk. This can bring a large speedup for embedded subtitles with lots of events. To make this possible, it is now forbidden to combine calls to ass_process_chunk with any other method of manipulating the event list, namely, manual manipulation and calls to ass_process_data, ass_read_memory and ass_read_file.
Interpret negative timestamp components as actual negative numbers. This change increases compatibility with VSFilter.
Font matching changes for VSFilter compatibility
Look up fonts that contain PostScript outlines by their PostScript name instead of their full names. Family names continue to be used for all fonts.
Keep spaces in font names
Drop support for Fontconfig < 2.10.92 to ensure correct font matching
Bug fixes
Fix building the assembler code for the x32 ABI
Fix static linking against libass through pkg-config when libass uses libiconv
Fix some small memory leaks, potential crashes and bad data uses

# $NetBSD: Makefile,v 1.15 2015/12/13 10:25:48 adam Exp $

DISTNAME=	libass-0.13.1
CATEGORIES=	multimedia
MASTER_SITES=	${MASTER_SITE_GITHUB:=libass/}
GITHUB_PROJECT=	libass
GITHUB_RELEASE=	${PKGVERSION_NOREV}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://code.google.com/p/libass/
COMMENT=	Portable subtitle renderer for the ASS/SSA subtitle format
LICENSE=	isc

USE_LIBTOOL=		yes
USE_TOOLS+=		pkg-config
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-asm
PKGCONFIG_OVERRIDE+=	libass.pc.in

LDFLAGS+=	${BUILDLINK_LDADD.iconv}

BUILDLINK_API_DEPENDS.fribidi+=	fribidi>=0.19.0
.include "../../converters/fribidi/buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../fonts/harfbuzz/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../textproc/enca/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"