File:  [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins1-good / Makefile
Revision 1.29: download - view: text, annotated - select for diffs
Mon May 13 09:05:55 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
gstreamer1: updated to 1.24.3

1.24.3

This release only contains bugfixes and it should be safe to update from 1.24.x.

Highlighted bugfixes in 1.24.3

EXIF image tag parsing security fixes
Subtitle handling improvements in parsebin
Fix issues with HLS streams that contain VTT subtitles
Qt6 QML sink re-render and re-sizing fixes
unixfd ipc plugin timestamp and segment handling fixes
vah264enc, vah265enc: Do not touch the PTS of the output frame
vah264dec and vapostproc fixes and improvements
v4l2: multiple fixes and improvements, incl. for mediatek JPEG decoder and v4l2 loopback
v4l2: fix hang after seek with some v4l2 decoders
Wayland sink fixes
ximagesink: fix regression on RPi/aarch64
fmp4mux, mp4mux gained FLAC audio support
D3D11, D3D12: reliablity improvements and memory leak fixes
Media Foundation device provider fixes
GTK4 paintable sink improvements including support for directly importing dmabufs with GTK 4.14
WebRTC sink/source fixes and improvements
AWS s3sink, s3src, s3hlssink now support path-style addressing
MPEG-TS demuxer fixes
Python bindings fixes
various bug fixes, memory leak fixes, and other stability and reliability improvements



1.24.2

This release only contains bugfixes and it should be safe to update from 1.24.x.

Highlighted bugfixes in 1.24.2

H.264 parsing regression fixes
WavPack typefinding improvements
Video4linux fixes and improvements
Android build and runtime fixes
macOS OpenGL memory leak and robustness fixes
Qt/QML video sink fixes
Package new analytics and mse libraries in binary packages
Windows MSVC binary packages: fix libvpx avx/avx2/avx512 instruction set detection
various bug fixes, memory leak fixes, and other stability and reliability improvements

# $NetBSD: Makefile,v 1.29 2024/05/13 09:05:55 adam Exp $

PKGNAME=	${DISTNAME:S/plugins/plugins1/}
CATEGORIES=	multimedia gnome

COMMENT=	Open source multimedia framework - good plugins

USE_TOOLS+=	xgettext

# Feature options for plugins without external deps
GST_PLUGINS+=	alpha
GST_PLUGINS+=	apetag
GST_PLUGINS+=	audiofx
GST_PLUGINS+=	audioparsers
GST_PLUGINS+=	auparse
GST_PLUGINS+=	autodetect
GST_PLUGINS+=	avi
GST_PLUGINS+=	cutter
GST_PLUGINS+=	debugutils
GST_PLUGINS+=	deinterlace
GST_PLUGINS+=	dtmf
GST_PLUGINS+=	effectv
GST_PLUGINS+=	equalizer
GST_PLUGINS+=	flv
GST_PLUGINS+=	flx
GST_PLUGINS+=	goom
GST_PLUGINS+=	goom2k1
GST_PLUGINS+=	icydemux
GST_PLUGINS+=	id3demux
GST_PLUGINS+=	imagefreeze
GST_PLUGINS+=	interleave
GST_PLUGINS+=	isomp4
GST_PLUGINS+=	law
GST_PLUGINS+=	level
GST_PLUGINS+=	matroska
GST_PLUGINS+=	monoscope
GST_PLUGINS+=	multifile
GST_PLUGINS+=	multipart
GST_PLUGINS+=	replaygain
GST_PLUGINS+=	rtp
GST_PLUGINS+=	rtpmanager
GST_PLUGINS+=	rtsp
GST_PLUGINS+=	shapewipe
GST_PLUGINS+=	smpte
GST_PLUGINS+=	spectrum
GST_PLUGINS+=	udp
GST_PLUGINS+=	videobox
GST_PLUGINS+=	videocrop
GST_PLUGINS+=	videofilter
GST_PLUGINS+=	videomixer
GST_PLUGINS+=	wavenc
GST_PLUGINS+=	wavparse
GST_PLUGINS+=	xingmux
GST_PLUGINS+=	y4m

GST_PLUGINS+=	nls
GST_PLUGINS+=	tests

.include "Makefile.common"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>