[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins1-base

File: [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins1-base / Makefile.common (download)

Revision 1.12, Wed Nov 18 12:04:16 2015 UTC (8 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.11: +3 -3 lines

Update gstreamer1 and plugins to 1.6.1.

GStreamer 1.6.1 Release Notes

The GStreamer team is proud to announce the first bugfix release in the stable 1.6 release series of your favourite cross-platform multimedia framework!

This release only contains bugfixes and it is safe to update from 1.6.0. For a full list of bugfixes see Bugzilla.

See http://gstreamer.freedesktop.org/releases/1.6/ for the latest version of this document.

Last updated: Friday 30 October 2015, 14:00 UTC (log)
Major bugfixes

    Crashes in the gst-libav encoders were fixed
    More DASH-IF test streams are working now
    Live DASH, HLS and MS SmoothStreaming streams work more reliable and other fixes for the adaptive streaming protocols
    Reverse playback works with scaletempo to keep the audio pitch
    Correct stream-time is reported for negative applied_rate
    SRTP packet validation during decoding does not reject valid packets anymore
    Fixes for audioaggregator and aggregator to start producing output at the right time, and e.g. not outputting lots of silence in the beginning
    gst-libav's internal ffmpeg snapshot was updated to 2.8.1
    cerbero has support for Mac OS X 10.11 (El Capitan)
    Various memory leaks were fixed, including major leaks in playbin, playsink and decodebin
    Various GObject-Introspection annotation fixes for bindings
    and many, many more

GStreamer 1.6 Release Notes

The GStreamer team is proud to announce a new major feature release in the stable 1.x API series of your favourite cross-platform multimedia framework!

This release has been in the works for more than a year and is packed with new features, bug fixes and other improvements.

See http://gstreamer.freedesktop.org/releases/1.6/ for the latest version of this document.
Highlights

    Stereoscopic 3D and multiview video support
    Trick mode API for key-frame only fast-forward/fast-reverse playback etc.
    Improved DTS (decoding timestamp) vs. PTS (presentation timestamp) handling to account for negative DTS
    New GstVideoConverter API for more optimised and more correct conversion of raw video frames between all supported formats, with rescaling
    v4l2src now supports renegotiation
    v4l2transform can now do scaling
    V4L2 Element now report Colorimetry properly
    Easier chunked recording of MP4, Matroska, Ogg, MPEG-TS: new splitmuxsink and multifilesink improvements
    Content Protection signalling API and Common Encryption (CENC) support for DASH/MP4
    Many adaptive streaming (DASH, HLS and MSS) improvements
    New PTP and NTP network client clocks and better remote clock tracking stability
    High-quality text subtitle overlay at display resolutions with glimagesink or gtkglsink
    RECORD support for the GStreamer RTSP Server
    Retransmissions (RTX) support in RTSP server and client
    RTSP seeking support in client and server has been fixed
    RTCP scheduling improvements and reduced size RTCP support
    MP4/MOV muxer acquired a new "robust" mode of operation which attempts to keep the output file in a valid state at all times
    Live mixing support in aggregator, audiomixer and compositor was improved a lot
    compositor now also supports rescaling of inputs streams on the fly
    New audiointerleave element with proper input synchronisation and live input support
    Blackmagic Design DeckLink capture and playback card support was rewritten from scratch; 2k/4k support; mode sensing
    KLV metadata support in RTP and MPEG-TS
    H.265 video encoder (x265), decoders (libav, libde265) and RTP payloader and depayloaders
    New DTLS plugin and SRTP/DTLS support
    OpenGL3 support, multiple contexts and context propagation, 3D video, transfer/conversion separation, subtitle blending
    New OpenGL-based QML video sink, Gtk GL video sink, CoreAnimation CAOpenGLLayerSink video sink
    gst-libav switched to ffmpeg as libav-provider, gains support for 3D/multiview video, trick modes, and the CAVS codec
    GstHarness API for unit tests
    gst-editing-services got a completely new ges-launch-1.0 interface, improved mixing support and integration into gst-validate
    gnonlin has been deprecated in favor of nle (Non Linear Engine) in gst-editing-services
    gst-validate has a new plugin system, an extensive default testsuite, support for concurrent test runs and valgrind support
    cerbero build tool for SDK binary packages gains new 'bundle-source' command
    Various improvements to the Android, iOS, OS X and Windows platform support

Full log at
http://gstreamer.freedesktop.org/releases/1.6/

# $NetBSD: Makefile.common,v 1.12 2015/11/18 12:04:16 wiz Exp $
#
# used by audio/gst-plugins1-alsa/Makefile
# used by audio/gst-plugins1-cdparanoia/Makefile
# used by sysutils/gst-plugins1-gio/Makefile
# used by audio/gst-plugins1-libvisual/Makefile
# used by multimedia/gst-plugins1-ogg/Makefile
# used by devel/gst-plugins1-pango/Makefile
# used by multimedia/gst-plugins1-theora/Makefile
# used by audio/gst-plugins1-vorbis/Makefile
# used by x11/gst-plugins1-x11/Makefile
#

GST_PLUGINS1_TYPE=	base
GST_PLUGINS1_VER=	1.6.1
BUILDLINK_API_DEPENDS.gstreamer1+= gstreamer1>=1.6.1
LICENSE=		gnu-lgpl-v2

# Disable all drivers and features by default.
.for driver in	alsa \
		cdparanoia \
		freetypetest \
		gio \
		ivorbis \
		libvisual \
		ogg \
		pango \
		theora \
		vorbis \
		x \
		xshm \
		xvideo
CONFIGURE_ARGS+=	--disable-${driver}
.endfor

.include "../../devel/orc/buildlink3.mk"
.include "plugins.mk"