[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins0.10-base

File: [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins0.10-base / Attic / Makefile (download)

Revision 1.42, Thu May 6 08:15:59 2021 UTC (2 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.41: +13 -2 lines

gst-plugins0.10-base: fix build with gmake 4.3

Based on patches for chat/farstream.

# $NetBSD: Makefile,v 1.42 2021/05/06 08:15:59 wiz Exp $
#

.include "Makefile.common"
PKGREVISION=		17

#CONFIGURE_ARGS+=	--disable-silent-rules

COMMENT+=		Base plugins

# some plugins were moved from bad to base
CONFLICTS+=		gst-plugins0.10-bad<0.10.10

USE_TOOLS+=		perl:run autoconf automake gmake
TOOL_DEPENDS+=		gtk-doc-[0-9]*:../../textproc/gtk-doc

MAKE_JOBS_SAFE=		no
PKGCONFIG_OVERRIDE+=	pkgconfig/*.pc.in
REPLACE_PERL+=		tools/gst-visualise-m.m

PKG_OPTIONS_VAR=	PKG_OPTIONS.gst-plugins0.10-base
PKG_SUPPORTED_OPTIONS=	introspection
PKG_SUGGESTED_OPTIONS=	introspection
.include "../../mk/bsd.options.mk"

PLIST_VARS+=	introspection

# only useful if gstreamer was built with the "gstcheck" option
TEST_TARGET=		check-torture

# soft dependency only, .pc file not needed
#.include "../../textproc/iso-codes/buildlink3.mk"

.if !empty(PKG_OPTIONS:Mintrospection)
PLIST.introspection=	yes
.include "../../devel/gobject-introspection/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-introspection
.endif

pre-configure:
	cd ${WRKSRC} && autoreconf -fiv

# XXX: hack
# autoreconf some breaks the file names of the .mo files
# manually fix this here instead of debugging generated Makefiles
post-install:
	find ${DESTDIR}${PREFIX}/share/locale -name .mo -execdir mv .mo gst-plugins-base-0.10.mo \;

.include "../../mk/bsd.pkg.mk"