[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins0.10-base

File: [cvs.NetBSD.org] / pkgsrc / multimedia / gst-plugins0.10-base / Attic / Makefile (download)

Revision 1.35, Sun Aug 11 13:22:02 2019 UTC (4 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.34: +2 -2 lines

Bump PKGREVISIONs for perl 5.30.0

# $NetBSD: Makefile,v 1.35 2019/08/11 13:22:02 wiz Exp $
#

.include "Makefile.common"
PKGREVISION=		12

#CONFIGURE_ARGS+= --disable-silent-rules

COMMENT+=		Base plugins

# some plugins were moved from bad to base
CONFLICTS+=		gst-plugins0.10-bad<0.10.10

USE_TOOLS+=		perl:run
MAKE_JOBS_SAFE=		no
PKGCONFIG_OVERRIDE+=	pkgconfig/*.pc.in
REPLACE_PERL+=		tools/gst-visualise-m.m

PKG_OPTIONS_VAR=	PKG_OPTIONS.gst-plugins0.10-base
PKG_SUPPORTED_OPTIONS=	introspection
PKG_SUGGESTED_OPTIONS=	introspection
.include "../../mk/bsd.options.mk"

PLIST_VARS+=	introspection

# only useful if gstreamer was built with the "gstcheck" option
TEST_TARGET=		check-torture

# soft dependency only, .pc file not needed
#.include "../../textproc/iso-codes/buildlink3.mk"

.if !empty(PKG_OPTIONS:Mintrospection)
PLIST.introspection=	yes
.include "../../devel/gobject-introspection/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-introspection
.endif

.include "../../mk/bsd.pkg.mk"