[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / gecko-mediaplayer

File: [cvs.NetBSD.org] / pkgsrc / multimedia / gecko-mediaplayer / Attic / Makefile (download)

Revision 1.4, Tue Jul 12 14:11:58 2011 UTC (12 years, 9 months ago) by obache
Branch: MAIN
Changes since 1.3: +2 -2 lines

Update gecko-mediaplayer to 1.0.4.

1.0.4
	Fix problem where file is downloaded before gnome-mplayer is started (locally cached)
	Added Portuguese translation
	Remove some whitespace
	Updated French translation
	Updated Polish translation
	Updated Turkish translation
1.0.4b2
	If http is found in the URL it may not be a stream (this might break some sites)
	Get status messages looking better, requires gnome-mplayer from SVN on same date
	Disable Windows OnDSPlayStateChangeEvt callback
	Emulate WMP status
	Emulate WMP versionInfo
	Add in some more WMP javascript emulation
	Align PlayStateChanges similar to WMP
	Rework how media events are handled
	Fix problems with SetVolume
	Remove a couple of state change callbacks to stop fork bomb
	Call javascript function OnDSPlayStateChange if it is exists
	Add .media.getItemInfo title,url, bitrate to WMP Javascript emulation
	Add .URL to WMP Javascript emulation
	Updated Polish translation
	Add .media.duration to WMP Javascript emulation
	Add .settings.volume to WMP Javascript emulation
1.0.4b1
	When getting a file from Apple, only play the first media link
	Add udp as supported streaming format
	Fix up some issues with apple trailers

# $NetBSD: Makefile,v 1.4 2011/07/12 14:11:58 obache Exp $
#

DISTNAME=	gecko-mediaplayer-1.0.4
CATEGORIES=	multimedia www
MASTER_SITES=	http://gecko-mediaplayer.googlecode.com/files/

MAINTAINER=	obache@NetBSD.org
HOMEPAGE=	http://code.google.com/p/gecko-mediaplayer/
COMMENT=	Multimedia browser plugin for Gecko based browsers
LICENSE=	gnu-gpl-v2

DEPENDS+=	gnome-mplayer-[0-9]*:../../multimedia/gnome-mplayer

PKG_DESTDIR_SUPPORT=	user-destdir

GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_LANGUAGES=		c c++
USE_TOOLS+=		pkg-config msgfmt

GCONF_SCHEMAS+=		gecko-mediaplayer.schemas

CONFIGURE_ARGS+=	--with-gconf
CONFIGURE_ARGS+=	--enable-new-libxul
CONFIGURE_ARGS+=	--with-plugin-dir=${PREFIX}/lib/netscape/plugins
CONFIGURE_ARGS+=	--with-libcurl

.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/nspr/buildlink3.mk"
BUILDLINK_DEPMETHOD.xulrunner=	build
.include "../../devel/xulrunner/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../devel/GConf/schemas.mk"
.include "../../mk/dlopen.buildlink3.mk"
.if empty(BUILDLINK_LDADD.ldl)
BUILDLINK_TRANSFORM+=	rm:-ldl
.endif
.include "../../mk/bsd.pkg.mk"