[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / adobe-flash-player

File: [cvs.NetBSD.org] / pkgsrc / multimedia / adobe-flash-player / Makefile (download)

Revision 1.1, Fri Mar 17 21:56:29 2017 UTC (11 months ago) by tsutsui
Branch: MAIN

Re-import multimedia/adobe-flash-player24 as multimedia/adobe-flash-player
for future major version bump with compatibility.

We had multiple adobe-flash-plugin versions in the past because
newer 11.x versions didn't work on older (4.x) NetBSD systems.
However I guess Adobe will not put aggressive changes that require
newer Linux kernel version (i.e. emul.linux.kern.osrelease on NetBSD)
in future periodical major updates, as per their announcements:
 https://blogs.adobe.com/flashplayer/2016/08/beta-news-flash-player-npapi-for-linux.html
> Because this change is primarily a security initiative, some features
> (like GPU 3D acceleration and premium video DRM) will not be fully
> implemented.

No objection on pkgsrc-users@:
 http://mail-index.netbsd.org/pkgsrc-users/2017/03/14/msg024523.html
Also ok'ed by gdt@ in private mail.

---

NPAPI Adobe Flash player plugin for the Firefox browser.
This package contains a plugin that enables web browsers to render
the Flash format.

The nspluginwrapper option (enabled by default on non Linux platforms)
permits the use of the the Linux x86 and x86_64 flash player in Firefox
browsers on other x86 systems and x86_64 systems.

For NetBSD this package requires NetBSD 6.2 or 7.1 (and later versions)
which include procfs fixes for Linux binaries.

# $NetBSD: Makefile,v 1.1 2017/03/17 21:56:29 tsutsui Exp $

FLASH_VERSION=		24.0.0.221
DISTNAME=		flash_player_npapi_linux.${FLASH_ARCH}
PKGNAME=		adobe-flash-player-${FLASH_VERSION}
DIST_SUBDIR=		${PKGNAME_NOREV}
CATEGORIES=		multimedia www
MASTER_SITES=		http://fpdownload.macromedia.com/get/flashplayer/pdc/${FLASH_VERSION}/

MAINTAINER=		tsutsui@NetBSD.org
HOMEPAGE=		http://www.adobe.com/products/flashplayer.html
COMMENT=		Adobe Flash Player Browser NPAPI plugin
LICENSE=		flash-license

RESTRICTED=		Redistribution not permitted
NO_BIN_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_SRC_ON_FTP=		${RESTRICTED}

# On NetBSD, requires sufficiently new compat_linux and
# procfs_map.c fixes pulled after 6.1 and 7.0.
NOT_FOR_PLATFORM=	NetBSD-[0-5]*-* NetBSD-6.[0-1].*-* NetBSD-7.0.*-*

WRKSRC=			${WRKDIR}
BUILD_DIRS=		# empty

CRYPTO=			yes

EMUL_PLATFORMS=		linux-i386 linux-x86_64
EMUL_MODULES.linux=	gtk2 x11 glx krb5 alsa curl nss nspr
# flashplayer 24 still supports OpenSUSE 11.3, but NetBSD 6.x uses 12.1
# by default so I won't bother to test with 11.3.
EMUL_REQD=		suse>=12.1

.include "../../mk/bsd.prefs.mk"

.if ${EMUL_PLATFORM} == "linux-i386"
FLASH_ARCH=		i386
.elif ${EMUL_PLATFORM} == "linux-x86_64"
FLASH_ARCH=		x86_64
.endif

CONFLICTS=		adobe-flash-plugin-[0-9]*

NS_PLUGINS_DIR=		${PREFIX}/lib/netscape/plugins

.include "options.mk"

do-install:
	${INSTALL_DATA_DIR} ${DESTDIR}${NS_PLUGINS_DIR}
	${INSTALL_DATA} ${WRKSRC}/libflashplayer.so \
		${DESTDIR}${NS_PLUGINS_DIR}

.include "../../mk/bsd.pkg.mk"