The NetBSD Project

CVS log for pkgsrc/multimedia/adobe-flash-player/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / multimedia / adobe-flash-player

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.34 / (download) - annotate - [select for diffs], Tue May 14 15:15:55 2019 UTC (8 days, 2 hours ago) by tsutsui
Branch: MAIN
CVS Tags: HEAD
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

adobe-flash-player: update to 32.0.0.192.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb19-26.html

Adobe Security Bulletin
 Security Bulletin for Adobe Flash Player | APSB19-26

 Summary

  Adobe has released security updates for Adobe Flash Player for
  Windows, macOS, Linux and Chrome OS. These updates address
  a critical vulnerability in Adobe Flash Player. Successful
  exploitation could lead toarbitrary code executionin the context
  of the current user.

Revision 1.33 / (download) - annotate - [select for diffs], Wed Apr 10 14:18:03 2019 UTC (6 weeks ago) by tsutsui
Branch: MAIN
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

adobe-flash-player: update to 32.0.0.171.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb19-19.html

Adobe Security Bulletin
 Updates available for Adobe Flash Player | APSB19-19

 Summary

  Adobe has released security updates for Adobe Flash Player for
  Windows, macOS, Linux and Chrome OS. These updates address a
  critical and animportantvulnerability in Adobe Flash Player.
  Successful exploitation could lead toarbitrary code execution
  in the context of the current user.

Revision 1.32 / (download) - annotate - [select for diffs], Thu Mar 14 15:31:47 2019 UTC (2 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

adobe-flash-player: 32.0.0.156.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb19-12.html

Adobe Security Bulletin
 Updates available for Flash Player | APSB19-12

  Summary

  Adobe has released updates for Adobe Flash Player for Windows, macOS,
  Linux and Chrome OS. These updates address feature and performance
  bugs, and do not include security fixes.

Revision 1.31 / (download) - annotate - [select for diffs], Tue Feb 12 14:42:55 2019 UTC (3 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

adobe-flash-player: update to 32.0.0.142.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb19-06.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB19-06

  Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address one important
  vulnerability in Adobe Flash Player. Successful exploitation could
  lead toinformation disclosurein the context of the current user.

Revision 1.30 / (download) - annotate - [select for diffs], Sat Jan 12 13:32:59 2019 UTC (4 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

adobe-flash-player: update to 32.0.0.114.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb19-01.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB19-01

  Summary

  Adobe has released updates for Adobe Flash Player for Windows, macOS,
  Linux and Chrome OS. These updates address feature and performance bugs,
  and do not include security fixes.

Revision 1.29 / (download) - annotate - [select for diffs], Thu Dec 6 15:38:32 2018 UTC (5 months, 2 weeks ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

adobe-flash-player: update to 32.0.0.101.

Upstream announcemnet:

https://helpx.adobe.com/security/products/flash-player/apsb18-42.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-42

  Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address one critical
  vulnerability in Adobe Flash Player and one important vulnerability in
  Adobe Flash Player installer. Successful exploitation could lead to
  Arbitrary Code Execution and privilege escalation in the context of
  the current user respectively.

  Adobe is aware of reports that an exploit for CVE-2018-15982 exists in
  the wild.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Nov 22 16:09:46 2018 UTC (5 months, 4 weeks ago) by tsutsui
Branch: MAIN
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

adobe-flash-player: update to 31.0.0.153.

Upstream announcemnet:

https://helpx.adobe.com/security/products/flash-player/apsb18-44.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-44

  Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address a critical vulnerability
  in Adobe Flash Player 31.0.0.148 and earlier versions.  Successful
  exploitation could lead to arbitrary code execution in the context of
  the current user.

  Technical details about this vulnerability are publicly available.

Revision 1.27 / (download) - annotate - [select for diffs], Tue Nov 13 15:45:35 2018 UTC (6 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

adobe-flash-player: update to 31.0.0.148.

Upstream announcemnet:

https://helpx.adobe.com/security/products/flash-player/apsb18-39.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-39

  Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address an important
  vulnerability in Adobe Flash Player 31.0.0.122 and earlier versions.
  Successful exploitation could lead to information disclosure.

Revision 1.26 / (download) - annotate - [select for diffs], Wed Oct 10 15:17:05 2018 UTC (7 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

adobe-flash-player: update to 31.0.0.122.

Upstream announcemnet:

https://helpx.adobe.com/security/products/flash-player/apsb18-35.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-35

  Summary

  Adobe has released updates for Adobe Flash Player for Windows, macOS,
  Linux and Chrome OS.  These updates address feature and performance
  bugs, and do not include security fixes.

Revision 1.25 / (download) - annotate - [select for diffs], Tue Sep 11 15:45:43 2018 UTC (8 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

adobe-flash-player: update to 31.0.0.108.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb18-31.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-31

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address an important
  vulnerability in Adobe Flash Player 30.0.0.154 and earlier versions.
  Successful exploitation could lead to information disclosure.

Revision 1.24 / (download) - annotate - [select for diffs], Wed Aug 15 03:32:29 2018 UTC (9 months ago) by tsutsui
Branch: MAIN
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

adobe-flash-player: update to 30.0.0.154.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb18-25.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-25

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address important
  vulnerabilities in Adobe Flash Player 30.0.0.134 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in the
  context of the current user.

Revision 1.22.2.1 / (download) - annotate - [select for diffs], Sat Jul 14 07:49:05 2018 UTC (10 months, 1 week ago) by spz
Branch: pkgsrc-2018Q2
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored) next main 1.23 (colored)

Pullup ticket #5783 - requested by bsiegert
multimedia/adobe-flash-player: security update

Revisions pulled up:
- multimedia/adobe-flash-player/Makefile                        1.23
- multimedia/adobe-flash-player/distinfo                        1.21

-------------------------------------------------------------------
   Module Name:    pkgsrc
   Committed By:   tsutsui
   Date:           Wed Jul 11 11:57:07 UTC 2018

   Modified Files:
           pkgsrc/multimedia/adobe-flash-player: Makefile distinfo

   Log Message:
   adobe-flash-player: update to 30.0.0.134.

   Upstream announcement:

   https://helpx.adobe.com/security/products/flash-player/apsb18-24.html

   Adobe Security Bulletin
    Security updates available for Flash Player | APSB18-24

    Summary

     Adobe has released security updates for Adobe Flash Player for Windows,
     macOS, Linux and Chrome OS. These updates address critical
     vulnerabilities in Adobe Flash Player 30.0.0.113 and earlier versions.
     Successful exploitation could lead to arbitrary code execution in the
     context of the current user.


   To generate a diff of this commit:
   cvs rdiff -u -r1.22 -r1.23 pkgsrc/multimedia/adobe-flash-player/Makefile
   cvs rdiff -u -r1.20 -r1.21 pkgsrc/multimedia/adobe-flash-player/distinfo

Revision 1.23 / (download) - annotate - [select for diffs], Wed Jul 11 11:57:07 2018 UTC (10 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

adobe-flash-player: update to 30.0.0.134.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb18-24.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-24

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address critical
  vulnerabilities in Adobe Flash Player 30.0.0.113 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in the
  context of the current user.

Revision 1.22 / (download) - annotate - [select for diffs], Sat Jun 9 07:23:58 2018 UTC (11 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base
Branch point for: pkgsrc-2018Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

adobe-flash-player: update to 30.0.0.113.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb18-19.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-19

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  macOS, Linux and Chrome OS. These updates address critical
  vulnerabilities in Adobe Flash Player 29.0.0.171 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in the
  context of the current user.

  Adobe is aware of a report that an exploit for CVE-2018-5002 exists
  in the wild, and is being used in limited, targeted attacks against
  Windows users. These attacks leverage Office documents with embedded
  malicious Flash Player content distributed via email.

Revision 1.21 / (download) - annotate - [select for diffs], Thu May 10 14:03:01 2018 UTC (12 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

adobe-flash-player: update to 29.0.0.171.

Upstream announcement:

https://helpx.adobe.com/security/products/flash-player/apsb18-16.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-16

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  Macintosh, Linux and Chrome OS. These updates address critical
  vulnerabilities in Adobe Flash Player 29.0.0.140 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in the
  context of the current user.

Revision 1.20 / (download) - annotate - [select for diffs], Fri Apr 13 10:31:22 2018 UTC (13 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

adobe-flash-player: update to 29.0.0.140.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb18-08.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-08

 Summary

  Adobe has released security updates for Adobe Flash Player for Windows,
  Macintosh, Linux and Chrome OS. These updates address critical
  vulnerabilities in Adobe Flash Player 29.0.0.113 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in
  the context of the current user.

Revision 1.19 / (download) - annotate - [select for diffs], Wed Mar 14 16:33:33 2018 UTC (14 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

adobe-flash-player: update to 29.0.0.113.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb18-05.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-05

 Summary
  Adobe has released security updates for Adobe Flash Player for Windows,
  Macintosh, Linux and Chrome OS. These updates address critical
  vulnerabilities in Adobe Flash Player 28.0.0.161 and earlier versions.
  Successful exploitation could lead to arbitrary code execution in the
  context of the current user.

Revision 1.18 / (download) - annotate - [select for diffs], Sun Feb 11 15:36:08 2018 UTC (15 months, 1 week ago) by wiz
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

adobe-flash-player: follow redirect

Revision 1.17 / (download) - annotate - [select for diffs], Thu Feb 8 14:48:28 2018 UTC (15 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

adobe-flash-player: update to 28.0.0.161.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb18-03.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-03

 Summary
  Adobe has released security updates for Adobe Flash Player for Windows,
  Macintosh, Linux and Chrome OS. These updates address critical
  vulnerabilities that could lead to remote code execution in Adobe Flash
  Player 28.0.0.137 and earlier versions.  Successful exploitation could
  potentially allow an attacker to take control of the affected system.

  Adobe is aware of a report that an exploit for CVE-2018-4878 exists in
  the wild, and is being used in limited, targeted attacks against Windows
  users.  These attacks leverage Office documents with embedded malicious
  Flash content distributed via email.

Revision 1.16 / (download) - annotate - [select for diffs], Fri Jan 12 14:48:30 2018 UTC (16 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

adobe-flash-player: update to 28.0.0.137.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb18-01.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB18-01

 Summary
  Adobe has released security updates for Adobe Flash Player for Windows,
  Macintosh, Linux and Chrome OS. These updates address an important
  out-of-bounds read vulnerability that could lead to information exposure.

Revision 1.15 / (download) - annotate - [select for diffs], Tue Jan 2 05:37:22 2018 UTC (16 months, 2 weeks ago) by maya
Branch: MAIN
Changes since 1.14: +1 -3 lines
Diff to previous 1.14 (colored)

Remove traces of crypto restrictions from packages.

ok for idea riastradh.

Revision 1.14 / (download) - annotate - [select for diffs], Wed Dec 13 16:19:36 2017 UTC (17 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

adobe-flash-player: update to 28.0.0.126.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb17-42.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB17-42

 Summary
  Adobe has released a security update for Adobe Flash Player for
  Windows, Macintosh, Linux and Chrome OS. This update addresses
  a regression that could lead to the unintended reset of the
  global settings preference file.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Nov 16 15:10:44 2017 UTC (18 months ago) by tsutsui
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

adobe-flash-player: update to 27.0.0.187.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb17-33.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB17-33

Revision 1.12 / (download) - annotate - [select for diffs], Thu Oct 26 15:09:21 2017 UTC (18 months, 3 weeks ago) by tsutsui
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

adobe-flash-player: update to 27.0.0.183.

Upstream announcement:

 https://helpx.adobe.com/flash-player/release-note/fp_27_air_27_release_notes.html

October 25, 2017

In today's release, we've updated Flash Player with an importantfunctional
fix impacting Flex content and recommend those users impacted update.

Revision 1.9.4.1 / (download) - annotate - [select for diffs], Wed Oct 18 18:15:22 2017 UTC (19 months ago) by spz
Branch: pkgsrc-2017Q3
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored) next main 1.10 (colored)

Pullup ticket #5582 - requested by bsiegert
multimedia/adobe-flash-player: security update

Revisions pulled up:
- multimedia/adobe-flash-player/Makefile                        1.11
- multimedia/adobe-flash-player/distinfo                        1.11

-------------------------------------------------------------------
   Module Name:	pkgsrc
   Committed By:	tsutsui
   Date:		Tue Oct 17 13:52:29 UTC 2017

   Modified Files:
    	pkgsrc/multimedia/adobe-flash-player: Makefile distinfo

   Log Message:
   adobe-flash-player: update to 27.0.0.170.

   Upstream announcement:

     https://helpx.adobe.com/security/products/flash-player/apsb17-32.html

   Adobe Security Bulletin

   Summary

   Adobe has released a security update for Adobe Flash Player for Windows,
   Macintosh, Linux and Chrome OS. This update addresses a critical type
   confusion vulnerability that could lead to code execution.

   Adobe is aware of a report that an exploit for CVE-2017-11292 exists
   in the wild, and is being used in limited, targeted attacks against
   users running Windows.


   To generate a diff of this commit:
   cvs rdiff -u -r1.10 -r1.11 pkgsrc/multimedia/adobe-flash-player/Makefile \
        pkgsrc/multimedia/adobe-flash-player/distinfo

Revision 1.11 / (download) - annotate - [select for diffs], Tue Oct 17 13:52:29 2017 UTC (19 months ago) by tsutsui
Branch: MAIN
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

adobe-flash-player: update to 27.0.0.170.

Upstream announcement:

 https://helpx.adobe.com/security/products/flash-player/apsb17-32.html

Adobe Security Bulletin

Summary

Adobe has released a security update for Adobe Flash Player for Windows,
Macintosh, Linux and Chrome OS. This update addresses a critical type
confusion vulnerability that could lead to code execution.

Adobe is aware of a report that an exploit for CVE-2017-11292 exists
in the wild, and is being used in limited, targeted attacks against
users running Windows.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Oct 11 14:26:51 2017 UTC (19 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

adobe-flash-player: update to 27.0.0.159.

Note this version seems to include a fix for crash of nspluginwrapper
(npviewer.bin) on NetBSD/i386 7.1 with pulseaudio (i.e. no libflashsupport)
settings.

Upstream changes:

 https://helpx.adobe.com/security/products/flash-player/apsb17-31.html

Adobe Security Bulletin

Summary

Adobe has released an update for Adobe Flash Player for Windows,
Macintosh, Linux and Chrome OS. This monthly update addresses
functionality bugs.

Revision 1.9 / (download) - annotate - [select for diffs], Sat Sep 16 15:23:27 2017 UTC (20 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-
Branch point for: pkgsrc-2017Q3
Changes since 1.8: +1 -1 lines
Diff to previous 1.8 (colored)

adobe-flash-player: revert to 26.0.0.151.

It looks adobe flash player 27 now requires udev support to play sound,
but at least NetBSD/i386 7.1 with nspluginwrapper can't handle it.
XXX: old vulnerable binaries on upstream will be removed soon

Revision 1.8 / (download) - annotate - [select for diffs], Wed Sep 13 16:27:44 2017 UTC (20 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Update adobe-flash-player to 27.0.0.130.

Upstream announcemnt:

 https://helpx.adobe.com/security/products/flash-player/apsb17-28.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB17-28

Revision 1.7 / (download) - annotate - [select for diffs], Sat Aug 12 14:14:21 2017 UTC (21 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update adobe-flash-player to 26.0.0.151.

Upstream announcemnt:

 https://helpx.adobe.com/security/products/flash-player/apsb17-23.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB17-23

Revision 1.6 / (download) - annotate - [select for diffs], Sat Jul 15 09:31:00 2017 UTC (22 months, 1 week ago) by tsutsui
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Update adobe-flash-player to 26.0.0.137.

Upstream announcemnt:

 https://helpx.adobe.com/security/products/flash-player/apsb17-21.html

Adobe Security Bulletin
 Security updates available for Flash Player | APSB17-21

Revision 1.2.2.3 / (download) - annotate - [select for diffs], Wed Jun 21 18:31:52 2017 UTC (23 months ago) by bsiegert
Branch: pkgsrc-2017Q1
Changes since 1.2.2.2: +3 -3 lines
Diff to previous 1.2.2.2 (colored) to branchpoint 1.2 (colored) next main 1.3 (colored)

Pullup ticket #5484 - requested by sevan
multimedia/adobe-flash-player: security fix

Revisions pulled up:
- multimedia/adobe-flash-player/Makefile                        1.5
- multimedia/adobe-flash-player/distinfo                        1.5

---
   Module Name:    pkgsrc
   Committed By:   tsutsui
   Date:           Fri Jun 16 16:53:55 UTC 2017

   Modified Files:
           pkgsrc/multimedia/adobe-flash-player: Makefile distinfo

   Log Message:
   Update adobe-flash-player to 26.0.0.131.

   Upstream announcemnt:

   26.0.0.131:

    https://helpx.adobe.com/flash-player/release-note/fp_26_air_26_release_notes.html

   June 16, 2017

   Flash Player

   * Buttons can't be clicked in some AS2 content (FP-4198473)

   ---

   26.0.0.126:

    https://helpx.adobe.com/security/products/flash-player/apsb17-17.html

   Adobe Security Bulletin

   Security updates available for Flash Player | APSB17-17

   Summary

   Adobe has released security updates for Adobe Flash Player for Windows,
    Macintosh, Linux and Chrome OS. These updates address critical
   vulnerabilities that could potentially allow an attacker to take
   control of the affected system.

   (CVE numbers are now in HTML table as details so not copy-n-paste'd to
    commit log)

Revision 1.5 / (download) - annotate - [select for diffs], Fri Jun 16 16:53:55 2017 UTC (23 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.4: +3 -3 lines
Diff to previous 1.4 (colored)

Update adobe-flash-player to 26.0.0.131.

Upstream announcemnt:

26.0.0.131:

 https://helpx.adobe.com/flash-player/release-note/fp_26_air_26_release_notes.html

June 16, 2017

Flash Player

* Buttons can't be clicked in some AS2 content (FP-4198473)

---

26.0.0.126:

 https://helpx.adobe.com/security/products/flash-player/apsb17-17.html

Adobe Security Bulletin

Security updates available for Flash Player | APSB17-17

Summary

Adobe has released security updates for Adobe Flash Player for Windows,
 Macintosh, Linux and Chrome OS. These updates address critical
vulnerabilities that could potentially allow an attacker to take
control of the affected system.

(CVE numbers are now in HTML table as details so not copy-n-paste'd to
 commit log)

Revision 1.2.2.2 / (download) - annotate - [select for diffs], Sat Jun 3 17:48:04 2017 UTC (23 months, 2 weeks ago) by bsiegert
Branch: pkgsrc-2017Q1
Changes since 1.2.2.1: +2 -2 lines
Diff to previous 1.2.2.1 (colored) to branchpoint 1.2 (colored)

Pullup ticket #5436 - requested by sevan
multimedia/adobe-flash-player: security fix

Revisions pulled up:
- multimedia/adobe-flash-player/Makefile                        1.4
- multimedia/adobe-flash-player/distinfo                        1.4

---
   Module Name:    pkgsrc
   Committed By:   tsutsui
   Date:           Sat May 13 04:11:46 UTC 2017

   Modified Files:
           pkgsrc/multimedia/adobe-flash-player: Makefile distinfo

   Log Message:
   Update adobe-flash-player to 25.0.0.171.

   Upstream announcements:

    https://helpx.adobe.com/security/products/flash-player/apsb17-15.html

   Security updates available for Adobe Flash Player

   Release date: May 9, 2017

   Vulnerability identifier: APSB17-15

   CVE number: CVE-2017-3068, CVE-2017-3069, CVE-2017-3070, CVE-2017-3071,
    CVE-2017-3072, CVE-2017-3073, CVE-2017-3074

   Platform: Windows, Macintosh, Linux and Chrome OS

Revision 1.4 / (download) - annotate - [select for diffs], Sat May 13 04:11:46 2017 UTC (2 years ago) by tsutsui
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Update adobe-flash-player to 25.0.0.171.

Upstream announcements:

 https://helpx.adobe.com/security/products/flash-player/apsb17-15.html

Security updates available for Adobe Flash Player

Release date: May 9, 2017

Vulnerability identifier: APSB17-15

CVE number: CVE-2017-3068, CVE-2017-3069, CVE-2017-3070, CVE-2017-3071,
 CVE-2017-3072, CVE-2017-3073, CVE-2017-3074

Platform: Windows, Macintosh, Linux and Chrome OS

Revision 1.2.2.1 / (download) - annotate - [select for diffs], Thu Apr 13 11:20:21 2017 UTC (2 years, 1 month ago) by bsiegert
Branch: pkgsrc-2017Q1
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Pullup ticket #5269 - requested by sevan
multimedia/adobe-flash-player: security fix

Revisions pulled up:
- multimedia/adobe-flash-player/Makefile                        1.3
- multimedia/adobe-flash-player/distinfo                        1.3

---
   Module Name:    pkgsrc
   Committed By:   tsutsui
   Date:           Wed Apr 12 15:31:13 UTC 2017

   Modified Files:
           pkgsrc/multimedia/adobe-flash-player: Makefile distinfo

   Log Message:
   Update adobe-flash-player to 25.0.0.148.

   Upstream announcements:

    https://helpx.adobe.com/security/products/flash-player/apsb17-10.html

   Adobe Security Bulletin

   Security updates available for Adobe Flash Player

   Release date: April 11, 2017

   Vulnerability identifier: APSB17-10

   CVE number: CVE-2017-3058, CVE-2017-3059, CVE-2017-3060, CVE-2017-3061,
    CVE-2017-3062, CVE-2017-3063, CVE-2017-3064

   Platform: Windows, Macintosh, Linux and Chrome OS

Revision 1.3 / (download) - annotate - [select for diffs], Wed Apr 12 15:31:13 2017 UTC (2 years, 1 month ago) by tsutsui
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Update adobe-flash-player to 25.0.0.148.

Upstream announcements:

 https://helpx.adobe.com/security/products/flash-player/apsb17-10.html

Adobe Security Bulletin

Security updates available for Adobe Flash Player

Release date: April 11, 2017

Vulnerability identifier: APSB17-10

CVE number: CVE-2017-3058, CVE-2017-3059, CVE-2017-3060, CVE-2017-3061,
 CVE-2017-3062, CVE-2017-3063, CVE-2017-3064

Platform: Windows, Macintosh, Linux and Chrome OS

Revision 1.2 / (download) - annotate - [select for diffs], Fri Mar 17 22:11:12 2017 UTC (2 years, 2 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base
Branch point for: pkgsrc-2017Q1
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Update adobe-flash-player to 25.0.0.127.

Upstream announcements:

 https://helpx.adobe.com/security/products/flash-player/apsb17-07.html

Security updates available for Adobe Flash Player

Release date: March 14, 2017

Vulnerability identifier: APSB17-07

CVE number: CVE-2017-2997, CVE-2017-2998, CVE-2017-2999, CVE-2017-3000,
 CVE-2017-3001, CVE-2017-3002, CVE-2017-3003

Platform: Windows, Macintosh, Linux and Chrome OS

Revision 1.1 / (download) - annotate - [select for diffs], Fri Mar 17 21:56:29 2017 UTC (2 years, 2 months ago) by tsutsui
Branch: MAIN

Re-import multimedia/adobe-flash-player24 as multimedia/adobe-flash-player
for future major version bump with compatibility.

We had multiple adobe-flash-plugin versions in the past because
newer 11.x versions didn't work on older (4.x) NetBSD systems.
However I guess Adobe will not put aggressive changes that require
newer Linux kernel version (i.e. emul.linux.kern.osrelease on NetBSD)
in future periodical major updates, as per their announcements:
 https://blogs.adobe.com/flashplayer/2016/08/beta-news-flash-player-npapi-for-linux.html
> Because this change is primarily a security initiative, some features
> (like GPU 3D acceleration and premium video DRM) will not be fully
> implemented.

No objection on pkgsrc-users@:
 http://mail-index.netbsd.org/pkgsrc-users/2017/03/14/msg024523.html
Also ok'ed by gdt@ in private mail.

---

NPAPI Adobe Flash player plugin for the Firefox browser.
This package contains a plugin that enables web browsers to render
the Flash format.

The nspluginwrapper option (enabled by default on non Linux platforms)
permits the use of the the Linux x86 and x86_64 flash player in Firefox
browsers on other x86 systems and x86_64 systems.

For NetBSD this package requires NetBSD 6.2 or 7.1 (and later versions)
which include procfs fixes for Linux binaries.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>