The NetBSD Project

CVS log for pkgsrc/mk/bsd.pkg.use.mk

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / mk

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.67 / (download) - annotate - [select for diffs], Tue Jan 2 05:49:44 2018 UTC (14 months, 2 weeks ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, HEAD
Changes since 1.66: +1 -2 lines
Diff to previous 1.66 (colored)

Remove traces of crypto restrictions.

ok for idea riastradh

Revision 1.66 / (download) - annotate - [select for diffs], Sun Mar 5 10:38:37 2017 UTC (2 years ago) by kamil
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-
Changes since 1.65: +2 -2 lines
Diff to previous 1.65 (colored)

Fix path to cross-libtool-base in TOOL_DEPENDS+= for crossbuilding

Revision 1.65 / (download) - annotate - [select for diffs], Wed Jan 18 05:33:39 2017 UTC (2 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.64: +2 -2 lines
Diff to previous 1.64 (colored)

Coorect version of libtool to current one.

Revision 1.64 / (download) - annotate - [select for diffs], Tue Jan 17 22:57:39 2017 UTC (2 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.63: +2 -2 lines
Diff to previous 1.63 (colored)

Bump LIBTOOL_REQD, newer version needed for cwrappers.

PR 51826.

Revision 1.63 / (download) - annotate - [select for diffs], Thu Nov 10 20:58:46 2016 UTC (2 years, 4 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.62: +4 -1 lines
Diff to previous 1.62 (colored)

Handle optional ctfmerge/ctfconvert presence on NetBSD by explicitly
passing down NOCTF when they don't exist.

Revision 1.62 / (download) - annotate - [select for diffs], Sun Jun 19 20:03:09 2016 UTC (2 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.61: +1 -5 lines
Diff to previous 1.61 (colored)

Get rid of INSTALLATION_PREFIX.

Revision 1.61 / (download) - annotate - [select for diffs], Sun Jun 19 18:01:58 2016 UTC (2 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.60: +1 -3 lines
Diff to previous 1.60 (colored)

Remove support for USE_CROSSBASE.

Revision 1.60 / (download) - annotate - [select for diffs], Sat Jul 4 16:18:38 2015 UTC (3 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.59: +1 -8 lines
Diff to previous 1.59 (colored)

Remove USE_X11BASE and X11PREFIX.

Revision 1.59 / (download) - annotate - [select for diffs], Mon May 4 19:23:19 2015 UTC (3 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.58: +4 -8 lines
Diff to previous 1.58 (colored)

Drop _LIBTOOL and _SHLIBTOOL and make LIBTOOL and SHLIBTOOL point to the
wrapped version by full path. This fixes some cases where the wrappers
have been bypassed. lang/lua52 triggered the investigation as it failed
to link against libreadline, which should have been translated to
libedit. Tested by jperkin and myself with full bulk builds.

Revision 1.58 / (download) - annotate - [select for diffs], Tue Dec 30 15:13:19 2014 UTC (4 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.57: +5 -13 lines
Diff to previous 1.57 (colored)

Remove pkg_views support, second part: infrastructure.

Revision 1.57 / (download) - annotate - [select for diffs], Wed Oct 1 19:14:21 2014 UTC (4 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.56: +2 -5 lines
Diff to previous 1.56 (colored)

Remove mk glue for devel/nbitools.

Revision 1.56 / (download) - annotate - [select for diffs], Mon Sep 9 16:35:40 2013 UTC (5 years, 6 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.55: +8 -2 lines
Diff to previous 1.55 (colored)

Only add HAVE_LLVM / HAVE_GCC if they are already set.

Revision 1.55 / (download) - annotate - [select for diffs], Sun Sep 8 16:32:17 2013 UTC (5 years, 6 months ago) by joerg
Branch: MAIN
Changes since 1.54: +2 -2 lines
Diff to previous 1.54 (colored)

Pass down HAVE_LLVM and HAVE_GCC.

Revision 1.54 / (download) - annotate - [select for diffs], Fri May 10 09:07:37 2013 UTC (5 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.53: +3 -2 lines
Diff to previous 1.53 (colored)

check defined before using USE_LANGUAGES as condition.

Revision 1.53 / (download) - annotate - [select for diffs], Thu May 9 23:37:25 2013 UTC (5 years, 10 months ago) by riastradh
Branch: MAIN
Changes since 1.52: +15 -2 lines
Diff to previous 1.52 (colored)

Split BUILD_DEPENDS into TOOL_DEPENDS and BUILD_DEPENDS in mk/.

Build depends are target packages that are needed at build-time for,
e.g., static libraries to link against, header files to include, &c.
Tool depends are native packages that are needed at build-time for,
e.g., compilers/linkers/&c. to run.

ok agc

Revision 1.52 / (download) - annotate - [select for diffs], Thu May 9 13:53:48 2013 UTC (5 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.51: +10 -1 lines
Diff to previous 1.51 (colored)

Split Fortran support from devel/libtool-base into a separate package
devel/libtool-fortran. If USE_LIBTOOL is present and Fortran is in
USE_LANGUAGES, include the new package.

Revision 1.51 / (download) - annotate - [select for diffs], Mon Mar 19 12:34:14 2012 UTC (7 years ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.50: +1 -12 lines
Diff to previous 1.50 (colored)

Drop imake-check logic from X11 components' builtin.mk.
Always use xorg-cf-files and imake from pkgsrc, replacing xpkgwedge.
Always install man pages, not cat pages when using imake.
Unify the various imake PLIST variables in preparation for dropping.
Adjust xbattbar for the new expectations.

Revision 1.50 / (download) - annotate - [select for diffs], Sun Dec 20 12:32:55 2009 UTC (9 years, 3 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.49: +2 -2 lines
Diff to previous 1.49 (colored)

Fix libtool under OS X: require a fixed version of f2c, and thus bump
PKGREVISION of libtool to 3 and require it as a dependency.

Revision 1.49 / (download) - annotate - [select for diffs], Wed Dec 16 19:48:09 2009 UTC (9 years, 3 months ago) by joerg
Branch: MAIN
Changes since 1.48: +2 -2 lines
Diff to previous 1.48 (colored)

Force libtool 2.2 on all platforms.

Revision 1.48 / (download) - annotate - [select for diffs], Wed Jul 22 09:05:24 2009 UTC (9 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.47: +1 -8 lines
Diff to previous 1.47 (colored)

Remove USE_DIRS infrastructure support and support packages.

See http://mail-index.netbsd.org/pkgsrc-changes/2009/07/22/msg026834.html.

Revision 1.47 / (download) - annotate - [select for diffs], Fri May 16 20:00:09 2008 UTC (10 years, 10 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

If we have USE_BSD_MAKEFILE, pass down INSTALL=${TOOLS_INSTALL:Q} in the
environment.
Otherwise BSD style packages will use the install(1) which
bootstrap-mk-files' sys.mk picked, rather than the one from
TOOLS_PLATFORM.install (which may be specified by the user in mk.conf).

Revision 1.46 / (download) - annotate - [select for diffs], Thu Feb 7 12:26:55 2008 UTC (11 years, 1 month ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1
Changes since 1.45: +1 -2 lines
Diff to previous 1.45 (colored)

Get rid of USE_TOOLS+=nroff in the USE_BSD_MAKEFILE case.
Just because a package has BSD style Makefile doesn't mean it has manpages.
A sweep of packages with USE_BSD_MAKEFILE=yes is forthcoming;
USE_TOOLS+=groff nroff will be added where appropriate.

Revision 1.45 / (download) - annotate - [select for diffs], Fri Nov 30 08:27:51 2007 UTC (11 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.44: +9 -1 lines
Diff to previous 1.44 (colored)

Documented USE_IMAKE.

Revision 1.44 / (download) - annotate - [select for diffs], Wed Oct 17 10:43:37 2007 UTC (11 years, 5 months ago) by rillig
Branch: MAIN
Changes since 1.43: +3 -3 lines
Diff to previous 1.43 (colored)

Made the .include lines simpler.

Revision 1.43 / (download) - annotate - [select for diffs], Mon Jul 2 14:54:09 2007 UTC (11 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.42: +3 -6 lines
Diff to previous 1.42 (colored)

Remove USE_MTREE support. Keep one copy (the NetBSD version) for
the purpose of print-PLIST in plist/common-dirs.mtree.

Discussed with wiz@, no objections on tech-pkg@.

Revision 1.42 / (download) - annotate - [select for diffs], Fri Mar 2 09:08:34 2007 UTC (12 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, jlam-pkgviews-base, jlam-pkgviews
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

Make MTREE_FILE and MTREE_ARGS internal by prefixing them with '_'.
They are not supposed to be set by the user.

Revision 1.41 / (download) - annotate - [select for diffs], Sat Feb 10 08:59:07 2007 UTC (12 years, 1 month ago) by rillig
Branch: MAIN
Changes since 1.40: +2 -2 lines
Diff to previous 1.40 (colored)

Replaced the deprecated PKG_SKIP_REASON with PKG_FAIL_REASON.

Revision 1.40 / (download) - annotate - [select for diffs], Mon Jan 22 20:47:06 2007 UTC (12 years, 1 month ago) by rillig
Branch: MAIN
Changes since 1.39: +1 -2 lines
Diff to previous 1.39 (colored)

Reverted the change between 1.37 and 1.38.

MANPATH cannot be overridden so easily to make it right for imake
Packages. Noticed by Dan.

Revision 1.39 / (download) - annotate - [select for diffs], Sun Jan 7 13:38:52 2007 UTC (12 years, 2 months ago) by rillig
Branch: MAIN
Changes since 1.38: +13 -4 lines
Diff to previous 1.38 (colored)

Added the variable USE_BSD_MAKEFILE.

Revision 1.38 / (download) - annotate - [select for diffs], Sat Jan 6 16:47:54 2007 UTC (12 years, 2 months ago) by rillig
Branch: MAIN
Changes since 1.37: +2 -1 lines
Diff to previous 1.37 (colored)

Fixed PKGMANDIR for all packages using Imake.

Revision 1.37 / (download) - annotate - [select for diffs], Wed Dec 20 01:04:46 2006 UTC (12 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.36: +4 -2 lines
Diff to previous 1.36 (colored)

For modular Xorg disable xpkgwedge (will be made a hard error later).
Don't add ${X11BASE}/bin to PATH, don't include mk/x11.buildlink3.mk
when USE_X11BASE is set and don't use BUILDLINK_X11_DIR and related
magic.

OKed by wiz@

Revision 1.36 / (download) - annotate - [select for diffs], Fri Jul 7 14:29:41 2006 UTC (12 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.35: +1 -2 lines
Diff to previous 1.35 (colored)

No need to define LIBTOOL_OVERRIDE explicitly since libtool-override.mk
will search for libtool scripts up to ${OVERRIDE_DIRDEPTH} below
${WRKSRC} already.

Revision 1.35 / (download) - annotate - [select for diffs], Wed Jul 5 04:32:10 2006 UTC (12 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.34: +6 -2 lines
Diff to previous 1.34 (colored)

Teach the tools framework about the following new tools:

	itools, intltool, diff3, sdiff, msgmerge

* Adding USE_TOOLS+=itools to a package Makefile will cause the
  tool-directory versions of imake, makedepend, mkdirhier and xmkmf
  to point to the ones from the devel/nbitools package.

  This change will remove the need for nbitools/buildlink3.mk, which
  currently does a bit of hackery to force the "right" imake tools to
  be used by packages that need it.

* Adding USE_TOOLS+=intltool to a package Makefile will cause the
  local versions of intltool-* inside ${WRKSRC} to be replaced by
  copies from the textproc/intltool package.  If "intltool" is not
  specified as a tool, then we create "broken" intltool-* tools in
  the tools directory to help highlight hidden dependencies on the
  intltool package.

  In addition, modify the tools framework so that if "perl" is not
  specified as a tool, then we create a "broken" perl tool in the
  tools directory for the same reason as for "intltool".

  These two changes together will remove the need for
  intltools/buildlink3.mk and should also catch all cases where the
  sources' intltools may have been silently used because perl was
  found on the system.

* Adding USE_TOOLS+=diff3, USE_TOOLS+=sdiff, or USE_TOOLS+=msgmerge
  to a package Makefile will cause the corresponding tool to be pulled
  into the tools directory.

  These are convenience tools to help simplify dependencies for some
  packages.

Revision 1.1.2.11, Wed Jun 7 15:25:38 2006 UTC (12 years, 9 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.10: +1 -1 lines
FILE REMOVED

EOL the tv-derecurse branch; it has become too outdated.  The last live
revision can be fetched at the tv-derecurse-eol tag.

Revision 1.34 / (download) - annotate - [select for diffs], Sat Jun 3 23:11:42 2006 UTC (12 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.33: +1 -4 lines
Diff to previous 1.33 (colored)

First pass at implementing support for package system flavors other
than pkgsrc's current one.  This is an important lead-up to any project
that redesigns the pkg_* tools in that it doesn't tie us to past design
(mis)choices.  This commit mostly deals with rearranging code, although
there was a considerable amount of rewriting done in cases where I
thought the code was somewhat messy and was difficult to understand.

The design I chose for supporting multiple package system flavors is
that the various depends, install, package, etc.  modules would define
default targets and variables that may be overridden in files from
pkgsrc/mk/flavor/${PKG_FLAVOR}.  The default targets would do the
sensible thing of doing nothing, and pkgsrc infrastructure would rely
on the appropriate things to be defined in pkgsrc/mk/flavor to do the
real work.  The pkgsrc/mk/flavor directory contains subdirectories
corresponding to each package system flavor that we support.  Currently,
I only have "pkg" which represents the current pkgsrc-native package
flavor.  I've separated out most of the code where we make assumptions
about the package system flavor, mostly either because we directly
use the pkg_* tools, or we make assumptions about the package meta-data
directory, or we directly manipulate the package meta-data files, and
placed it into pkgsrc/mk/flavor/pkg.

There are several new modules that have been refactored out of bsd.pkg.mk
as part of these changes: check, depends, install, package, and update.
Each of these modules has been slimmed down by rewriting them to avoid
some recursive make calls.  I've also religiously documented which
targets are "public" and which are "private" so that users won't rely
on reaching into pkgsrc innards to call a private target.

The "depends" module is a complete overhaul of the way that we handle
dependencies.  There is now a separate "depends" phase that occurs
before the "extract" phase where dependencies are installed.  This
differs from the old way where dependencies were installed just before
extraction occurred.  The reduce-depends.mk file is now replaced by
a script that is invoked only once during the depends phase and is
used to generate a cookie file that holds the full set of reduced
dependencies.  It is now possible to type "make depends" in a package
directory and all missing dependencies will be installed.

Future work on this project include:

    * Resolve the workflow design in anticipation of future work on
      staged installations where "package" conceptually happens before
      "install".

    * Rewrite the buildlink3 framework to not assume the use of the
      pkgsrc pkg_* tools.

    * Rewrite the pkginstall framework to provide a standard pkg_*
      tool to perform the actions, and allowing a purely declarative
      file per package to describe what actions need to be taken at
      install or deinstall time.

    * Implement support for the SVR4 package flavor.  This will be
      proof that the appropriate abstractions are in place to allow
      using a completely different set of package management tools.

Revision 1.33 / (download) - annotate - [select for diffs], Thu May 25 11:00:39 2006 UTC (12 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.32: +1 -13 lines
Diff to previous 1.32 (colored)

No package is using USE_RMAN any longer, remove it.

Revision 1.32 / (download) - annotate - [select for diffs], Thu Apr 13 18:23:36 2006 UTC (12 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.31: +1 -7 lines
Diff to previous 1.31 (colored)

BUILD_USE_MSGFMT and USE_MSGFMT_PLURALS are obsolete.  Replace with
USE_TOOLS+=msgfmt.

Revision 1.31 / (download) - annotate - [select for diffs], Thu Apr 13 16:35:58 2006 UTC (12 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.30: +3 -4 lines
Diff to previous 1.30 (colored)

Overhaul the way packages can ask for "msgfmt".  If a package needs
msgfmt, then it should set the following in the package Makefile:

	USE_TOOLS+=	msgfmt

To deal with message files that use the "msgid_plural" statement,
which isn't supported in NetBSD<=3.x and also in gettext<=0.10.35, we
determine if the built-in "msgfmt" is sufficiently new enough to
understand "msgid_plural".  If it isn't, then we use the msgfmt.sh
script to transform the msgid_plural statements to an equivalent
construct that's understood by older msgfmt tools.

The msgfmt.sh script is a straightforward translation of the original
perl script msgfmt.pl script by Julio M. Merino Vidal into shell and
awk, which are more lightweight dependencies than perl.

We remove the USE_MSGFMT_PLURALS bits in gettext-lib/builtin.mk as they
are made obsolete by the new code in mk/tools/msgfmt.mk.

BUILD_USE_MSGFMT is still supported but will be removed in a separate
commit.

Revision 1.30 / (download) - annotate - [select for diffs], Sat Mar 11 04:01:27 2006 UTC (13 years ago) by reed
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

BUILD_DEPENDS on gettext-tools not gettext for BUILD_USES_MSGFMT.

Revision 1.29 / (download) - annotate - [select for diffs], Thu Mar 9 00:20:27 2006 UTC (13 years ago) by jlam
Branch: MAIN
Changes since 1.28: +1 -9 lines
Diff to previous 1.28 (colored)

Reimplement the info-file handling so that we use an +INFO_FILES
scriptlet to manage the info-file registration.  The new scriptlet's
template is install/info-files.  Remove obsolete texinfo.mk and
install/install-info.

No changes to package Makefiles are necessary -- the re-implementation
is internal to pkgsrc infrastructure.

Revision 1.28 / (download) - annotate - [select for diffs], Sun Mar 5 16:27:29 2006 UTC (13 years ago) by jlam
Branch: MAIN
Changes since 1.27: +3 -4 lines
Diff to previous 1.27 (colored)

* Teach the tools framework how to supply the pkgsrc version of
  makeinfo if no native makeinfo executable exists.  Honor TEXINFO_REQD
  when determining whether the native makeinfo can be used.

* Remove USE_MAKEINFO and replace it with USE_TOOLS+=makeinfo.

* Get rid of all the "split" argument deduction for makeinfo since
  the PLIST module already handles varying numbers of split info files
  correctly.

NOTE: Platforms that have "makeinfo" in the base system should check
      that the makeinfo entries of pkgsrc/mk/tools.${OPSYS}.mk are
      correct.

Revision 1.27 / (download) - annotate - [select for diffs], Thu Jan 12 19:05:06 2006 UTC (13 years, 2 months ago) by joerg
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Require xpkgwedge 1.15.

Revision 1.26 / (download) - annotate - [select for diffs], Thu Jan 12 18:39:13 2006 UTC (13 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

Don't ever depend on xpkgwedge if we're building xpkgwedge.

Revision 1.25 / (download) - annotate - [select for diffs], Mon Dec 5 22:07:07 2005 UTC (13 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.24: +15 -15 lines
Diff to previous 1.24 (colored)

Applied all quoting fixes found by "pkglint --autofix".

Revision 1.24 / (download) - annotate - [select for diffs], Sun Dec 4 01:44:30 2005 UTC (13 years, 3 months ago) by joerg
Branch: MAIN
Changes since 1.23: +3 -1 lines
Diff to previous 1.23 (colored)

Add IMAKE_GAMEMAN_SUFFIX and IMAKE_GAMEMAN_DIR to allow PLISTs
to pick up the correct locations.

XXX Default values are guessed, x11/xsnow can be used for testing

Revision 1.23 / (download) - annotate - [select for diffs], Wed Sep 21 20:37:01 2005 UTC (13 years, 5 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

Bump LIBTOOL_REQD to 1.5.18nb5.  This pulls in the -avoid-version fix for
some platforms, which includes all non-ELFs and many ELF-like platforms
(that still use a.out naming conventions).

Since a branch is coming, bump the version in a blanket rather than per
platform.

Revision 1.22 / (download) - annotate - [select for diffs], Tue Jul 19 23:01:55 2005 UTC (13 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.21: +3 -2 lines
Diff to previous 1.21 (colored)

Tools that are marked with ":pkgsrc" are needed very early on, probably
too early for pkgsrc to adequately cope.  In this case, imake-check.mk
was marking "imake" as a tool that was used to perform some tests.
This was causing xpkgwedge to be unnecessarily marked as a build
dependency since using imake in pkgsrc pretty much requires xpkgwedge.
However, in the case where we are running the "imake checks", we don't
need xpkgwedge around.

Solve this issue by marking all the tools in imake-check.mk with
":pkgsrc", and modify the xpkgwedge dependency test to not care about
"imake:pkgsrc".

Revision 1.21 / (download) - annotate - [select for diffs], Thu Jun 23 18:41:57 2005 UTC (13 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Clean up some clutter in pkgsrc/mk: move the ${OPSYS}.*.dist mtree
files into mk/platform, where they now live with the ${OPSYS}.mk files.

Revision 1.20 / (download) - annotate - [select for diffs], Tue Jun 14 20:14:50 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Require xpkgwedge>=1.14 so that the correct make is always invoked on
Solaris and Linux, regardless of whether we use the same make to build
the software or not.

Revision 1.19 / (download) - annotate - [select for diffs], Tue Jun 14 20:04:36 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.18: +4 -2 lines
Diff to previous 1.18 (colored)

We need xpkgwedge whenever we use imake.

Revision 1.18 / (download) - annotate - [select for diffs], Tue Jun 14 07:25:24 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Require xpkgwedge>=1.13 when used as a build dependency so that the
correct make(1) program is invoked by pkgxmkmf.

Revision 1.17 / (download) - annotate - [select for diffs], Tue Jun 14 02:09:38 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.16: +6 -3 lines
Diff to previous 1.16 (colored)

We only need to set USE_X11BASE, run install.man, and override the
compiler (CC/CXX) if we're actually using imake to generate Makefiles
for building and installing software.  This fixes errors in various
KDE-3.x packages that use imake for other purposes.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Jun 1 18:03:05 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.15: +2 -9 lines
Diff to previous 1.15 (colored)

Massive cleanup of buildlink3.mk and builtin.mk files in pkgsrc.
Several changes are involved since they are all interrelated.  These
changes affect about 1000 files.

The first major change is rewriting bsd.builtin.mk as well as all of
the builtin.mk files to follow the new example in bsd.builtin.mk.
The loop to include all of the builtin.mk files needed by the package
is moved from bsd.builtin.mk and into bsd.buildlink3.mk.  bsd.builtin.mk
is now included by each of the individual builtin.mk files and provides
some common logic for all of the builtin.mk files.  Currently, this
includes the computation for whether the native or pkgsrc version of
the package is preferred.  This causes USE_BUILTIN.* to be correctly
set when one builtin.mk file includes another.

The second major change is teach the builtin.mk files to consider
files under ${LOCALBASE} to be from pkgsrc-controlled packages.  Most
of the builtin.mk files test for the presence of built-in software by
checking for the existence of certain files, e.g. <pthread.h>, and we
now assume that if that file is under ${LOCALBASE}, then it must be
from pkgsrc.  This modification is a nod toward LOCALBASE=/usr.  The
exceptions to this new check are the X11 distribution packages, which
are handled specially as noted below.

The third major change is providing builtin.mk and version.mk files
for each of the X11 distribution packages in pkgsrc.  The builtin.mk
file can detect whether the native X11 distribution is the same as
the one provided by pkgsrc, and the version.mk file computes the
version of the X11 distribution package, whether it's built-in or not.

The fourth major change is that the buildlink3.mk files for X11 packages
that install parts which are part of X11 distribution packages, e.g.
Xpm, Xcursor, etc., now use imake to query the X11 distribution for
whether the software is already provided by the X11 distribution.
This is more accurate than grepping for a symbol name in the imake
config files.  Using imake required sprinkling various builtin-imake.mk
helper files into pkgsrc directories.  These files are used as input
to imake since imake can't use stdin for that purpose.

The fifth major change is in how packages note that they use X11.
Instead of setting USE_X11, package Makefiles should now include
x11.buildlink3.mk instead.  This causes the X11 package buildlink3
and builtin logic to be executed at the correct place for buildlink3.mk
and builtin.mk files that previously set USE_X11, and fixes packages
that relied on buildlink3.mk files to implicitly note that X11 is
needed.  Package buildlink3.mk should also include x11.buildlink3.mk
when linking against the package libraries requires also linking
against the X11 libraries.  Where it was obvious, redundant inclusions
of x11.buildlink3.mk have been removed.

Revision 1.15 / (download) - annotate - [select for diffs], Sun May 22 19:11:12 2005 UTC (13 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.14: +1 -27 lines
Diff to previous 1.14 (colored)

Remove the old tools framework and references to _USE_NEW_TOOLS.

Revision 1.14 / (download) - annotate - [select for diffs], Wed May 18 22:42:07 2005 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.13: +8 -47 lines
Diff to previous 1.13 (colored)

Goal:	Remove USE_PERL5 from pkgsrc.
Plan:
	(1) Change USE_PERL5=build into USE_TOOLS+=perl.
	(2) Change all other USE_PERL5 into including perl5/buildlink3.mk.

Possibly, for packages that don't actually build anything with perl,
but merely require it for the perl interpreter, we can instead do:

	USE_TOOLS+=		perl
	TOOLS_DEPMETHOD.perl=	DEPENDS

but this is more verbose than simply including the perl5/buildlink3.mk
file.

Move the PERL5_REQD computation into a lang/perl5/version.mk file,
and only do the USE_PERL5 logic in bsd.pkg.use.mk if we're not using
the new tools framework.  This consolidates all of the perl-handling
into two places -- lang/perl5 and mk/tools/perl.mk.

Revision 1.13 / (download) - annotate - [select for diffs], Wed May 18 14:41:50 2005 UTC (13 years, 10 months ago) by tv
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Since there may have been merge errors in libtool-base 1.5.18, force
LIBTOOL_REQD to 1.5.18nb1.

Revision 1.12 / (download) - annotate - [select for diffs], Tue May 17 22:49:55 2005 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.11: +6 -2 lines
Diff to previous 1.11 (colored)

If USE_TOOLS has "perl" then also define PERL5_PKGSRCDIR for use by
mk/tools/perl.mk.  This fixes broken dependencies on perl where the
path to the package wasn't defined.

Revision 1.11 / (download) - annotate - [select for diffs], Tue May 17 22:22:52 2005 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Make USE_TOOLS+=imake imply USE_X11BASE=yes, along with the other
variable definitions that apply when USE_IMAKE is defined.

Revision 1.1.2.10 / (download) - annotate - [select for diffs], Tue May 17 18:29:44 2005 UTC (13 years, 10 months ago) by tv
Branch: tv-derecurse
CVS Tags: tv-derecurse-eol
Changes since 1.1.2.9: +6 -16 lines
Diff to previous 1.1.2.9 (colored) to branchpoint 1.1 (colored)

sync [all but bsd.pkg.mk] with HEAD

Revision 1.10 / (download) - annotate - [select for diffs], Thu May 12 21:03:46 2005 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: tv-derecurse-merge
Changes since 1.9: +3 -1 lines
Diff to previous 1.9 (colored)

Teach the new tools framework more about perl.  We include perl5/vars.mk
in mk/tools/perl.mk since many packages expect to be able to use the
variables defined in vars.mk, but those variables can only be defined
if PERL5 is correctly defined, and that is only true after it is set
here.

Revision 1.9 / (download) - annotate - [select for diffs], Thu May 12 20:31:56 2005 UTC (13 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.8: +2 -6 lines
Diff to previous 1.8 (colored)

Don't check for whether variables are defined or not before adding
them to PLIST_SUBST.  They may simply be defined later on in the
Makefile processing.  Instead check whether USE_PERL5 was specified
to determine whether to pass along PERL5_{SITEARCH,SITELIB,ARCHLIB}
to PLIST_SUBST.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Apr 9 23:16:45 2005 UTC (13 years, 11 months ago) by markd
Branch: MAIN
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

Sense of a USE_BUILDLINK3 test was reversed when USE_BUILDLINK3 was
switched on always, resulting in instances of X11R6/lib libraries being
linked in to binaries along with pkgsrc versions of the same. Fix.

Revision 1.7 / (download) - annotate - [select for diffs], Thu Mar 24 17:46:00 2005 UTC (13 years, 11 months ago) by tv
Branch: MAIN
Changes since 1.6: +2 -6 lines
Diff to previous 1.6 (colored)

USE_BUILDLINK3 is no longer optional (and cannot be turned off).  Per mail
to tech-pkg:

=====

* USE_BUILDLINK3=YES will be unconditional.  (In fact, USE_BUILDLINK3 will
  be ignored altogether by mk/; but see below.)

* NO_BUILDLINK and NO_WRAPPER will be ignored by mk/.  If a build happens,
  these phases will happen.

* The existing NO_BUILD will imply the previous NO_BUILDLINK and NO_WRAPPER.
  If no build happens, those phases are not needed.

* NO_TOOLS will be ignored by mk/.  The tools phase, which provides much
  more than just the C compiler, will always happen regardless of package.
  This will make metapackage builds only slightly slower, in trade for far
  less user error.

Revision 1.6 / (download) - annotate - [select for diffs], Tue Mar 22 15:40:06 2005 UTC (14 years ago) by tv
Branch: MAIN
Changes since 1.5: +2 -5 lines
Diff to previous 1.5 (colored)

Bump LIBTOOL_REQD to 1.5.14; this unifies all the support again and fixes
a good number of bugs.

Revision 1.1.2.9 / (download) - annotate - [select for diffs], Fri Feb 25 14:46:51 2005 UTC (14 years ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.8: +8 -27 lines
Diff to previous 1.1.2.8 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.5 / (download) - annotate - [select for diffs], Thu Feb 24 22:38:42 2005 UTC (14 years ago) by jlam
Branch: MAIN
CVS Tags: tv-derecurse-base, pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.4: +8 -27 lines
Diff to previous 1.4 (colored)

* Teach devel/p5-Module-Build to write .packlists just like MakeMaker.pm
  does.  This allows us to use dynamic PLISTs for Perl modules that are
  built using Module::Build.  Bump the PKGREVISION of p5-Module-Build
  to 1.

* Drop the use of PERL5_USES_MODULE_BUILD and introduce a new variable
  PERL5_MODULE_TYPE that is either "MakeMaker" or "Module::Build" that
  names the framework used to build/install the module.

* Split out the variables set in perl5/buildlink3.mk that are also used
  by perl5/module.mk into a new file perl5/vars.mk.  Move some PERL5_*
  variable definitions from pkgsrc/mk/bsd.pkg.use.mk into perl5/vars.mk.
  This just centralizes the common PERL5_* definitions into a single
  file location.

* Convert the known packages that use Module::Build to set
  PERL5_MODULE_TYPE and PERL5_PACKLIST:

	devel/p5-Class-Container
	devel/p5-Exception-Class
	devel/p5-Log-Dispatch
	devel/p5-Array-Compare
	textproc/p5-Pod-Coverage
	www/p5-Apache-Session-Wrapper
	www/p5-MasonX-Request-WithApacheSession

Revision 1.4 / (download) - annotate - [select for diffs], Fri Feb 11 16:15:53 2005 UTC (14 years, 1 month ago) by tv
Branch: MAIN
Changes since 1.3: +82 -0 lines
Diff to previous 1.3 (colored)

Migrate the big block of USE_PERL5 and PERL5_REQD logic to bsd.pkg.use.mk.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 11 16:11:36 2005 UTC (14 years, 1 month ago) by tv
Branch: MAIN
Changes since 1.2: +88 -0 lines
Diff to previous 1.2 (colored)

Migrate several USE_* logic blocks, previously sprinkled liberally
throughout bsd.pkg.mk, to labelled blocks in bsd.pkg.use.mk.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Feb 11 15:55:13 2005 UTC (14 years, 1 month ago) by tv
Branch: MAIN
Changes since 1.1: +53 -0 lines
Diff to previous 1.1 (colored)

Merge down some more visual cleanup from tv-derecurse to reduce divergence.

Part of this, introduce bsd.pkg.use.mk, where the Special Logic invoked
by various pkgsrc-wide USE_* variables will be migrated/consolidated.

Revision 1.1.2.8 / (download) - annotate - [select for diffs], Fri Feb 11 15:27:57 2005 UTC (14 years, 1 month ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.7: +0 -3 lines
Diff to previous 1.1.2.7 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.7 / (download) - annotate - [select for diffs], Thu Jan 13 20:20:35 2005 UTC (14 years, 2 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.6: +1 -29 lines
Diff to previous 1.1.2.6 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.6 / (download) - annotate - [select for diffs], Thu Jan 13 20:11:55 2005 UTC (14 years, 2 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.5: +2 -0 lines
Diff to previous 1.1.2.5 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.5 / (download) - annotate - [select for diffs], Mon Jan 10 16:15:25 2005 UTC (14 years, 2 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.4: +0 -4 lines
Diff to previous 1.1.2.4 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.4 / (download) - annotate - [select for diffs], Fri Dec 31 20:25:30 2004 UTC (14 years, 2 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.3: +1 -0 lines
Diff to previous 1.1.2.3 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.3 / (download) - annotate - [select for diffs], Mon Dec 20 20:46:00 2004 UTC (14 years, 3 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.2: +5 -5 lines
Diff to previous 1.1.2.2 (colored) to branchpoint 1.1 (colored)

sync with HEAD

Revision 1.1.2.2 / (download) - annotate - [select for diffs], Sun Nov 28 20:11:32 2004 UTC (14 years, 3 months ago) by tv
Branch: tv-derecurse
Changes since 1.1.2.1: +0 -10 lines
Diff to previous 1.1.2.1 (colored) to branchpoint 1.1 (colored)

Merge from HEAD.

Revision 1.1.2.1 / (download) - annotate - [select for diffs], Mon Nov 22 22:48:05 2004 UTC (14 years, 3 months ago) by tv
Branch: tv-derecurse
Changes since 1.1: +265 -0 lines
Diff to previous 1.1 (colored)

So that I don't lose all this work, stash the work-in-progress derecursion
cleanup onto the tv-derecurse branch (only branched in pkgsrc/mk).

Revision 1.1, Mon Nov 22 22:48:05 2004 UTC (14 years, 3 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Branch point for: tv-derecurse
FILE REMOVED

file bsd.pkg.use.mk was initially added on branch tv-derecurse.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>