[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / zyGrib

File: [cvs.NetBSD.org] / pkgsrc / misc / zyGrib / Makefile (download)

Revision 1.18, Fri Jun 17 15:57:13 2011 UTC (12 years, 10 months ago) by plunky
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.17: +32 -15 lines



update to zyGrib version 4.0.1:


# 2011-05-21 : zyGrib Version 4.0.1

    * User can choose visible data in the left board (right clic in the panel).
    * Bug fixed: crash sometimes with data out of the "normal" range.

# 2011-05-08 : zyGrib Version 4.0

    * NOAA data up to 8 days rather than 7.
    * Color scales.
    * Data values panel can be hidden (Ctrl+V).
    * Colors scale panel can be hidden (Ctrl+Y).
    * Warning : changes in directories structure.
    * Totally new colors scheme.
      Color scales are editable (text files colors_xxx.txt).
          o 1 ligne per threshold : v r g b
            v = threshold value
            r g b = rgb level (red, green, blue) between 0 and 255
          o values must be in ascending order
          o color is attributed to values ##less than or equal to v
            except the last which is also the color of all excess values##
          o fixed color (no interpolation) below the first value or above the last.
    * More complete list of cities (source GeoNames)
      Around 60,000 cities come with zygrib (population >= 3000).
      Around 100,000 smaller cities are available in additional files (see download page).
    * New population threshold for shown cities:
         1. population >= 1000000
         2. population >= 100000
         3. population >= 10000
         4. population >= 1000
         5. population < 1000
    * Bug fixed : values displayed for the position under the mouse are updated when the date is changed using the keyboard.
    * Bug fixed : crash (sometimes) when the mouse was moved on a POI while reading aa grib file.

# $NetBSD: Makefile,v 1.18 2011/06/17 15:57:13 plunky Exp $
#

DISTNAME=	zyGrib-4.0.1
CATEGORIES=	misc
MASTER_SITES=	http://www.zygrib.org/getfile.php?file=
EXTRACT_SUFX=	.tgz

MAINTAINER=	plunky@rya-online.net
HOMEPAGE=	http://www.zygrib.org/
COMMENT=	GRIB file viewer for weather data
LICENSE=	gnu-gpl-v3

DEPENDS+=	liberation-ttf-[0-9]*:../../fonts/liberation-ttf

WRKSRC=		${WRKDIR}/${DISTNAME}/src
USE_LANGUAGES=	c c++
USE_TOOLS+=	make

CONFIGURE_ENV+=	QTDIR=${QTDIR}

PKG_DESTDIR_SUPPORT=	user-destdir

SUBST_CLASSES+=		paths
SUBST_STAGE.paths=	post-patch
SUBST_MESSAGE.paths=	Fixing shared data paths.
SUBST_FILES.paths=	util/Util.h
SUBST_SED.paths+=	-e "s|\"data/|\"${PREFIX}/share/zyGrib/|"

INSTALLATION_DIRS+=	bin
INSTALLATION_DIRS+=	share/zyGrib/colors
INSTALLATION_DIRS+=	share/zyGrib/config
INSTALLATION_DIRS+=	share/zyGrib/gis
INSTALLATION_DIRS+=	share/zyGrib/img
INSTALLATION_DIRS+=	share/zyGrib/maps/gshhs
INSTALLATION_DIRS+=	share/zyGrib/stuff
INSTALLATION_DIRS+=	share/zyGrib/tr

INSTALL_FILES+=	colors/colors_binary.txt
INSTALL_FILES+=	colors/colors_cape_jkg.txt
INSTALL_FILES+=	colors/colors_clouds_black_pc.txt
INSTALL_FILES+=	colors/colors_clouds_white_pc.txt
INSTALL_FILES+=	colors/colors_deltatemp_celcius.txt
INSTALL_FILES+=	colors/colors_humidrel_pc.txt
INSTALL_FILES+=	colors/colors_rain_mmh.txt
INSTALL_FILES+=	colors/colors_snowdepth_m.txt
INSTALL_FILES+=	colors/colors_temp_celcius.txt
INSTALL_FILES+=	colors/colors_wind_kts.txt
INSTALL_FILES+=	gis/cities_10k-more.txt.gz
INSTALL_FILES+=	gis/cities_3k-10k.txt.gz
INSTALL_FILES+=	gis/countries_en.txt.gz
INSTALL_FILES+=	gis/countries_fr.txt.gz
INSTALL_FILES+=	img/1leftarrow.png
INSTALL_FILES+=	img/1rightarrow.png
INSTALL_FILES+=	img/2leftarrow.png
INSTALL_FILES+=	img/2rightarrow.png
INSTALL_FILES+=	img/anim.png
INSTALL_FILES+=	img/back.png
INSTALL_FILES+=	img/connect_no.png
INSTALL_FILES+=	img/down.png
INSTALL_FILES+=	img/drapeau_cz.png
INSTALL_FILES+=	img/drapeau_de.png
INSTALL_FILES+=	img/drapeau_en.png
INSTALL_FILES+=	img/drapeau_es.png
INSTALL_FILES+=	img/drapeau_fr.png
INSTALL_FILES+=	img/drapeau_it.png
INSTALL_FILES+=	img/drapeau_nl.png
INSTALL_FILES+=	img/drapeau_pt.png
INSTALL_FILES+=	img/drapeau_ru.png
INSTALL_FILES+=	img/exit.png
INSTALL_FILES+=	img/fileclose.png
INSTALL_FILES+=	img/fileopen.png
INSTALL_FILES+=	img/forward.png
INSTALL_FILES+=	img/help.png
INSTALL_FILES+=	img/info.png
INSTALL_FILES+=	img/media-floppy.png
INSTALL_FILES+=	img/meteoblue.png
INSTALL_FILES+=	img/network.png
INSTALL_FILES+=	img/player_eject.png
INSTALL_FILES+=	img/player_end.png
INSTALL_FILES+=	img/player_fwd.png
INSTALL_FILES+=	img/player_pause.png
INSTALL_FILES+=	img/player_play.png
INSTALL_FILES+=	img/player_playlist.png
INSTALL_FILES+=	img/player_rew.png
INSTALL_FILES+=	img/player_start.png
INSTALL_FILES+=	img/player_stop.png
INSTALL_FILES+=	img/reload.png
INSTALL_FILES+=	img/resource.rc
INSTALL_FILES+=	img/up.png
INSTALL_FILES+=	img/viewmag+.png
INSTALL_FILES+=	img/viewmag-.png
INSTALL_FILES+=	img/viewmag1.png
INSTALL_FILES+=	img/viewmagfit.png
INSTALL_FILES+=	img/zyGrib.icns
INSTALL_FILES+=	img/zyGrib_32.ico
INSTALL_FILES+=	img/zyGrib_32.xpm
INSTALL_FILES+=	maps/gshhs/README.gshhs
INSTALL_FILES+=	maps/gshhs/README.gshhs.rangs
INSTALL_FILES+=	maps/gshhs/gshhs_2.rim
INSTALL_FILES+=	maps/gshhs/gshhs_3.rim
INSTALL_FILES+=	maps/gshhs/gshhs_4.rim
INSTALL_FILES+=	maps/gshhs/rangs_2.cat
INSTALL_FILES+=	maps/gshhs/rangs_2.cel
INSTALL_FILES+=	maps/gshhs/rangs_3.cat
INSTALL_FILES+=	maps/gshhs/rangs_3.cel
INSTALL_FILES+=	maps/gshhs/rangs_4.cat
INSTALL_FILES+=	maps/gshhs/rangs_4.cel
INSTALL_FILES+=	maps/gshhs/wdb_borders_c.b
INSTALL_FILES+=	maps/gshhs/wdb_borders_i.b
INSTALL_FILES+=	maps/gshhs/wdb_borders_l.b
INSTALL_FILES+=	maps/gshhs/wdb_rivers_c.b
INSTALL_FILES+=	maps/gshhs/wdb_rivers_i.b
INSTALL_FILES+=	maps/gshhs/wdb_rivers_l.b
INSTALL_FILES+=	stuff/boat_parameters.csv
INSTALL_FILES+=	tr/zyGrib_cz.qm
INSTALL_FILES+=	tr/zyGrib_cz.ts
INSTALL_FILES+=	tr/zyGrib_de.qm
INSTALL_FILES+=	tr/zyGrib_de.ts
INSTALL_FILES+=	tr/zyGrib_es.qm
INSTALL_FILES+=	tr/zyGrib_es.ts
INSTALL_FILES+=	tr/zyGrib_fr.qm
INSTALL_FILES+=	tr/zyGrib_fr.ts
INSTALL_FILES+=	tr/zyGrib_it.qm
INSTALL_FILES+=	tr/zyGrib_it.ts
INSTALL_FILES+=	tr/zyGrib_nl.qm
INSTALL_FILES+=	tr/zyGrib_nl.ts
INSTALL_FILES+=	tr/zyGrib_ru.qm
INSTALL_FILES+=	tr/zyGrib_ru.ts

do-configure:
	cd ${WRKSRC} && ${QTDIR}/bin/qmake

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/zyGrib ${DESTDIR}${PREFIX}/bin
.for f in ${INSTALL_FILES}
	${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/data/${f} ${DESTDIR}${PREFIX}/share/zyGrib/${f}
.endfor

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../geography/proj/buildlink3.mk"
.include "../../x11/qt4-libs/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk"
.include "../../x11/qwt-qt4/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"