[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / xdg-dirs

File: [cvs.NetBSD.org] / pkgsrc / misc / xdg-dirs / Attic / Makefile (download)

Revision 1.17, Thu Oct 25 22:01:02 2007 UTC (16 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.16: +2 -1 lines

* If PLIST_SRC is explicitly set to an empty value in a package Makefile,
  then automatically generate a PLIST that says "${PKGNAME} has no files".

* If PLIST_SRC and GENERATE_PLIST are not set in a package Makefile,
  and no PLIST files exist, then fail during the package build with
  PKG_FAIL_REASON.

* Remove "intentionally empty" PLISTs again.

Now, the easy way to say that a package installs no files is to just
add the following to the package Makefile:

	PLIST_SRC=	# empty

# $NetBSD: Makefile,v 1.17 2007/10/25 22:01:02 jlam Exp $
#

DISTNAME=	xdg-dirs-1.4
CATEGORIES=	misc gnome kde
MASTER_SITES=	# empty
DISTFILES=	# empty

MAINTAINER=	jmmv@NetBSD.org
HOMEPAGE=	# empty
COMMENT=	Shared XDG directories

PKG_DESTDIR_SUPPORT=	user-destdir

CONFLICTS=	gnome2-dirs<=1.2

NO_BUILD=	yes
NO_CONFIGURE=	yes
NO_CHECKSUM=	yes
NO_EXTRACT=	yes
PLIST_SRC=	# empty
USE_LANGUAGES=	# empty
WRKSRC=		${WRKDIR}

.include "dirs.mk"
.include "../../mk/bsd.prefs.mk"

REQD_DIRS+=	${XDG_DIRS:O:S/^/${PREFIX}\//}

do-install:	# nothing

.include "../../mk/bsd.pkg.mk"