[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / tmux

File: [cvs.NetBSD.org] / pkgsrc / misc / tmux / Makefile (download)

Revision 1.28, Sat May 16 20:27:49 2015 UTC (8 years, 10 months ago) by ryoon
Branch: MAIN
Changes since 1.27: +2 -2 lines

Update to 2.0

Changelog:
CHANGES FROM 1.9a to 2.0 6 March 2015

Incompatible Changes
====================

* The choose-list command has been removed.
* 'terminal-overrides' is now a server option, not a session option.
* 'message-limit' is now a server option, not a session option.
* 'monitor-content' option has been removed.
* 'pane_start_path' option has been removed.
* The "info" mechanism which used to (for some commands) provide feedback
  has been removed, and like other commands, they now produce nothing on
  success.

Normal Changes
==============

* tmux can now write an entry to utmp if the library 'utempter' is present
  at compile time.
* set-buffer learned append mode (-a), and a corresponding
  'append-selection' command has been added to copy-mode.
* choose-mode now has the following commands which can be bound:
	- start-of-list
	- end-of-list
	- top-line
	- bottom-line

* choose-buffer now understands UTF-8.
* Pane navigation has changed:
	- The old way of always using the top or left if the choice is ambiguous.
	- The new way of remembering the last used pane is annoying if the
	  layout is balanced and the leftmost is obvious to the user (because
	  clearly if we go right from the top-left in a tiled set of four we want
	  to end up in top-right, even if we were last using the bottom-right).

      So instead, use a combination of both: if there is only one possible
      pane alongside the current pane, move to it, otherwise choose the most
      recently used of the choice.
* 'set-buffer' can now be told to give names to buffers.
* The 'new-session', 'new-window', 'split-window', and 'respawn-pane' commands
  now understand multiple arguments and handle quoting problems correctly.
* 'capture-pane' understands '-S-' to mean the start of the pane, and '-E-' to
  mean the end of the pane.
* Support for function keys beyond F12 has changed.  The following explains:
	- F13-F24 are S-F1 to S-F12
	- F25-F36 are C-F1 to C-F12
	- F37-F48 are C-S-F1 to C-S-F12
	- F49-F60 are M-F1 to M-F12
	- F61-F63 are M-S-F1 to M-S-F3

 Therefore, F13 becomes a binding of S-F1, etc.
* Support using pane id as part of session or window specifier (so % means
  session-of-%1 or window-of-%1) and window id as part of session
  (so @1 means session-of-@1).
* 'copy-pipe' command now understands formats via -F
* 'if-shell'  command now understands formats via -F
* 'split-window' and 'join-window' understand -b to create the pane to the left
  or above the target pane.

# $NetBSD: Makefile,v 1.28 2015/05/16 20:27:49 ryoon Exp $

DISTNAME=	tmux-2.0
CATEGORIES=	misc
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=tmux/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://tmux.sourceforge.net/
COMMENT=	BSD-licensed terminal multiplexer (GNU Screen alternative)
LICENSE=	modified-bsd

GNU_CONFIGURE=	yes
USE_TERMINFO=	yes

.include "../../mk/bsd.prefs.mk"
.include "../../mk/compiler.mk"
.if !empty(MACHINE_PLATFORM:MSunOS-5.1[0-9]-*) && \
    !empty(CC_VERSION:Mgcc-4.[6-9].*)
BUILDLINK_TRANSFORM+=	opt:-D_XPG4_2:-D_XPG6
.endif

.include "../../devel/libevent/buildlink3.mk"
BUILDLINK_API_DEPENDS.libevent+=	libevent>=2.0.10
.include "../../mk/terminfo.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"