The NetBSD Project

CVS log for pkgsrc/misc/ruby-rainbow/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / misc / ruby-rainbow

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.10 / (download) - annotate - [select for diffs], Tue May 2 00:13:04 2023 UTC (4 months, 3 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.9: +4 -4 lines
Diff to previous 1.9 (colored)

misc/ruby-rainbow: update to 3.1.1

3.1.1 (2022-01-11)

* Add screenshot of example in README
* fix: Include all lib/ files

Revision 1.9 / (download) - annotate - [select for diffs], Tue Oct 26 10:59:31 2021 UTC (22 months, 3 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

misc: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (possibly fetched
conditionally?):

./misc/libreoffice/distinfo libreoffice/harfbuzz-2.6.4.tar.xz

Revision 1.8 / (download) - annotate - [select for diffs], Thu Oct 7 14:35:47 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

misc: Remove SHA1 hashes for distfiles

Revision 1.7 / (download) - annotate - [select for diffs], Sat Dec 9 19:31:58 2017 UTC (5 years, 9 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.6: +5 -5 lines
Diff to previous 1.6 (colored)

ruby-rainbow: update to 3.0.0.

Upstream changes (from Changelog.md):

## 3.0.0 (2017-11-29)

* added String refinement
* added new `Rainbow.uncolor` method
* dropped MRI 1.9.3 compatibility
* dropped MRI 2.0 compatibility
* removed Rake dependency

Revision 1.6 / (download) - annotate - [select for diffs], Sat Apr 22 16:39:31 2017 UTC (6 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

Update ruby-rainbow to 2.2.2.

# 2.2.0 (2016-12-27)

* improved Windows support
* added Ruby 2.4 support
* added `bold` alias method for `bright`

# 2.2.1 (2016-12-28)

* fixed gem installation (2.2.0 was a broken release)

# 2.2.2 (2017-04-21)

* added explicit rake dependency to fix installation issue

Revision 1.5 / (download) - annotate - [select for diffs], Tue Mar 15 14:38:07 2016 UTC (7 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

Update ruby-rainbow to 2.1.0.

## 2.1.0 (2016-01-24)

* added X11 color support
* fixed `require` issue when rainbow is used as a dependency in another gem
* improved Windows support

Revision 1.4 / (download) - annotate - [select for diffs], Tue Nov 3 23:49:51 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Add SHA512 digests for distfiles for misc category

Problems found locating distfiles:
	Package colorls: missing distfile ls.tar.gz
	Package molden: missing distfile molden-4.6/molden4.6.tar.gz
	Package softmaker-office-demo: missing distfile ofl06trial.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Mar 9 15:24:07 2014 UTC (9 years, 6 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

Update ruby-rainbow to 2.0.0.

Changelog (per Changelog.md)

## 1.99.2 (2014-01-24)

* bring back ruby 1.8 support

## 2.0.0 (2014-01-24)

* disable string mixin by default

Revision 1.2 / (download) - annotate - [select for diffs], Fri Jan 17 18:16:27 2014 UTC (9 years, 8 months ago) by tsutsui
Branch: MAIN
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Update ruby-rainbow to 1.99.1. Part of PR/48447.

Changelog (per Changelog.md)

## 1.99.0 (2013-12-26)

* preparation for dropping String monkey patching
* `require "rainbow/string"` if you want to use monkey patched String
* introduction of Rainbow() wrapper
* support for MRI 1.8.7, 1.9.2, 1.9.3, 2.0 and 2.1, JRuby and Rubinius
* deprecation of Sickill::Rainbow namespace (use Rainbow.enabled = true instead)

## 1.99.1 (2013-12-28)

* drop support for ruby 1.8
* `require "rainbow/string"` -> `require "rainbow/ext/string"`
* custom rainbow wrapper instances (with separate enabled/disabled state)
* shortcut methods for changing text color (`Rainbow("foo").red`)

Revision 1.1 / (download) - annotate - [select for diffs], Thu May 9 15:53:32 2013 UTC (10 years, 4 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2

PR pkg/47791 orignated by tsutsui@  for tw,
CUI client for twitter written by ruby.

 This is actually following set. But just making package on
net/ruby-tw will pull all these prerequisites.

- misc/ruby-args_parser   args_parser-0.1.4
  Parse ARGV from command line with DSL.

- misc/ruby-hashie	hashie-1.2.0
  Hashie is a small collection of tools that make hashes more powerful.
  Currently includes Mash (Mocking Hash) and Dash (Discrete Hash).

- misc/ruby-parallel	parallel-0.6.4
  Ruby gem to run any kind of code in parallel processes.

- misc/ruby-rainbow	rainbow-1.1.4
  Rainbow extends ruby String class enabling coloring text on ANSI terminals.

- net/ruby-tw		 tw-0.3.9
  Ruby based CUI Twitter client.

- net/ruby-twitter	twitter-4.6.2
  A Ruby interface to the Twitter API.

- net/ruby-userstream	userstream-1.3.0
  UserStream is a simple twitter userstream library.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>