The NetBSD Project

CVS log for pkgsrc/misc/ruby-pry/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / misc / ruby-pry

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.17: download - view: text, markup, annotated - select for diffs
Thu Jan 2 05:36:40 2025 UTC (2 weeks, 3 days ago) by taca
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +4 -4 lines
misc/ruby-pry: update to 0.15.2

0.15.1 (2024-12-24)

Bug Fixes

* Restore Pry.config.ls compatibility (#2335)
* Avoid breaking reading inputs if Prism is not available (#2338)

0.15.2 (2024-12-24)

This release fixes one additional scenario that could happen if Prism was
not available.

Bug Fixes

* Avoid breaking reading input if Prism version is undetectable (#2340)

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon Dec 9 15:21:51 2024 UTC (5 weeks, 6 days ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +4 -4 lines
misc/ruby-pry: update to 0.15.0

0.15.0 (2024-11-15)

Features

* Added support for Reline (#2298)
* Added support for Ruby 3.3 (#2295)
* Added Pry::Input::SimpleStdio for dumb terminals when Reline is in use
  (#2304)
* Remove OpenStruct usage (#2307) (#2309)
* Disable coloring of output when NO_COLOR is set.  (#2323)
* Add pry --no-multiline flag to keep single line prompt.  (#2327)

Bug Fixes

* Fix typos on docs and and comments (#2300) (#2301)
* Fix 'calling clear method' on user code when defined in pry context.
  (#2291)
* Fix arguments WatchExpression#add_expression (#2278)

Breaking changes

* Remove support for deprecated Pry.config.prompt = [proc {}, proc {}]
  Use Pry::Prompt API instead (#2308)
* Remove deprecated Pry.config.exception_whitelist.
  Use Pry.config.unrescued_exceptions instead.  (#2326)

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Jan 15 15:40:21 2023 UTC (2 years ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -4 lines
misc/ruby-pry: update to 0.14.2

0.14.2 (2023-01-09)

Features

* Configure code as a supported editor on Pry::Editor (#2236)
* Added support for Ruby 3.2 (#2263)
* Added support for Ruby 3.1 (#2228)

Bug fixes

* Short circuit eval regexes in finding module definition (#2253)
* Revert "Escape non-printing characters" (#2235)
* Fixed bug where WeirdMethodLocator would fail to find the source of a
  method breaking whereami (#2244)
* Fixed bug where pry would throw an FrozenError when dealing with
  incomplete tokens (#2136)
* Restore --no-history CLI flag functionality (#2196)
* Fixed bug where reading from the _out_ sticky local variable could return
  wrong results (#2201)

Breaking Changes

* Remove support for Ruby 1.9 and JRuby < 9.0 (#2239)

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Oct 26 10:59:31 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
misc: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (possibly fetched
conditionally?):

./misc/libreoffice/distinfo libreoffice/harfbuzz-2.6.4.tar.xz

Revision 1.13: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:35:46 2021 UTC (3 years, 3 months ago) by nia
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +1 -2 lines
misc: Remove SHA1 hashes for distfiles

Revision 1.12: download - view: text, markup, annotated - select for diffs
Tue May 4 16:16:03 2021 UTC (3 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +5 -5 lines
misc/ruby-pry: update to 0.14.1

0.14.1 (April 12, 2021)

Bug fixes

* Fixed bad coloring of some RDoc-style docs (#2182)
* Fixed broken --plugins option. It shows a warning now (#2180)
* Fixed bad output on printing non-visible characters with color codes
  (#2154)
* Fixed bad output when colors are disabled and a string with color codes is
  printed (#2158)

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sat Feb 13 13:58:03 2021 UTC (3 years, 11 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +5 -5 lines
misc/ruby-pry: update to 0.14.0

0.14.0 (February 8, 2021)

Features

* Made ? an alias to show-source -d (#2133)
* Added support for Ruby 3.0

Breaking changes

* Deleted support for plugin autoloading (#2119).  In order to load a Pry
  plugin you must require it from your pryrc or add it to your Gemfile.

	# ~/.pryrc
	require 'pryrc'

Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon Apr 27 15:00:27 2020 UTC (4 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +5 -5 lines
misc/ruby-pry: update to 0.13.1

Update ruby-pry to 0.13.1.


### [v0.13.1][v0.13.1] (April 12, 2020)

#### Bug fixes

* Fixed bug where on invalid input only the last syntax error is displayed
  (instead of all of them) ([#2117](https://github.com/pry/pry/pull/2117))
* Fixed `Pry::Config` raising `NoMethodError` on undefined option instead of
  returning `nil` (usually invoked via `Pry.config.foo_option` calls)
  ([#2126](https://github.com/pry/pry/pull/2126))
* Fixed `help` command not displaying regexp aliases properly
  ([#2120](https://github.com/pry/pry/pull/2120))
* Fixed `pry-backtrace` not working ([#2122](https://github.com/pry/pry/pull/2122))

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri Mar 27 06:07:57 2020 UTC (4 years, 9 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -5 lines
misc/ruby-pryu: commit forgotten files

Commit forgotten files.  Noted by joerg@.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Dec 17 15:02:23 2018 UTC (6 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +5 -5 lines
misc/ruby-pry: update to 0.12.2

pkgsr change:
* Remove @PREFIX@ from ALTERNATIVES file.

### [v0.12.2][v0.12.2] (November 12, 2018)

#### Bug fixes

* Restore removed deprecations, which were removed by accident due to a bad
  rebase.

### [v0.12.1][v0.12.1] (November 12, 2018)

#### Bug fixes

* Stopped creating a new hash each time `Pry::Prompt#[]` is invoked
  ([#1855](https://github.com/pry/pry/pull/1855))
* Fixed `less` pager not working when it's available
  ([#1861](https://github.com/pry/pry/pull/1861))

### [v0.12.0][v0.12.0] (November 5, 2018)

#### Major changes

* Dropped support for Rubinius ([#1785](https://github.com/pry/pry/pull/1785))

#### Features

* Added a new command, `clear-screen`, that clears the content of the screen Pry
  is running in regardless of platform (Windows or UNIX-like)
  ([#1723](https://github.com/pry/pry/pull/1723))
* Added a new command, `gem-stat`, that prints gem statistics such as gem
  dependencies and downloads ([#1707](https://github.com/pry/pry/pull/1707))
* Added support for nested exceptions for the `wtf` command
  ([#1791](https://github.com/pry/pry/pull/1791))
* Added support for dynamic prompt names
  ([#1833](https://github.com/pry/pry/pull/1833))

  ```rb
  # pryrc
  Pry.config.prompt_name = Pry.lazy { rand(100) }

  # Session
  [1] 80(main)>
  [2] 87(main)>
  [3] 30(main)>
  ```
* Added support for XDG Base Directory Specification
  ([#1609](https://github.com/pry/pry/pull/1609),
  [#1844](https://github.com/pry/pry/pull/1844),
  ([#1848](https://github.com/pry/pry/pull/1848)))
* Removed the `simple-prompt`. Use `change-prompt simple` instead. The
  `list-prompt` command was removed and embedded as `change-prompt --list`
  ([#1849](https://github.com/pry/pry/pull/1849))

#### API changes

* The following methods started accepting the new optional `config` parameter
  ([#1809](https://github.com/pry/pry/pull/1809)):
  * `Pry::Helpers.tablify(things, line_length, config = Pry.config)`
  * `Pry::Helpers.tablify_or_one_line(heading, things, config = Pry.config)`
  * `Pry::Helpers.tablify_to_screen_width(things, options, config = Pry.config)`
  * `Pry::Helpers::Table.new(items, args, config = Pry.config)`

  You are expected to pass a session-local `_pry_.config` instead of the global
  one.

* Added new method `Pry::Config.assign`, for creating a Config non-recursively
  ([#1725](https://github.com/pry/pry/issues/1725))
* Added `Pry.lazy`, which is a helper method for values that need to be
  calculated dynamically. Currently, only `config.prompt_name` supports it
  ([#1833](https://github.com/pry/pry/pull/1833))
* `Pry::Prompt` responds to `.[]`, `.all` & `.add` now. The `Pry::Prompt.add`
  method must be used for implementing custom prompts. See the API in the
  documentation for the class ([#1846](https://github.com/pry/pry/pull/1846))

#### Breaking changes

* Deleted the `Pry::Helpers::Text.bright_default` alias for
  `Pry::Helpers::Text.bold` ([#1795](https://github.com/pry/pry/pull/1795))
* `Pry::Helpers.tablify_to_screen_width(things, options, config = Pry.config)`
  requires `options` or `nil` in place of them.
* `Pry::Helpers::Table.new(items, args, config = Pry.config)` requires `args`
  or `nil` in place of them.
* Completely revamped `Pry::HistoryArray`
  ([#1818](https://github.com/pry/pry/pull/1818)).
  * It's been renamed to `Pry::Ring`
    ([#1817](https://github.com/pry/pry/pull/1817))
  * The implementation has changed and as result, the following methods were
    removed:
    * `Pry::Ring#length` (use `Pry::Ring#count` instead)
    * `#empty?`, `#each`, `#inspect`, `#pop!`, `#to_h`
  * To access old Enumerable methods convert the ring to Array with `#to_a`
  * Fixed indexing for elements (e.g. `_pry_.input_ring[0]` always return some
    element and not `nil`)
* Renamed `Pry.config.prompt_safe_objects` to `Pry.config.prompt_safe_contexts`
* Removed deprecated `Pry::CommandSet#before_command` &
  `Pry::CommandSet#after_command` ([#1838](https://github.com/pry/pry/pull/1838))

#### Deprecations

* Deprecated `_pry_.input_array` & `_pry_.output_array` in favour of
  `_pry_.input_ring` & `_pry_.output_ring` respectively
  ([#1814](https://github.com/pry/pry/pull/1814))
* Deprecated `Pry::Command#text`. Please use `#black`, `#white`, etc. directly
  instead (as you would with helper functions from `BaseHelpers` and
  `CommandHelpers`) ([#1701](https://github.com/pry/pry/pull/1701))
* Deprecated `_pry_.input_array` & `_pry_.output_array` in favour of
  `_pry_.input_ring` and `_pry_.output_ring` respectively
  ([#1817](https://github.com/pry/pry/pull/1817))
* Deprecated `Pry::Platform`. Use `Pry::Helpers::Platform` instead. Note that
  `Pry::Helpers::BaseHelpers` still includes the `Platform` methods but emits a
  warning. You must switch to `Pry::Helpers::Platform` in your code
  ([#1838](https://github.com/pry/pry/pull/1838),
  ([#1845](https://github.com/pry/pry/pull/1845)))
* Deprecated `Pry::Prompt::MAP`. You should use `Pry::Prompt.all` instead to
  access the same map ([#1846](https://github.com/pry/pry/pull/1846))

#### Bug fixes

* Fixed a bug where `cd Hash.new` reported `self` as an instance of Pry::Config
  in the prompt ([#1725](https://github.com/pry/pry/pull/1725))
* Silenced the `Could not find files for the given pattern(s)` error message
  coming from `where` on Windows, when `less` or another pager is not installed
  ([#1767](https://github.com/pry/pry/pull/1767))
* Fixed possible double loading of Pry plugins' `cli.rb` on Ruby (>= 2.4) due to
  [the `realpath` changes while invoking
  `require`](https://bugs.ruby-lang.org/issues/10222)
  ([#1762](https://github.com/pry/pry/pull/1762),
  [#1774](https://github.com/pry/pry/pull/1762))
* Fixed `NoMethodError` on code objects that have a comment but no source when
  invoking `show-source` ([#1779](https://github.com/pry/pry/pull/1779))
* Fixed `negative argument (ArgumentError)` upon pasting code with tabs, which
  used to confuse automatic indentation
  ([#1771](https://github.com/pry/pry/pull/1771))
* Fixed Pry not being able to load history on Ruby 2.4.4+ when it contains the
  null character ([#1789](https://github.com/pry/pry/pull/1789))
* Fixed Pry raising errors on `cd`'ing into some objects that redefine
  `method_missing` and `respond_to?`
  ([#1811](https://github.com/pry/pry/pull/1811))
* Fixed bug when indentation leaves parts of input after pressing enter when
  Readline is enabled with mode indicators for vi mode
  ([#1813](https://github.com/pry/pry/pull/1813),
  [#1820](https://github.com/pry/pry/pull/1820),
  [#1825](https://github.com/pry/pry/pull/1825))
* Fixed `edit` not writing to history
  ([#1749](https://github.com/pry/pry/issues/1749))

#### Other changes

* Deprecated the `Data` constant to match Ruby 2.5 in the `ls` command
  ([#1731](https://github.com/pry/pry/pull/1731))

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Mar 14 15:04:44 2018 UTC (6 years, 10 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -5 lines
misc/ruby-pry: update to 0.11.3

pkgsrc change: add support for pkg_alternatives

### HEAD

#### Features

* Add Pry::Testable, an improved modular replacement for PryTestHelpers.
  **breaking change**.

See pull request [#1679](https://github.com/pry/pry/pull/1679).

* Add a new category module: "Pry::Platform". Loosely related to #1668 below.

See pull request [#1670](https://github.com/pry/pry/pull/1670)

* Add `mac_osx?` and `linux?` utility functions to Pry::Helpers::BaseHelpers.

See pull request [#1668](https://github.com/pry/pry/pull/1668).

* Add utility functions for drawing colorised text on a colorised background.

See pull request [#1673](https://github.com/pry/pry/pull/1673).

#### Bug fixes

* Fix a case of infinite recursion in `Pry::Method::WeirdMethodLocator#find_method_in_superclass`
  that users of the [Hanami](http://hanamirb.org/) web framework experienced and
  reported since 2015.

See pull request [#1639](https://github.com/pry/pry/pull/1689).

* Fix a bug where Method objects were not returned for setters inherited
  from a default (Pry::Config::Default). Eg, this is no longer an error:

      pry(main)> d = Pry::Config.from_hash({}, Pry::Config::Default.new)
      pry(main)> d.method(:exception_whitelist=) # Error

See pull request [#1688](https://github.com/pry/pry/pull/1688).

* Do not capture unused Proc objects in Text helper methods `no_color` and `no_paging`,
  for performance reasons. Improve the documentation of both methods.

See pull request [#1691](https://github.com/pry/pry/pull/1691).

* Fix `String#pp` output color.

See pull request [#1674](https://github.com/pry/pry/pull/1674).

### 0.11.0

* Add alias 'whereami[?!]+' for 'whereami' command. ([#1597](https://github.com/pry/pry/pull/1597))
* Improve Ruby 2.4 support ([#1611](https://github.com/pry/pry/pull/1611)):
  * Deprecated constants are hidden from `ls` output by default, use the `-d` switch to see them.
  * Fix warnings that originate in Pry while using the repl.
* Improve completion speed in large applications. ([#1588](https://github.com/pry/pry/pull/1588))
* Pry::ColorPrinter.pp: add `newline` argument and pass it on to PP. ([#1603](https://github.com/pry/pry/pull/1603))
* Use `less` or system pager pager on MS Windows if it is available. ([#1512](https://github.com/pry/pry/pull/1512))
* Add `Pry.configure` as an alternative to the current way of changing configuration options in `.pryrc` files. ([#1502](https://github.com/pry/pry/pull/1502))
* Add `Pry::Config::Behavior#eager_load!` to add a possible workaround for issues like ([#1501](https://github.com/pry/pry/issues/1501))
* Remove Slop as a runtime dependency by vendoring v3.4 as Pry::Slop.
  People can depend on Slop v4 and Pry at the same time without running into version conflicts. ([#1497](https://github.com/pry/pry/issues/1497))
* Fix auto-indentation of code that uses a single-line rescue ([#1450](https://github.com/pry/pry/issues/1450))
* Remove "Pry::Config#refresh", please use "Pry::Config#clear" instead.
* Defining a method called "ls" no longer breaks the "ls" command ([#1407](https://github.com/pry/pry/issues/1407))
* Don't raise when directory permissions don't allow file expansion ([#1432](https://github.com/pry/pry/issues/1432))
* Syntax highlight &lt;tt&gt; tags in documentation output.
* Add support for BasicObject subclasses who implement their own #inspect (#1341)
* Fix 'include RSpec::Matchers' at the top-level (#1277)
* Add 'gem-readme' command, prints the README file bundled with a rubygem
* Add 'gem-search' command, searches for a gem with the rubygems.org HTTP API
* Fixed bug in the `cat` command where it was impossible to use line numbers with files ([#1349](https://github.com/pry/pry/issues/1349))
* Fixed uncaught Errno::EOPNOTSUPP exception when $stdout is a socket ([#1352](https://github.com/pry/pry/issues/1352))
* Display a warning when you cd'ed inside a C object and executed 'show-source' without arguments ([#691](https://github.com/pry/pry/issues/691))
* Make the stagger_output method more reliable by reusing possibly available Pry instance ([#1364](https://github.com/pry/pry/pull/1364))
* Make the 'gem-install' message less confusing by removing backticks ([#1350](https://github.com/pry/pry/pull/1350))
* Fixed error when Pry was trying to load incompatible versions of plugins ([#1312](https://github.com/pry/pry/issues/1312))
* Fixed bug when `hist --clear` led to ArgumentError ([#1340](https://github.com/pry/pry/pull/1340))
* Fixed the "uninitialized constant Pry::ObjectPath::StringScanner" exception during autocomplete ([#1330](https://github.com/pry/pry/issues/1330))
* Secured usage of colours with special characters (RL_PROMPT_START_IGNORE and RL_PROMPT_END_IGNORE) in Pry::Helpers::Text ([#493](https://github.com/pry/pry/issues/493#issuecomment-39232771))
* Fixed regression with `pry -e` when it messes the terminal ([#1387](https://github.com/pry/pry/issues/1387))
* Fixed regression with space prefixes of expressions ([#1369](https://github.com/pry/pry/issues/1369))
* Introduced the new way to define hooks for commands (with `Pry.hooks.add_hook("{before,after}_commandName")`). The old way is deprecated, but still supported (with `Pry.commands.{before,after}_command`) ([#651](https://github.com/pry/pry/issues/651))
* Removed old API's using `Pry::Hooks.from_hash` altogether
* Removed hints on Foreman support (see [this](https://github.com/ddollar/foreman/pull/536))
* Fixed support for the tee command ([#1334](https://github.com/pry/pry/issues/1334))
* Implemented support for CDPATH for ShellCommand ([#1433](https://github.com/pry/pry/issues/1433), [#1434](https://github.com/pry/pry/issues/1434))
* `Pry::CLI.parse_options` does not start Pry anymore ([#1393](https://github.com/pry/pry/pull/1393))
* The gem uses CPU-less platforms for Windows now ([#1410](https://github.com/pry/pry/pull/1410))
* Add `Pry::Config::Memoization` to make it easier to implement your own `Pry::Config::Default` class.([#1503](https://github.com/pry/pry/pull/1503/))
* Lazy load the config defaults for `Pry.config.history` and `Pry.config.gist`.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 17 14:30:35 2016 UTC (8 years, 3 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -5 lines
Update ruby-pry to 0.10.4.

* Clean up warnings.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Dec 12 14:50:16 2015 UTC (9 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -5 lines
Update ruby-pry to 0.10.3.

### 0.10.3

* cherry-pick 0d1d72b and e0e5c75 to fix the install of Pry on Windows.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Nov 3 23:49:51 2015 UTC (9 years, 2 months ago) by agc
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
Add SHA512 digests for distfiles for misc category

Problems found locating distfiles:
	Package colorls: missing distfile ls.tar.gz
	Package molden: missing distfile molden-4.6/molden4.6.tar.gz
	Package softmaker-office-demo: missing distfile ofl06trial.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Oct 4 13:02:20 2015 UTC (9 years, 3 months ago) by taca
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +4 -4 lines
Update ruby-pry to 0.10.2.

### 0.10.2

* cherry-pick c2ed9ec135bd791a32c70fbe05cc0508ea17c4040e from master (fix inf. loop with prepended methods source retrieval)
* Update some specs for recent ruby versions  (2.2+)

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Feb 4 15:33:12 2015 UTC (9 years, 11 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +4 -4 lines
Update ruby-pry to 0.10.1.

Changes are too many to write here, please refer CHANGELOG.md file.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Jun 3 15:08:21 2014 UTC (10 years, 7 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Import misc/ruby-pry into pkgsrc.

Pry is a powerful alternative to the standard IRB shell for Ruby. It
is written from scratch to provide a number of advanced features.

Pry also aims to be more than an IRB replacement; it is an attempt to
bring REPL driven programming to the Ruby language. It is currently
not as powerful as tools like SLIME for lisp, but that is the general
direction Pry is heading.

Pry is also fairly flexible and allows significant user customization
is trivial to set it to read from any object that has a readline
method and write to any object that has a puts method - many other
aspects of Pry are also configurable making it a good choice for
implementing custom shells.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>