[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / raspberrypi-userland

File: [cvs.NetBSD.org] / pkgsrc / misc / raspberrypi-userland / Makefile (download)

Revision 1.16, Sun Nov 3 17:04:26 2019 UTC (4 years, 1 month ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base
Branch point for: pkgsrc-2019Q4
Changes since 1.15: +3 -3 lines

misc: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

# $NetBSD: Makefile,v 1.16 2019/11/03 17:04:26 rillig Exp $
#

DISTNAME=	userland-20170109
PKGREVISION=	3
PKGNAME=	raspberrypi-${DISTNAME}
CATEGORIES=	misc
MASTER_SITES=	${MASTER_SITE_GITHUB:=jaredmcneill/}
GITHUB_PROJECT=	userland
GITHUB_TAG=	734d76b0675685e9ec9148694f2cc00f58e5ebc0

MAINTAINER=	jmcneill@NetBSD.org
HOMEPAGE=	https://github.com/jaredmcneill/userland
COMMENT=	Various libraries for the Raspberry Pi
LICENSE=	modified-bsd

EXTRACT_USING=	bsdtar

ONLY_FOR_PLATFORM=	NetBSD-*-*arm*

USE_LANGUAGES=	c c++

USE_CMAKE=	yes
CMAKE_ARGS+=	-DCMAKE_TOOLCHAIN_FILE=${WRKSRC}/makefiles/cmake/toolchains/arm-netbsdelf.cmake
USE_TOOLS+=	bash:run

SUBST_CLASSES+=		vc
SUBST_STAGE.vc=		pre-configure
SUBST_MESSAGE.vc=	Fixing hard-coded install paths.
SUBST_FILES.vc=		makefiles/cmake/vmcs.cmake
SUBST_SED.vc=		-e 's,/opt/vc,${PREFIX},g'

REPLACE_BASH+=		buildme \
			host_applications/linux/apps/dtoverlay/dtoverlay-post \
			host_applications/linux/apps/dtoverlay/dtoverlay-pre

.include "options.mk"

.include "../../mk/bsd.pkg.mk"