[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / misc / openoffice2

Annotation of pkgsrc/misc/openoffice2/Makefile, Revision 1.24

1.24    ! hira        1: # $NetBSD: Makefile,v 1.23 2007/09/21 13:04:03 wiz Exp $
1.1       hira        2: #
                      3:
1.21      hira        4: OO_VER=                        2.2.1
1.1       hira        5: DISTNAME=              openoffice-${OO_VER}
                      6: PKGNAME=               openoffice2-${OO_VER}
1.24    ! hira        7: PKGREVISION=           3
1.1       hira        8: CATEGORIES=            misc
                      9: MASTER_SITES=          ${MASTER_SITE_OPENOFFICE:=stable/${OO_VER}/}
                     10: DIST_SUBDIR=           ${DISTNAME}
                     11:
1.14      hira       12: DISTFILES=             OOo_${OO_VER}_src_core.tar.bz2
1.1       hira       13: DISTFILES+=            OOo_${OO_VER}_src_binfilter.tar.bz2
1.14      hira       14: DISTFILES+=            OOo_${OO_VER}_src_l10n.tar.bz2
1.1       hira       15: #DISTFILES+=           OOo_${OO_VER}_src_sdk.tar.bz2
                     16: DISTFILES+=            OOo_${OO_VER}_src_system.tar.bz2
                     17: # Missing file from tarball...
                     18: DISTFILES+=            bridge.h
                     19: SITES.bridge.h=                http://www.openoffice.org/source/browse/%2Acheckout%2A/udk/bridges/inc/bridges/cpp_uno/Attic/
                     20:
1.8       hira       21: MAINTAINER=            hira@NetBSD.org
1.1       hira       22: HOMEPAGE=              http://www.openoffice.org/
                     23: COMMENT=               Integrated office productivity suite (version 2)
                     24:
                     25: BUILD_DEPENDS+=                bison-[0-9]*:../../devel/bison
                     26: BUILD_DEPENDS+=                zip-[0-9]*:../../archivers/zip
                     27: BUILD_DEPENDS+=                unzip-[0-9]*:../../archivers/unzip
                     28: BUILD_DEPENDS+=                p5-Archive-Zip-[0-9]*:../../archivers/p5-Archive-Zip
                     29:
1.3       hira       30: .include "../../mk/bsd.prefs.mk"
                     31:
1.21      hira       32: WRKSRC=                        ${WRKDIR}/OOF680_m18
1.7       hira       33: CONFIGURE_DIRS=                config_office
                     34:
1.14      hira       35: # Cannot compile with 3.3.x (GCC Bugzilla Bug 16879).
                     36: GCC_REQD+=             3.4
1.3       hira       37: USE_LANGUAGES+=                c c++
1.1       hira       38:
1.9       hira       39: USE_TOOLS+=            bash gmake imake perl pkg-config tar
1.1       hira       40: PTHREAD_OPTS+=         require
                     41: PTHREAD_AUTO_VARS=     yes
                     42:
                     43: CONFLICTS+=            staroffice-[0-9]*
                     44: CONFLICTS+=            openoffice-[0-9]*
                     45: CONFLICTS+=            openoffice-bin-[0-9]*
                     46: CONFLICTS+=            openoffice2-bin-[0-9]*
                     47: CONFLICTS+=            openoffice-linux-[0-9]*
                     48:
                     49: ONLY_FOR_PLATFORM=     NetBSD-1.6Z[G-Z]*-i386 NetBSD-[2-9]*-i386
                     50:
                     51: GNU_CONFIGURE=         yes
1.15      hira       52: CONFIGURE_ENV+=                X_LIBS=${X11_LDFLAGS:M*:Q}
1.9       hira       53: CONFIGURE_ARGS+=       --with-use-shell=bash
1.1       hira       54: CONFIGURE_ARGS+=       --enable-binfilter
1.9       hira       55: CONFIGURE_ARGS+=       --enable-cairo
1.1       hira       56: CONFIGURE_ARGS+=       --disable-ldap
1.9       hira       57: CONFIGURE_ARGS+=       --with-system-freetype
1.1       hira       58:
                     59: # `portable' supports all platforms.
                     60: CONFIGURE_ARGS+=       --enable-epm --with-package-format=portable
                     61:
                     62: # XXX: Error in OOo internal libsndfile.
1.9       hira       63: CONFIGURE_ARGS+=       --disable-pasf --without-nas
1.1       hira       64:
1.20      hira       65: # systray quickstarter is broken with mutex handling.
                     66: CONFIGURE_ARGS+=       --disable-systray
                     67:
1.1       hira       68: # Disable Java.
                     69: CONFIGURE_ARGS+=       --without-java --disable-odk --disable-gcjaot
                     70:
                     71: # NOTE: In this version, this value should be separated by space (comma
                     72: #       causes build error).
1.15      hira       73: CONFIGURE_ARGS+=       --with-lang=${OO_LANGS:Q}
1.1       hira       74:
                     75: .include "options.mk"
                     76:
                     77: UNLIMIT_RESOURCES+=    datasize
                     78:
1.15      hira       79: OO_RELEASE=            OpenOffice.org${OO_VER}
1.1       hira       80: PLIST_SRC+=            ${WRKDIR}/.PLIST_SRC
1.15      hira       81: MESSAGE_SUBST+=                OO_RELEASE=${OO_RELEASE}
1.1       hira       82: INSTALLATION_DIRS=     bin
                     83:
1.16      hira       84: OO_UNXNAME=    openoffice.org2.2
1.15      hira       85: OO_PKGPATH=    ${WRKSRC}/instsetoo_native/${OPENOFFICE_OUTPATH}.pro/OpenOffice/portable/install
1.16      hira       86: OO_PKGROOT=    /opt/${OO_UNXNAME}
                     87: OO_PROGRAMS=   scalc sdraw simpress soffice swriter unopkg
1.1       hira       88:
                     89: post-extract:
                     90:        ${CP} ${DISTDIR}/${DIST_SUBDIR}/bridge.h                \
1.7       hira       91:                ${WRKSRC}/bridges/inc/bridges/cpp_uno/
1.1       hira       92:
                     93: do-build:
1.19      hira       94:        ${_ULIMIT_CMD} ${SETENV} ${MAKE_ENV} bash -c "cd ${WRKSRC} && ./bootstrap && source ${OPENOFFICE_SETFILE}Env.Set.sh && dmake build_all"
1.1       hira       95:
                     96: post-build:
1.15      hira       97:        cd ${WRKDIR} &&                                         \
                     98:        ${RM} -fr opt &&                                        \
                     99:        for l in ${OO_LANGS}; do                                \
                    100:                for f in ${OO_PKGPATH:Q}/$${l}/*/*.sw; do       \
                    101:                        ${TAR} xpfk $$f;                        \
                    102:                done;                                           \
1.1       hira      103:        done
1.16      hira      104:        ${ECHO} "#!${SH}" > ${WRKDIR}/${OO_UNXNAME}
                    105:        ${ECHO} "exec ${PREFIX}/${OO_RELEASE}/program/soffice \"\$$@\"" \
                    106:                >> ${WRKDIR}/${OO_UNXNAME}
                    107:        ${ECHO} "#!${SH}" > ${WRKDIR}/${OO_UNXNAME}-printeradmin
                    108:        ${ECHO} "exec ${PREFIX}/${OO_RELEASE}/program/spadmin"  \
                    109:                >> ${WRKDIR}/${OO_UNXNAME}-printeradmin
1.1       hira      110:
                    111: do-install:
1.15      hira      112:        ${INSTALL_DATA_DIR} ${PREFIX}/${OO_RELEASE}
                    113:        cd ${WRKDIR}${OO_PKGROOT} &&                            \
                    114:        ${TAR} cf - . | ${TAR} Cxpf ${PREFIX}/${OO_RELEASE} -
                    115:        for f in ${OO_PROGRAMS}; do                             \
                    116:                ${LN} -sf ${PREFIX}/${OO_RELEASE}/program/$$f   \
                    117:                        ${PREFIX}/bin/$$f;                      \
1.1       hira      118:        done
1.16      hira      119:        ${INSTALL_SCRIPT} ${WRKDIR}/${OO_UNXNAME} ${PREFIX}/bin
                    120:        ${INSTALL_SCRIPT} ${WRKDIR}/${OO_UNXNAME}-printeradmin  \
                    121:                ${PREFIX}/bin
1.1       hira      122:
                    123: post-install:
1.15      hira      124:        cd ${PREFIX} &&                                         \
                    125:        ${FIND} ${OO_RELEASE} \! -type d -print |               \
                    126:        ${SORT} > ${PLIST_SRC} &&                               \
                    127:        ${FIND} ${OO_RELEASE} -type d -print | ${SORT} -r |     \
1.1       hira      128:        ${AWK} '{print("@dirrm "$$1)}' >> ${PLIST_SRC}
1.15      hira      129:        for f in ${OO_PROGRAMS}; do                             \
                    130:                ${ECHO} bin/$$f >> ${PLIST_SRC};                \
1.5       hira      131:        done
1.16      hira      132:        ${ECHO} bin/${OO_UNXNAME} >> ${PLIST_SRC}
                    133:        ${ECHO} bin/${OO_UNXNAME}-printeradmin >> ${PLIST_SRC}
1.1       hira      134:
                    135: # everything specific to your OS/Arch goes into its own Makefile
                    136: # group together i386, i486, i586 and i686 (for Linux)
                    137: #
                    138: ARCH=  ${MACHINE_ARCH:C/i[3-6]86/i386/g}
                    139:
                    140: .if exists(Makefile.${OPSYS}.${ARCH})
                    141: .  include "Makefile.${OPSYS}.${ARCH}"
                    142: .endif
                    143:
                    144: .include "../../fonts/fontconfig/buildlink3.mk"
1.12      hira      145: .include "../../graphics/MesaLib/buildlink3.mk"
1.11      hira      146: .include "../../graphics/cairo/buildlink3.mk"
1.1       hira      147: .include "../../graphics/freetype2/buildlink3.mk"
                    148: .include "../../textproc/libxml2/buildlink3.mk"
                    149: .include "../../textproc/libxslt/buildlink3.mk"
                    150: .include "../../x11/libX11/buildlink3.mk"
1.6       abs       151: .include "../../x11/libXaw/buildlink3.mk"
1.1       hira      152: .include "../../x11/libXcursor/buildlink3.mk"
                    153: .include "../../x11/libXext/buildlink3.mk"
                    154: .include "../../x11/libXfixes/buildlink3.mk"
                    155: .include "../../x11/libXi/buildlink3.mk"
                    156: .include "../../x11/libXinerama/buildlink3.mk"
                    157: .include "../../x11/libXrandr/buildlink3.mk"
                    158: .include "../../x11/libXrender/buildlink3.mk"
1.6       abs       159: .include "../../x11/libXt/buildlink3.mk"
1.1       hira      160: .include "../../mk/compiler.mk"
                    161: .include "../../mk/pthread.buildlink3.mk"
                    162: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>